summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-03-06 16:31:16 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-03-06 16:31:16 +0000
commit992edbac9efd5c164f08908ffef1e37f06d98d8d (patch)
tree75aafaf7bb76ce3e51d6b4b02096df819c55d3fd /dev-util/catalyst
parentApparently paxctl is required for pax-marking binaries that will run at build... (diff)
downloadgentoo-2-992edbac9efd5c164f08908ffef1e37f06d98d8d.tar.gz
gentoo-2-992edbac9efd5c164f08908ffef1e37f06d98d8d.tar.bz2
gentoo-2-992edbac9efd5c164f08908ffef1e37f06d98d8d.zip
Revbump catalyst to include 3 patches ACK'd by team, bugs 394461, 395371, 406599
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog15
-rw-r--r--dev-util/catalyst/catalyst-2.0.7.1-r1.ebuild100
-rw-r--r--dev-util/catalyst/files/0001-Add-new-T-purgetmponly-option.patch81
-rw-r--r--dev-util/catalyst/files/0001-add-etc-make.profile-to-cleanables-too.patch25
-rw-r--r--dev-util/catalyst/files/0001-s-etc-make.profile-etc-portage-make.profile-g-Use-ne.patch62
-rw-r--r--dev-util/catalyst/files/0002-s-etc-make.conf-etc-portage-make.conf-g-Use-new-loca.patch262
6 files changed, 543 insertions, 2 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index aa8ecc675040..81253222c19e 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-util/catalyst
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.235 2011/11/19 20:28:00 jmbsvicetto Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.236 2012/03/06 16:31:15 darkside Exp $
+
+*catalyst-2.0.7.1-r1 (06 Mar 2012)
+
+ 06 Mar 2012; Jeremy Olexa <darkside@gentoo.org>
+ +files/0001-Add-new-T-purgetmponly-option.patch,
+ +files/0001-add-etc-make.profile-to-cleanables-too.patch,
+ +files/0002-s-etc-make.conf-etc-portage-make.conf-g-Use-new-loca.patch,
+ +catalyst-2.0.7.1-r1.ebuild,
+ +files/0001-s-etc-make.profile-etc-portage-make.profile-g-Use-ne.patch:
+ Revbump catalyst to include 3 patches ACK'd by team, bugs 394461, 395371,
+ 406599
*catalyst-2.0.7.1 (19 Nov 2011)
diff --git a/dev-util/catalyst/catalyst-2.0.7.1-r1.ebuild b/dev-util/catalyst/catalyst-2.0.7.1-r1.ebuild
new file mode 100644
index 000000000000..a9bf92462960
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.7.1-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.7.1-r1.ebuild,v 1.1 2012/03/06 16:31:15 darkside Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
+# catalyst-VER -> normal catalyst release
+
+EAPI=2
+
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ inherit git-2
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+inherit eutils multilib
+
+DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND="app-text/asciidoc"
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/000*.patch
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ if [[ ${PV} == 9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/0001-Add-new-T-purgetmponly-option.patch b/dev-util/catalyst/files/0001-Add-new-T-purgetmponly-option.patch
new file mode 100644
index 000000000000..6f8492bfa7bc
--- /dev/null
+++ b/dev-util/catalyst/files/0001-Add-new-T-purgetmponly-option.patch
@@ -0,0 +1,81 @@
+From 76f428436777a1217709055126961972194064a8 Mon Sep 17 00:00:00 2001
+From: Jeremy Olexa <darkside@gentoo.org>
+Date: Tue, 28 Feb 2012 21:21:33 +0000
+Subject: [PATCH] Add new -T (--purgetmponly) option
+
+This commit adds a new option to mimic the existing --purgeonly option
+EXCEPT does NOT remove generated PKGCACHE (or binpkgs).
+---
+ catalyst | 6 +++++-
+ modules/generic_stage_target.py | 11 ++++++++---
+ 2 files changed, 13 insertions(+), 4 deletions(-)
+
+diff --git a/catalyst b/catalyst
+index f05a7bc..09856e3 100755
+--- a/catalyst
++++ b/catalyst
+@@ -32,6 +32,7 @@ def usage():
+ print " -h --help print this help message"
+ print " -p --purge clear tmp dirs,package cache and autoresume flags"
+ print " -P --purgeonly clear tmp dirs,package cache and autoresume flags and exit"
++ print " -T --purgetmponly clear tmp dirs and autoresume flags and exit"
+ print " -s --snapshot generate a release snapshot"
+ print " -V --version display version information"
+ print " -v --verbose verbose output"
+@@ -229,7 +230,7 @@ if __name__ == "__main__":
+
+ # parse out the command line arguments
+ try:
+- opts,args = getopt.getopt(sys.argv[1:], "apPhvdc:C:f:FVs:", ["purge", "purgeonly", "help", "version", "debug",\
++ opts,args = getopt.getopt(sys.argv[1:], "apPThvdc:C:f:FVs:", ["purge", "purgeonly", "purgetmponly", "help", "version", "debug",\
+ "clear-autoresume", "config=", "cli=", "file=", "fetch", "verbose","snapshot="])
+
+ except getopt.GetoptError:
+@@ -301,6 +302,9 @@ if __name__ == "__main__":
+ if o in ("-P", "--purgeonly"):
+ conf_values["PURGEONLY"] = "1"
+
++ if o in ("-T", "--purgetmponly"):
++ conf_values["PURGETMPONLY"] = "1"
++
+ if o in ("-a", "--clear-autoresume"):
+ conf_values["CLEAR_AUTORESUME"] = "1"
+
+diff --git a/modules/generic_stage_target.py b/modules/generic_stage_target.py
+index 8aa2075..6039da5 100644
+--- a/modules/generic_stage_target.py
++++ b/modules/generic_stage_target.py
+@@ -1250,6 +1250,10 @@ class generic_stage_target(generic_target):
+ if self.settings.has_key("CLEAR_AUTORESUME"):
+ self.clear_autoresume()
+
++ if self.settings.has_key("PURGETMPONLY"):
++ self.purge()
++ return
++
+ if self.settings.has_key("PURGEONLY"):
+ self.purge()
+ return
+@@ -1642,15 +1646,16 @@ class generic_stage_target(generic_target):
+
+ def purge(self):
+ countdown(10,"Purging Caches ...")
+- if self.settings.has_key("PURGE") or self.settings.has_key("PURGEONLY"):
++ if self.settings.has_key("PURGE") or self.settings.has_key("PURGEONLY") or self.settings.has_key("PURGETMPONLY"):
+ print "clearing autoresume ..."
+ self.clear_autoresume()
+
+ print "clearing chroot ..."
+ self.clear_chroot()
+
+- print "clearing package cache ..."
+- self.clear_packages()
++ if not self.settings.has_key("PURGETMPONLY"):
++ print "clearing package cache ..."
++ self.clear_packages()
+
+ print "clearing kerncache ..."
+ self.clear_kerncache()
+--
+1.7.3.4
+
diff --git a/dev-util/catalyst/files/0001-add-etc-make.profile-to-cleanables-too.patch b/dev-util/catalyst/files/0001-add-etc-make.profile-to-cleanables-too.patch
new file mode 100644
index 000000000000..c6247a2b071f
--- /dev/null
+++ b/dev-util/catalyst/files/0001-add-etc-make.profile-to-cleanables-too.patch
@@ -0,0 +1,25 @@
+From 9eaf6fb3e8fab9b8f8b7087dc6ac2c239597b825 Mon Sep 17 00:00:00 2001
+From: Jeremy Olexa <darkside@gentoo.org>
+Date: Thu, 15 Dec 2011 16:51:12 +0000
+Subject: [PATCH] add /etc/make.profile to cleanables too
+
+---
+ modules/stage3_target.py | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/modules/stage3_target.py b/modules/stage3_target.py
+index 6ebdc49..351ad0c 100644
+--- a/modules/stage3_target.py
++++ b/modules/stage3_target.py
+@@ -22,6 +22,8 @@ class stage3_target(generic_stage_target):
+
+ def set_cleanables(self):
+ generic_stage_target.set_cleanables(self)
++ # Not sure where /etc/make.profile is being created
++ self.settings["cleanables"].extend(["/etc/make.profile"])
+
+ def register(foo):
+ foo.update({"stage3":stage3_target})
+--
+1.7.3.4
+
diff --git a/dev-util/catalyst/files/0001-s-etc-make.profile-etc-portage-make.profile-g-Use-ne.patch b/dev-util/catalyst/files/0001-s-etc-make.profile-etc-portage-make.profile-g-Use-ne.patch
new file mode 100644
index 000000000000..64b03e86c3a8
--- /dev/null
+++ b/dev-util/catalyst/files/0001-s-etc-make.profile-etc-portage-make.profile-g-Use-ne.patch
@@ -0,0 +1,62 @@
+From a800c2e9ce394b076eb4e15ae1cfa9a197e7aabb Mon Sep 17 00:00:00 2001
+From: Jeremy Olexa <darkside@gentoo.org>
+Date: Wed, 7 Dec 2011 15:58:25 +0000
+Subject: [PATCH] s:/etc/make.profile:/etc/portage/make.profile:g - Use new location
+
+Take 2, specify target symlink better and create /etc/portage first
+(fails with stage2 otherwise)
+---
+ modules/generic_stage_target.py | 7 ++++---
+ targets/stage1/stage1-chroot.sh | 2 +-
+ targets/stage1/stage1-controller.sh | 2 +-
+ 3 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/modules/generic_stage_target.py b/modules/generic_stage_target.py
+index 55baea7..6e0bc33 100644
+--- a/modules/generic_stage_target.py
++++ b/modules/generic_stage_target.py
+@@ -813,11 +813,12 @@ class generic_stage_target(generic_target):
+ # TODO: zmedico and I discussed making this a directory and pushing
+ # in a parent file, as well as other user-specified configuration.
+ print "Configuring profile link..."
+- cmd("rm -f "+self.settings["chroot_path"]+"/etc/make.profile",\
++ cmd("rm -f "+self.settings["chroot_path"]+"/etc/portage/make.profile",\
+ "Error zapping profile link",env=self.env)
+- cmd("ln -sf ../usr/portage/profiles/"+\
++ cmd("mkdir "+self.settings["chroot_path"]+"/etc/portage/")
++ cmd("ln -sf ../../usr/portage/profiles/"+\
+ self.settings["target_profile"]+" "+\
+- self.settings["chroot_path"]+"/etc/make.profile",\
++ self.settings["chroot_path"]+"/etc/portage/make.profile",\
+ "Error creating profile link",env=self.env)
+ touch(self.settings["autoresume_path"]+"config_profile_link")
+
+diff --git a/targets/stage1/stage1-chroot.sh b/targets/stage1/stage1-chroot.sh
+index 79f127f..976515d 100644
+--- a/targets/stage1/stage1-chroot.sh
++++ b/targets/stage1/stage1-chroot.sh
+@@ -14,7 +14,7 @@ if [ -z "${clst_buildpkgs}" ]
+ then
+ echo "Your profile seems to be broken."
+ echo "Could not build a list of build packages."
+- echo "Double check your /etc/make.profile link and the 'packages' files."
++ echo "Double check your /etc/portage/make.profile link and the 'packages' files."
+ exit 1
+ fi
+
+diff --git a/targets/stage1/stage1-controller.sh b/targets/stage1/stage1-controller.sh
+index 5625877..1f72067 100644
+--- a/targets/stage1/stage1-controller.sh
++++ b/targets/stage1/stage1-controller.sh
+@@ -13,7 +13,7 @@ case $1 in
+
+ # Setup make.conf and make.profile link in "ROOT in chroot":
+ copy_to_chroot ${clst_chroot_path}/etc/make.conf /${clst_root_path}/etc
+- copy_to_chroot ${clst_chroot_path}/etc/make.profile \
++ copy_to_chroot ${clst_chroot_path}/etc/portage/make.profile \
+ /${clst_root_path}/etc
+
+ # Enter chroot, execute our build script
+--
+1.7.3.4
+
diff --git a/dev-util/catalyst/files/0002-s-etc-make.conf-etc-portage-make.conf-g-Use-new-loca.patch b/dev-util/catalyst/files/0002-s-etc-make.conf-etc-portage-make.conf-g-Use-new-loca.patch
new file mode 100644
index 000000000000..da695e4eeb0d
--- /dev/null
+++ b/dev-util/catalyst/files/0002-s-etc-make.conf-etc-portage-make.conf-g-Use-new-loca.patch
@@ -0,0 +1,262 @@
+From 86b36782d0e5ab6e811dd2d0968b87e4eee38e7d Mon Sep 17 00:00:00 2001
+From: Jeremy Olexa <darkside@gentoo.org>
+Date: Tue, 20 Dec 2011 15:35:16 +0000
+Subject: [PATCH] s:/etc/make.conf:/etc/portage/make.conf:g - Use new location
+
+Tested with stage building only (not livecd)
+---
+ examples/livecd-stage2_template.spec | 2 +-
+ examples/stage4_template.spec | 2 +-
+ modules/generic_stage_target.py | 18 +++++++++---------
+ modules/stage3_target.py | 6 +++++-
+ targets/stage1/stage1-chroot.sh | 12 ++++++------
+ targets/stage1/stage1-controller.sh | 2 +-
+ targets/support/chroot-functions.sh | 16 ++++++++--------
+ targets/support/kmerge.sh | 6 +++---
+ targets/support/livecdfs-update.sh | 12 ++++++------
+ 9 files changed, 40 insertions(+), 36 deletions(-)
+
+diff --git a/examples/livecd-stage2_template.spec b/examples/livecd-stage2_template.spec
+index b957688..18a06a4 100644
+--- a/examples/livecd-stage2_template.spec
++++ b/examples/livecd-stage2_template.spec
+@@ -345,5 +345,5 @@ livecd/empty:
+ # This option tells catalyst to clean specific files from the filesystem and is
+ # very usefu in cleaning up stray files in /etc left over after livecd/unmerge.
+ # example:
+-# livecd/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/make.conf.example /etc/make.globals /etc/resolv.conf
++# livecd/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/portage/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/bootsplash* /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/portage/make.conf.example /etc/make.globals /etc/resolv.conf
+ livecd/rm:
+diff --git a/examples/stage4_template.spec b/examples/stage4_template.spec
+index c5cd65c..9da5e5e 100644
+--- a/examples/stage4_template.spec
++++ b/examples/stage4_template.spec
+@@ -254,5 +254,5 @@ stage4/empty:
+ # This option tells catalyst to clean specific files from the filesystem and is
+ # very usefu in cleaning up stray files in /etc left over after stage4/unmerge.
+ # example:
+-# stage4/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/make.conf.example /etc/make.globals /etc/resolv.conf
++# stage4/rm: /lib/*.a /usr/lib/*.a /usr/lib/gcc-lib/*/*/libgcj* /etc/dispatch-conf.conf /etc/etc-update.conf /etc/*- /etc/issue* /etc/portage/make.conf /etc/man.conf /etc/*.old /root/.viminfo /usr/sbin/fb* /usr/sbin/fsck.cramfs /usr/sbin/fsck.minix /usr/sbin/mkfs.minix /usr/sbin/mkfs.bfs /usr/sbin/mkfs.cramfs /lib/security/pam_access.so /lib/security/pam_chroot.so /lib/security/pam_debug.so /lib/security/pam_ftp.so /lib/security/pam_issue.so /lib/security/pam_mail.so /lib/security/pam_motd.so /lib/security/pam_mkhomedir.so /lib/security/pam_postgresok.so /lib/security/pam_rhosts_auth.so /lib/security/pam_userdb.so /usr/share/consolefonts/1* /usr/share/consolefonts/7* /usr/share/consolefonts/8* /usr/share/consolefonts/9* /usr/share/consolefonts/A* /usr/share/consolefonts/C* /usr/share/consolefonts/E* /usr/share/consolefonts/G* /usr/share/consolefonts/L* /usr/share/consolefonts/M* /usr/share/consolefonts/R* /usr/share/consolefonts/a* /usr/share/consolefonts/c* /usr/share/consolefonts/dr* /usr/share/consolefonts/g* /usr/share/consolefonts/i* /usr/share/consolefonts/k* /usr/share/consolefonts/l* /usr/share/consolefonts/r* /usr/share/consolefonts/s* /usr/share/consolefonts/t* /usr/share/consolefonts/v* /etc/splash/livecd-2006.1/16* /etc/splash/livecd-2006.1/12* /etc/splash/livecd-2006.1/6* /etc/splash/livecd-2006.1/8* /etc/splash/livecd-2006.1/images/silent-16* /etc/splash/livecd-2006.1/images/silent-12* /etc/splash/livecd-2006.1/images/silent-6* /etc/splash/livecd-2006.1/images/silent-8* /etc/splash/livecd-2006.1/images/verbose-16* /etc/splash/livecd-2006.1/images/verbose-12* /etc/splash/livecd-2006.1/images/verbose-6* /etc/splash/livecd-2006.1/images/verbose-8* /etc/portage/make.conf.example /etc/make.globals /etc/resolv.conf
+ stage4/rm:
+diff --git a/modules/generic_stage_target.py b/modules/generic_stage_target.py
+index 6e0bc33..8aa2075 100644
+--- a/modules/generic_stage_target.py
++++ b/modules/generic_stage_target.py
+@@ -938,7 +938,7 @@ class generic_stage_target(generic_target):
+
+ def chroot_setup(self):
+ self.makeconf=read_makeconf(self.settings["chroot_path"]+\
+- "/etc/make.conf")
++ "/etc/portage/make.conf")
+ self.override_cbuild()
+ self.override_chost()
+ self.override_cflags()
+@@ -950,7 +950,7 @@ class generic_stage_target(generic_target):
+ else:
+ print "Setting up chroot..."
+
+- #self.makeconf=read_makeconf(self.settings["chroot_path"]+"/etc/make.conf")
++ #self.makeconf=read_makeconf(self.settings["chroot_path"]+"/etc/portage/make.conf")
+
+ cmd("cp /etc/resolv.conf "+self.settings["chroot_path"]+"/etc",\
+ "Could not copy resolv.conf into place.",env=self.env)
+@@ -997,10 +997,10 @@ class generic_stage_target(generic_target):
+ "Could not copy /etc/hosts",env=self.env)
+
+ """ Modify and write out make.conf (for the chroot) """
+- cmd("rm -f "+self.settings["chroot_path"]+"/etc/make.conf",\
++ cmd("rm -f "+self.settings["chroot_path"]+"/etc/portage/make.conf",\
+ "Could not remove "+self.settings["chroot_path"]+\
+- "/etc/make.conf",env=self.env)
+- myf=open(self.settings["chroot_path"]+"/etc/make.conf","w")
++ "/etc/portage/make.conf",env=self.env)
++ myf=open(self.settings["chroot_path"]+"/etc/portage/make.conf","w")
+ myf.write("# These settings were set by the catalyst build script that automatically\n# built this stage.\n")
+ myf.write("# Please consult /usr/share/portage/config/make.conf.example for a more\n# detailed example.\n")
+ if self.settings.has_key("CFLAGS"):
+@@ -1046,9 +1046,9 @@ class generic_stage_target(generic_target):
+ myf.write('PORTDIR_OVERLAY="/usr/local/portage"\n')
+
+ myf.close()
+- cmd("cp "+self.settings["chroot_path"]+"/etc/make.conf "+\
+- self.settings["chroot_path"]+"/etc/make.conf.catalyst",\
+- "Could not backup /etc/make.conf",env=self.env)
++ cmd("cp "+self.settings["chroot_path"]+"/etc/portage/make.conf "+\
++ self.settings["chroot_path"]+"/etc/portage/make.conf.catalyst",\
++ "Could not backup /etc/portage/make.conf",env=self.env)
+ touch(self.settings["autoresume_path"]+"chroot_setup")
+
+ def fsscript(self):
+@@ -1093,7 +1093,7 @@ class generic_stage_target(generic_target):
+ cmd("rm -rf "+self.settings["chroot_path"]+"/usr/local/portage",\
+ "Could not remove /usr/local/portage",env=self.env)
+ cmd("sed -i '/^PORTDIR_OVERLAY/d' "+self.settings["chroot_path"]+\
+- "/etc/make.conf",\
++ "/etc/portage/make.conf",\
+ "Could not remove PORTDIR_OVERLAY from make.conf",env=self.env)
+
+ """ Clean up old and obsoleted files in /etc """
+diff --git a/modules/stage3_target.py b/modules/stage3_target.py
+index 351ad0c..f5ad9e2 100644
+--- a/modules/stage3_target.py
++++ b/modules/stage3_target.py
+@@ -22,8 +22,12 @@ class stage3_target(generic_stage_target):
+
+ def set_cleanables(self):
+ generic_stage_target.set_cleanables(self)
+- # Not sure where /etc/make.profile is being created
++ # Not sure where /etc/make.profile is being created (unless it is a
++ # leftover from the seed?)
+ self.settings["cleanables"].extend(["/etc/make.profile"])
++ # Not sure where /etc/make.conf is being created (unless it is a
++ # leftover from the seed?)
++ self.settings["cleanables"].extend(["/etc/make.conf"])
+
+ def register(foo):
+ foo.update({"stage3":stage3_target})
+diff --git a/targets/stage1/stage1-chroot.sh b/targets/stage1/stage1-chroot.sh
+index 976515d..e238012 100644
+--- a/targets/stage1/stage1-chroot.sh
++++ b/targets/stage1/stage1-chroot.sh
+@@ -20,19 +20,19 @@ fi
+
+ ## START BUILD
+ # First, we drop in a known-good baselayout
+-[ -e /etc/make.conf ] && \
+- echo 'USE="${USE} -build"' >> /etc/make.conf
++[ -e /etc/portage/make.conf ] && \
++ echo 'USE="${USE} -build"' >> /etc/portage/make.conf
+ run_merge "--oneshot --nodeps sys-apps/baselayout"
+-sed -i '/USE="${USE} -build"/d' /etc/make.conf
++sed -i '/USE="${USE} -build"/d' /etc/portage/make.conf
+
+ # Next, we install the package manager
+ clst_root_path=/ setup_pkgmgr
+ make_destpath /tmp/stage1root
+
+ # Now, we install our packages
+-[ -e /etc/make.conf ] && \
++[ -e /etc/portage/make.conf ] && \
+ echo "USE=\"-* bindist build ${BOOTSTRAP_USE} ${clst_HOSTUSE}\"" \
+- >> /etc/make.conf
++ >> /etc/portage/make.conf
+ run_merge "--oneshot ${clst_buildpkgs}"
+ sed -i "/USE=\"-* bindist build ${BOOTSTRAP_USE} ${clst_HOSTUSE}\"/d" \
+- /etc/make.conf
++ /etc/portage/make.conf
+diff --git a/targets/stage1/stage1-controller.sh b/targets/stage1/stage1-controller.sh
+index 1f72067..3c348ce 100644
+--- a/targets/stage1/stage1-controller.sh
++++ b/targets/stage1/stage1-controller.sh
+@@ -12,7 +12,7 @@ case $1 in
+ install -d ${clst_chroot_path}/${clst_root_path}/etc
+
+ # Setup make.conf and make.profile link in "ROOT in chroot":
+- copy_to_chroot ${clst_chroot_path}/etc/make.conf /${clst_root_path}/etc
++ copy_to_chroot ${clst_chroot_path}/etc/portage/make.conf /${clst_root_path}/etc
+ copy_to_chroot ${clst_chroot_path}/etc/portage/make.profile \
+ /${clst_root_path}/etc
+
+diff --git a/targets/support/chroot-functions.sh b/targets/support/chroot-functions.sh
+index 277fdc2..18cf49e 100644
+--- a/targets/support/chroot-functions.sh
++++ b/targets/support/chroot-functions.sh
+@@ -72,8 +72,8 @@ setup_myfeatures(){
+ then
+ export clst_myfeatures="${clst_myfeatures} distcc"
+ export DISTCC_HOSTS="${clst_distcc_hosts}"
+- [ -e /etc/make.conf ] && \
+- echo 'USE="${USE} -avahi -gtk -gnome"' >> /etc/make.conf
++ [ -e /etc/portage/make.conf ] && \
++ echo 'USE="${USE} -avahi -gtk -gnome"' >> /etc/portage/make.conf
+ # We install distcc to / on stage1, then use --noreplace, so we need to
+ # have some way to check if we need to reinstall distcc without being
+ # able to rely on USE, so we check for the distcc user and force a
+@@ -84,7 +84,7 @@ setup_myfeatures(){
+ else
+ clst_root_path=/ run_merge --oneshot --nodeps --noreplace sys-devel/distcc || exit 1
+ fi
+- sed -i '/USE="${USE} -avahi -gtk -gnome"/d' /etc/make.conf
++ sed -i '/USE="${USE} -avahi -gtk -gnome"/d' /etc/portage/make.conf
+ mkdir -p /etc/distcc
+ echo "${clst_distcc_hosts}" > /etc/distcc/hosts
+
+@@ -163,11 +163,11 @@ setup_gcc(){
+
+ setup_pkgmgr(){
+ # We need to merge our package manager with USE="build" set in case it is
+- # portage to avoid frying our /etc/make.conf file. Otherwise, we could
++ # portage to avoid frying our /etc/portage/make.conf file. Otherwise, we could
+ # just let emerge system could merge it.
+- [ -e /etc/make.conf ] && echo 'USE="${USE} build"' >> /etc/make.conf
++ [ -e /etc/portage/make.conf ] && echo 'USE="${USE} build"' >> /etc/portage/make.conf
+ run_merge --oneshot --nodeps sys-apps/portage
+- sed -i '/USE="${USE} build"/d' /etc/make.conf
++ sed -i '/USE="${USE} build"/d' /etc/portage/make.conf
+ }
+
+ cleanup_distcc() {
+@@ -233,11 +233,11 @@ die() {
+
+ make_destpath() {
+ # ROOT is / by default, so remove any ROOT= settings from make.conf
+- sed -i '/ROOT=/d' /etc/make.conf
++ sed -i '/ROOT=/d' /etc/portage/make.conf
+ export ROOT=/
+ if [ "${1}" != "/" -a -n "${1}" ]
+ then
+- echo "ROOT=\"${1}\"" >> /etc/make.conf
++ echo "ROOT=\"${1}\"" >> /etc/portage/make.conf
+ export ROOT=${1}
+ fi
+ if [ ! -d ${ROOT} ]
+diff --git a/targets/support/kmerge.sh b/targets/support/kmerge.sh
+index d3201bb..f57508f 100644
+--- a/targets/support/kmerge.sh
++++ b/targets/support/kmerge.sh
+@@ -191,8 +191,8 @@ then
+ fi
+ fi
+
+-[ -e /etc/make.conf ] && \
+- echo "USE=\"\${USE} ${clst_kernel_use} build\"" >> /etc/make.conf
++[ -e /etc/portage/make.conf ] && \
++ echo "USE=\"\${USE} ${clst_kernel_use} build\"" >> /etc/portage/make.conf
+
+ if [ -n "${clst_KERNCACHE}" ]
+ then
+@@ -232,7 +232,7 @@ then
+ fi
+
+ build_kernel
+-sed -i "/USE=\"\${USE} ${clst_kernel_use} build\"/d" /etc/make.conf
++sed -i "/USE=\"\${USE} ${clst_kernel_use} build\"/d" /etc/portage/make.conf
+ # grep out the kernel version so that we can do our modules magic
+ VER=`grep ^VERSION\ \= /usr/src/linux/Makefile | awk '{ print $3 };'`
+ PAT=`grep ^PATCHLEVEL\ \= /usr/src/linux/Makefile | awk '{ print $3 };'`
+diff --git a/targets/support/livecdfs-update.sh b/targets/support/livecdfs-update.sh
+index ad2f8b7..a7aad5f 100644
+--- a/targets/support/livecdfs-update.sh
++++ b/targets/support/livecdfs-update.sh
+@@ -112,12 +112,12 @@ fi
+
+ # Tweak the livecd make.conf so that users know not to edit it
+ # http://bugs.gentoo.org/show_bug.cgi?id=144647
+-mv /etc/make.conf /etc/make.conf.old
+-echo "####################################################" >> /etc/make.conf
+-echo "## ATTENTION: THIS IS THE MAKE.CONF ON THE LIVECD ##" >> /etc/make.conf
+-echo "## PLEASE EDIT /mnt/gentoo/etc/make.conf INSTEAD ##" >> /etc/make.conf
+-echo "####################################################" >> /etc/make.conf
+-cat /etc/make.conf.old >> /etc/make.conf
++mv /etc/portage/make.conf /etc/portage/make.conf.old
++echo "####################################################" >> /etc/portage/make.conf
++echo "## ATTENTION: THIS IS THE MAKE.CONF ON THE LIVECD ##" >> /etc/portage/make.conf
++echo "## PLEASE EDIT /mnt/gentoo/etc/portage/make.conf INSTEAD ##" >> /etc/portage/make.conf
++echo "####################################################" >> /etc/portage/make.conf
++cat /etc/portage/make.conf.old >> /etc/portage/make.conf
+
+ # devfs tweaks
+ [ -e /etc/devfsd.conf ] && sed -i '/dev-state/ s:^:#:' /etc/devfsd.conf
+--
+1.7.3.4
+