summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-10-31 22:17:21 +0000
committerRick Farina <zerochaos@gentoo.org>2012-10-31 22:17:21 +0000
commita04fdbef4ad20313c63d213db48d4bf17ef71e9c (patch)
treeb83050ebf446a9da1b67232ba45603aa128a8eab /dev-util/catalyst
parentupdate metadata.xml (diff)
downloadgentoo-2-a04fdbef4ad20313c63d213db48d4bf17ef71e9c.tar.gz
gentoo-2-a04fdbef4ad20313c63d213db48d4bf17ef71e9c.tar.bz2
gentoo-2-a04fdbef4ad20313c63d213db48d4bf17ef71e9c.zip
version bump to 2.0.12. this version includes better lbzip2 support as well as a fix for bug #439636 and several new features available in catalyst.conf
(Portage version: 2.1.11.31/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.12.ebuild107
2 files changed, 114 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index fff5e8d677be..304876554b3e 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.251 2012/10/14 05:51:29 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.252 2012/10/31 22:17:21 zerochaos Exp $
+
+*catalyst-2.0.12 (31 Oct 2012)
+
+ 31 Oct 2012; Rick Farina <zerochaos@gentoo.org> +catalyst-2.0.12.ebuild:
+ version bump to 2.0.12. this version includes better lbzip2 support as well as
+ a fix for bug #439636 and several new features available in catalyst.conf
14 Oct 2012; Matt Turner <mattst88@gentoo.org> catalyst-9999.ebuild:
Add app-arch/lbzip2 to RDEPEND. See upstream commit 166a239.
diff --git a/dev-util/catalyst/catalyst-2.0.12.ebuild b/dev-util/catalyst/catalyst-2.0.12.ebuild
new file mode 100644
index 000000000000..82d3b05081f3
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.12.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.12.ebuild,v 1.1 2012/10/31 22:17:21 zerochaos Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
+# catalyst-3.9999 -> catalyst_3 branch from Git
+# catalyst-VER -> normal catalyst release
+
+EAPI=3
+PYTHON_DEPEND="2"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ inherit git-2
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+
+ case ${PV} in
+ 2.9999) EGIT_BRANCH="catalyst_2" ;;
+ 3.9999) EGIT_BRANCH="catalyst_3" ;;
+ esac
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+inherit eutils multilib python
+
+DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="ccache kernel_linux"
+
+DEPEND="app-text/asciidoc"
+RDEPEND="app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+ if [[ ${PV} == *9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs 2 catalyst modules/catalyst_lock.py
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ if [[ ${PV} == 3.9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}