summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2006-09-13 13:14:23 +0000
committerLisa M. Seelye <lisa@gentoo.org>2006-09-13 13:14:23 +0000
commitbc94e693949d94a270257a0f4b3ec19163ef23c9 (patch)
tree203865a67ebd98c42e2192953c12e62a23ac5f11 /dev-util/ccache
parentFix PACKAGE value during re-autotooling, closes bug #127773 finally. (diff)
downloadgentoo-2-bc94e693949d94a270257a0f4b3ec19163ef23c9.tar.gz
gentoo-2-bc94e693949d94a270257a0f4b3ec19163ef23c9.tar.bz2
gentoo-2-bc94e693949d94a270257a0f4b3ec19163ef23c9.zip
Another attempt at bug 145167. Removing the stale wrappers in pkg_preinst.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog8
-rw-r--r--dev-util/ccache/ccache-2.4-r4.ebuild80
-rw-r--r--dev-util/ccache/files/digest-ccache-2.4-r43
3 files changed, 90 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 1042a4cbf17d..056b1ce55b7a 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ccache
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.45 2006/09/13 10:21:39 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.46 2006/09/13 13:14:23 lisa Exp $
+
+*ccache-2.4-r4 (13 Sep 2006)
+
+ 13 Sep 2006; Lisa Seelye <lisa@gentoo.org> -ccache-2.4-r3.ebuild,
+ +ccache-2.4-r4.ebuild:
+ Another attempt at bug 145167. Removing the stale wrappers in pkg_preinst.
*ccache-2.4-r3 (13 Sep 2006)
diff --git a/dev-util/ccache/ccache-2.4-r4.ebuild b/dev-util/ccache/ccache-2.4-r4.ebuild
new file mode 100644
index 000000000000..994967415f5e
--- /dev/null
+++ b/dev-util/ccache/ccache-2.4-r4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.4-r4.ebuild,v 1.1 2006/09/13 13:14:23 lisa Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ccache-2.4-respectflags.patch
+ epatch ${FILESDIR}/ccache-2.4-utimes.patch
+ eautoconf
+}
+
+do_links() {
+ insinto /usr/lib/ccache/bin
+ for a in ${CHOST}-{gcc,g++,c++} gcc c++ g++; do
+ dosym /usr/bin/${a} /usr/lib/ccache/bin/${a}
+ done
+}
+
+
+src_install() {
+ dobin ccache || die
+ doman ccache.1
+ dodoc README
+ dohtml web/*.html
+
+ diropts -m0755
+ dodir /usr/lib/ccache/bin
+ keepdir /usr/lib/ccache/bin
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/ccache-config
+
+ diropts -m0700
+ if use ppc-macos; then
+ dodir /var/root/.ccache
+ keepdir /var/root/.ccache
+ else
+ dodir /root/.ccache
+ keepdir /root/.ccache
+ fi
+ if [[ ${ROOT} = "/" ]] ; then
+ einfo "Scanning for compiler front-ends..."
+ do_links
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+}
+
+pkg_preinst() {
+ # Portage doesn't handle replacing a non-empty dir with a file!
+ [[ -d "${ROOT}/usr/lib/ccache" ]] && rm -fr "${ROOT}/usr/lib/ccache"
+ [[ -d "${ROOT}/usr/lib/ccache.backup" ]] && rm -fr "${ROOT}/usr/lib/ccache.backup"
+}
+
+pkg_postinst() {
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/lib/ccache/bin to the beginning of your path, before /usr/bin."
+ einfo "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ einfo "no additional steps. If this is your first install of ccache, type"
+ einfo "something like this to set a maximum cache size of 2GB:"
+ einfo "# ccache -M 2G"
+}
diff --git a/dev-util/ccache/files/digest-ccache-2.4-r4 b/dev-util/ccache/files/digest-ccache-2.4-r4
new file mode 100644
index 000000000000..3615329bad9d
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-2.4-r4
@@ -0,0 +1,3 @@
+MD5 73c1ed1e767c1752dd0f548ec1e66ce7 ccache-2.4.tar.gz 86363
+RMD160 43a0647c7faf659121a53a92ec45d245b8140124 ccache-2.4.tar.gz 86363
+SHA256 435f862ca5168c346f5aa9e242174bbf19a5abcaeecfceeac2f194558827aaa0 ccache-2.4.tar.gz 86363