summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2005-03-09 09:54:51 +0000
committerBrian Harring <ferringb@gentoo.org>2005-03-09 09:54:51 +0000
commite6383b0451bc54dbe50961ef33fcf13df5d2028a (patch)
treea70e75ad08414ef0beb5bc5f574d4a9a5cbeb8d6 /dev-util/ccache
parent79192, 79195, 79197 (diff)
downloadgentoo-2-e6383b0451bc54dbe50961ef33fcf13df5d2028a.tar.gz
gentoo-2-e6383b0451bc54dbe50961ef33fcf13df5d2028a.tar.bz2
gentoo-2-e6383b0451bc54dbe50961ef33fcf13df5d2028a.zip
version bump to 2.4
(Portage version: 1.584-cvs)
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog5
-rw-r--r--dev-util/ccache/Manifest2
-rw-r--r--dev-util/ccache/ccache-2.4.ebuild61
-rw-r--r--dev-util/ccache/files/digest-ccache-2.41
4 files changed, 68 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 36037e8f0b0f..0d6094f5698a 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/ccache
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.36 2005/02/21 14:14:22 gongloo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.37 2005/03/09 09:54:51 ferringb Exp $
+
+ 09 Mar 2005; Brian Harring <ferringb@gentoo.org> ccache-2.4.ebuild:
+ Version bump. bug 76133
21 Feb 2005; <gongloo@gentoo.org> ccache-2.3.ebuild:
Stable on ppc-macos.
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index af9cfe012c93..efffac3de84a 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -2,6 +2,8 @@ MD5 1756bcd960992b40320ea8eedd18d0a2 ChangeLog 4462
MD5 9e73e18fdc3867d8ed54b1ae91393c13 ccache-2.2.ebuild 2120
MD5 71448306578b156859d36db75dca80d9 ccache-2.3.ebuild 1951
MD5 23e270dc8b1687e8a41e37e1383b473d metadata.xml 390
+MD5 8e3f30b0237bde567f1f2bcf940a4153 ccache-2.4.ebuild 1931
MD5 3a5de45f5094320a0ce4eb5201506042 files/ccache-config 1554
MD5 0dfb58c5d312454e0c766c14f3d76dad files/digest-ccache-2.2 61
MD5 6bbfd5ad2a75fbaf4b4a5e42fc61270a files/digest-ccache-2.3 61
+MD5 4ec9394758a87717466629023c2872fd files/digest-ccache-2.4 61
diff --git a/dev-util/ccache/ccache-2.4.ebuild b/dev-util/ccache/ccache-2.4.ebuild
new file mode 100644
index 000000000000..1acfebd204e8
--- /dev/null
+++ b/dev-util/ccache/ccache-2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.4.ebuild,v 1.1 2005/03/09 09:54:51 ferringb Exp $
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+src_install() {
+ dobin ccache || die
+ doman ccache.1
+ dodoc README
+ dohtml web/*.html
+
+ diropts -m0755
+ dodir /usr/lib/ccache/bin
+ keepdir /usr/lib/ccache/bin
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_preinst() {
+ # Portage doesn't handle replacing a non-empty dir with a file!
+ [[ -e ${ROOT}/usr/bin/ccache ]] && rm -r "${ROOT}"/usr/bin/ccache
+ [[ -e ${ROOT}/usr/bin/ccache.backup ]] && rm -r "${ROOT}"/usr/bin/ccache.backup
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} = "/" ]] ; then
+ einfo "Scanning for compiler front-ends..."
+ /usr/bin/ccache-config --install-links
+ /usr/bin/ccache-config --install-links ${CHOST}
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/lib/ccache/bin to the beginning of your path, before /usr/bin."
+ einfo "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ einfo "no additional steps. If this is your first install of ccache, type"
+ einfo "something like this to set a maximum cache size of 2GB:"
+ einfo "# ccache -M 2G"
+}
diff --git a/dev-util/ccache/files/digest-ccache-2.4 b/dev-util/ccache/files/digest-ccache-2.4
new file mode 100644
index 000000000000..309204b80d28
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-2.4
@@ -0,0 +1 @@
+MD5 73c1ed1e767c1752dd0f548ec1e66ce7 ccache-2.4.tar.gz 86363