summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-20 14:20:39 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-20 14:20:39 +0000
commit775fae836dfd4f2d21588d04f0e1884a87a07813 (patch)
tree598ec3a0f5d9e8ef03d9ffd05f7a2f9d02ae0d65 /dev-util/ccmalloc
parentVersion bump. Drop old. (diff)
downloadgentoo-2-775fae836dfd4f2d21588d04f0e1884a87a07813.tar.gz
gentoo-2-775fae836dfd4f2d21588d04f0e1884a87a07813.tar.bz2
gentoo-2-775fae836dfd4f2d21588d04f0e1884a87a07813.zip
Revbump. Respect CFLAGS, #240274. Keyword ~amd64. Fix debug USE flag.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-util/ccmalloc')
-rw-r--r--dev-util/ccmalloc/ChangeLog8
-rw-r--r--dev-util/ccmalloc/ccmalloc-0.4.0-r1.ebuild (renamed from dev-util/ccmalloc/ccmalloc-0.4.0.ebuild)27
2 files changed, 25 insertions, 10 deletions
diff --git a/dev-util/ccmalloc/ChangeLog b/dev-util/ccmalloc/ChangeLog
index 8715b2322b00..9d310b317c84 100644
--- a/dev-util/ccmalloc/ChangeLog
+++ b/dev-util/ccmalloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ccmalloc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ChangeLog,v 1.4 2008/01/28 00:55:11 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ChangeLog,v 1.5 2008/10/20 14:20:39 hawking Exp $
+
+*ccmalloc-0.4.0-r1 (20 Oct 2008)
+
+ 20 Oct 2008; Ali Polatel <hawking@gentoo.org> -ccmalloc-0.4.0.ebuild,
+ +ccmalloc-0.4.0-r1.ebuild:
+ Revbump. Respect CFLAGS, #240274. Keyword ~amd64. Fix debug USE flag.
28 Jan 2008; Ali Polatel <hawking@gentoo.org> metadata.xml,
ccmalloc-0.4.0.ebuild:
diff --git a/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild b/dev-util/ccmalloc/ccmalloc-0.4.0-r1.ebuild
index 5c9caaa00ea5..81998f0d9882 100644
--- a/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild
+++ b/dev-util/ccmalloc/ccmalloc-0.4.0-r1.ebuild
@@ -1,27 +1,36 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ccmalloc-0.4.0.ebuild,v 1.2 2008/01/28 00:55:11 hawking Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccmalloc/ccmalloc-0.4.0-r1.ebuild,v 1.1 2008/10/20 14:20:39 hawking Exp $
DESCRIPTION="A easy-to-use memory debugging library"
HOMEPAGE="http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/"
SRC_URI="http://www.inf.ethz.ch/personal/biere/projects/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
-DEPEND="sys-devel/gcc sys-apps/sed"
-RDEPEND="virtual/libc"
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS #240274
+ sed -i \
+ -e "s/CFLAGS=/CFLAGS+=/" \
+ Makefile.in || die "sed in Makefile.in failed"
+}
src_compile() {
local myconf
- use debug && ${myconf} = "${myconf} --debug"
+ use debug && myconf="${myconf} --debug"
+ # Not a standard configure script.
./configure --prefix=/usr ${myconf} || die "configure failed"
emake || die "emake failed"
}
src_install() {
- einstall PREFIX="${D}"/usr || die "einstall failed"
- dodoc BUGS FEATURES NEWS README TODO USAGE VERSION
+ emake PREFIX="${D}"/usr install || die "emake install failed"
+ dodoc BUGS FEATURES NEWS README TODO USAGE VERSION || die "dodoc failed"
}