summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
commit9d54ef8c61839b12b04e3f719f44822578952d2b (patch)
tree42e96e1d4a6c36d7019ce455f02128719347fc90 /dev-util/cvsd
parentfix license/repoman (diff)
downloadgentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.gz
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.bz2
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.zip
fix license/repoman
Diffstat (limited to 'dev-util/cvsd')
-rw-r--r--dev-util/cvsd/cvsd-0.9.19.ebuild39
1 files changed, 18 insertions, 21 deletions
diff --git a/dev-util/cvsd/cvsd-0.9.19.ebuild b/dev-util/cvsd/cvsd-0.9.19.ebuild
index b8d7ac0a1cad..c4f92da60b42 100644
--- a/dev-util/cvsd/cvsd-0.9.19.ebuild
+++ b/dev-util/cvsd/cvsd-0.9.19.ebuild
@@ -1,30 +1,28 @@
-S=${WORKDIR}/${P}
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/cvsd-0.9.19.ebuild,v 1.2 2003/08/07 03:30:25 vapier Exp $
+
DESCRIPTION="CVS pserver daemon"
-SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/cvsd/"
-DEPEND="virtual/glibc"
+SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
-src_compile() {
- cd ${S}
- local myconf
-
- use tcpd && myconf="${myconf} --with-libwrap"
-
- econf --prefix=/usr ${myconf} || die
+DEPEND="virtual/glibc"
+src_compile() {
+ local myconf=""
+ use tcpd && myconf="--with-libwrap"
+ econf ${myconf} || die
make || die
}
src_install() {
- exeinto /usr/sbin
- doexe cvsd cvsd-buildroot cvsd-passwd
+ dosbin cvsd cvsd-buildroot cvsd-passwd
insinto /etc/cvsd
- mv cvsd.conf-dist cvsd.conf
- doins cvsd.conf
+ newins cvsd.conf-dist cvsd.conf
dodoc COPYING* ChangeLog* FAQ
dodoc NEWS README* TODO
@@ -32,12 +30,11 @@ src_install() {
doman cvsd-buildroot.8 cvsd-passwd.8 cvsd.8 cvsd.conf.5
exeinto /etc/init.d ; newexe ${FILESDIR}/cvsd.init cvsd
- insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
-
+ insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
}
+
pkg_postinst() {
- einfo
- einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
- einfo
+ einfo
+ einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
+ einfo
}
-