summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2006-08-12 16:48:12 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2006-08-12 16:48:12 +0000
commit3a27e8671b11d7127fabaeaad2d555b175b6adca (patch)
tree287599e27e6e8e045af13e83a14280b4f1fe5349 /dev-util/darcs
parentStable on SPARC wrt bug #139273. (diff)
downloadgentoo-2-3a27e8671b11d7127fabaeaad2d555b175b6adca.tar.gz
gentoo-2-3a27e8671b11d7127fabaeaad2d555b175b6adca.tar.bz2
gentoo-2-3a27e8671b11d7127fabaeaad2d555b175b6adca.zip
Version bump. See #142785. Thanks to Paulo Jorge de Oliveira Cantante de Matos for reminding us.
(Portage version: 2.1.1_pre5)
Diffstat (limited to 'dev-util/darcs')
-rw-r--r--dev-util/darcs/ChangeLog8
-rw-r--r--dev-util/darcs/darcs-1.0.8.ebuild58
-rw-r--r--dev-util/darcs/files/digest-darcs-1.0.83
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-util/darcs/ChangeLog b/dev-util/darcs/ChangeLog
index 0df6ced009c6..f25eb022207b 100644
--- a/dev-util/darcs/ChangeLog
+++ b/dev-util/darcs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/darcs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.57 2006/06/16 17:34:59 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.58 2006/08/12 16:48:12 kolmodin Exp $
+
+*darcs-1.0.8 (12 Aug 2006)
+
+ 12 Aug 2006; <kolmodin@gentoo.org> +darcs-1.0.8.ebuild:
+ Version bump. See #142785.
+ Thanks to Paulo Jorge de Oliveira Cantante de Matos for reminding us.
*darcs-1.0.7 (16 Jun 2006)
diff --git a/dev-util/darcs/darcs-1.0.8.ebuild b/dev-util/darcs/darcs-1.0.8.ebuild
new file mode 100644
index 000000000000..c8a05e1e445b
--- /dev/null
+++ b/dev-util/darcs/darcs-1.0.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.8.ebuild,v 1.1 2006/08/12 16:48:12 kolmodin Exp $
+
+inherit base
+
+DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
+HOMEPAGE="http://abridgegame.org/darcs"
+MY_P0="${P/_rc/rc}"
+MY_P="${MY_P0/_pre/pre}"
+SRC_URI="http://abridgegame.org/darcs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND=">=net-misc/curl-7.10.2
+ virtual/mta
+ >=virtual/ghc-6.2.2
+ doc? ( virtual/tetex
+ >=dev-tex/latex2html-2002.2.1_pre20041025-r1 )"
+
+RDEPEND=">=net-misc/curl-7.10.2
+ virtual/mta"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ base_src_unpack
+
+ # If we're going to use the CFLAGS with GHC's -optc flag then we'd better
+ # use it with -opta too or it'll break with some CFLAGS, eg -mcpu on sparc
+ sed -i 's:\($(addprefix -optc,$(CFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
+ ${S}/autoconf.mk.in
+
+ # On ia64 we need to tone down the level of inlining so we don't break some
+ # of the low level ghc/gcc interaction gubbins.
+ use ia64 && sed -i 's/-funfolding-use-threshold20//' "${S}/GNUmakefile"
+}
+
+src_compile() {
+ econf $(use_with doc docs) \
+ || die "configure failed"
+ emake all || die "make failed"
+}
+
+src_test() {
+ make test
+}
+
+src_install() {
+ make DESTDIR="${D}" installbin || die "installation failed"
+ if use doc; then
+ dodoc "${S}/darcs.ps"
+ dohtml "${S}/manual/"*
+ fi
+}
diff --git a/dev-util/darcs/files/digest-darcs-1.0.8 b/dev-util/darcs/files/digest-darcs-1.0.8
new file mode 100644
index 000000000000..fda527dde45e
--- /dev/null
+++ b/dev-util/darcs/files/digest-darcs-1.0.8
@@ -0,0 +1,3 @@
+MD5 a7a26d1a98c5675dcab4c2cc30eba59d darcs-1.0.8.tar.gz 1010010
+RMD160 a95309f7dc79b29d7e4f237627aa300a84aa5331 darcs-1.0.8.tar.gz 1010010
+SHA256 36cf64b10a9e09e4bb2d4bc78371a8b511e7e5bbf13deb1a754e867b0efcfcac darcs-1.0.8.tar.gz 1010010