summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-20 21:48:15 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-20 21:48:15 +0000
commite110cea92dee588c5aa37f451ff00020ed5a24d4 (patch)
tree863ed46dece4a0203743842114499511d24cdbe4 /dev-util/debootstrap
parentFix Manifest. (diff)
downloadgentoo-2-e110cea92dee588c5aa37f451ff00020ed5a24d4.tar.gz
gentoo-2-e110cea92dee588c5aa37f451ff00020ed5a24d4.tar.bz2
gentoo-2-e110cea92dee588c5aa37f451ff00020ed5a24d4.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/ChangeLog7
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.64.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-util/debootstrap/ChangeLog b/dev-util/debootstrap/ChangeLog
index 0cc7ba86cbf7..326cab70255d 100644
--- a/dev-util/debootstrap/ChangeLog
+++ b/dev-util/debootstrap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/debootstrap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/ChangeLog,v 1.267 2014/09/25 09:45:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/ChangeLog,v 1.268 2014/10/20 21:48:15 jer Exp $
+
+*debootstrap-1.0.64 (20 Oct 2014)
+
+ 20 Oct 2014; Jeroen Roovers <jer@gentoo.org> +debootstrap-1.0.64.ebuild:
+ Version bump.
*debootstrap-1.0.63 (25 Sep 2014)
diff --git a/dev-util/debootstrap/debootstrap-1.0.64.ebuild b/dev-util/debootstrap/debootstrap-1.0.64.ebuild
new file mode 100644
index 000000000000..fd1a05e51200
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.64.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debootstrap/debootstrap-1.0.64.ebuild,v 1.1 2014/10/20 21:48:15 jer Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="http://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ app-arch/xz-utils
+"
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.xz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring"
+ elog " (--keyring=K), please install app-crypt/gnupg."
+ fi
+}