summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-01-28 08:48:20 +0000
committerJeroen Roovers <jer@gentoo.org>2015-01-28 08:48:20 +0000
commit8273e7ae3a734e028af8585dbc248315dd66bf0c (patch)
treec93486191ab6796190f4bd1e68026fb790328bfb /dev-util/dialog
parentnew ebuild, written by maintainer, entered under proxy-maintainers herd, need... (diff)
downloadgentoo-2-8273e7ae3a734e028af8585dbc248315dd66bf0c.tar.gz
gentoo-2-8273e7ae3a734e028af8585dbc248315dd66bf0c.tar.bz2
gentoo-2-8273e7ae3a734e028af8585dbc248315dd66bf0c.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/dialog')
-rw-r--r--dev-util/dialog/ChangeLog9
-rw-r--r--dev-util/dialog/dialog-1.2.20150125.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-util/dialog/ChangeLog b/dev-util/dialog/ChangeLog
index d444bc778c6d..c937a4e922eb 100644
--- a/dev-util/dialog/ChangeLog
+++ b/dev-util/dialog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/dialog
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.222 2014/12/06 16:41:59 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.223 2015/01/28 08:48:20 jer Exp $
+
+*dialog-1.2.20150125 (28 Jan 2015)
+
+ 28 Jan 2015; Jeroen Roovers <jer@gentoo.org> +dialog-1.2.20150125.ebuild:
+ Version bump.
06 Dec 2014; Agostino Sarubbo <ago@gentoo.org> dialog-1.2.20140911.ebuild:
Stable for ia64, wrt bug #530244
diff --git a/dev-util/dialog/dialog-1.2.20150125.ebuild b/dev-util/dialog/dialog-1.2.20150125.ebuild
new file mode 100644
index 000000000000..5516581ab604
--- /dev/null
+++ b/dev-util/dialog/dialog-1.2.20150125.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.2.20150125.ebuild,v 1.1 2015/01/28 08:48:20 jer Exp $
+
+EAPI=5
+inherit eutils multilib versionator
+
+MY_PV="$(get_version_component_range 1-2)-$(get_version_component_range 3)"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="ftp://invisible-island.net/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+
+src_prepare() {
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}