summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-09 10:49:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-09 10:49:06 +0000
commite5343a7a67e146b6accc33abd92e07a7fb39b86c (patch)
treecaf7b95d8ee740f0f47e8ebf062c2949939aad38 /dev-util/google-perftools
parentUnmask google-perftools. (diff)
downloadgentoo-2-e5343a7a67e146b6accc33abd92e07a7fb39b86c.tar.gz
gentoo-2-e5343a7a67e146b6accc33abd92e07a7fb39b86c.tar.bz2
gentoo-2-e5343a7a67e146b6accc33abd92e07a7fb39b86c.zip
Remove old; add a patch to build with glibc 2.16 (bug #424992); make sure to disable frame pointer omission as upstream seems to be concerned about it.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/ChangeLog8
-rw-r--r--dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch13
-rw-r--r--dev-util/google-perftools/google-perftools-1.10.ebuild76
-rw-r--r--dev-util/google-perftools/google-perftools-1.9.ebuild76
-rw-r--r--dev-util/google-perftools/google-perftools-2.0.ebuild8
5 files changed, 26 insertions, 155 deletions
diff --git a/dev-util/google-perftools/ChangeLog b/dev-util/google-perftools/ChangeLog
index a7452d52aa5f..9b5c5783519e 100644
--- a/dev-util/google-perftools/ChangeLog
+++ b/dev-util/google-perftools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/google-perftools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.18 2012/07/06 00:57:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.19 2012/07/09 10:49:06 flameeyes Exp $
+
+ 09 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/gperftools-2.0+glibc-2.16.patch, -google-perftools-1.10.ebuild,
+ -google-perftools-1.9.ebuild, google-perftools-2.0.ebuild:
+ Remove old; add a patch to build with glibc 2.16 (bug #424992); make sure to
+ disable frame pointer omission as upstream seems to be concerned about it.
*google-perftools-2.0 (06 Jul 2012)
*google-perftools-1.10 (06 Jul 2012)
diff --git a/dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch b/dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch
new file mode 100644
index 000000000000..b17e0d57f5fb
--- /dev/null
+++ b/dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch
@@ -0,0 +1,13 @@
+Index: gperftools-2.0/src/base/linuxthreads.cc
+===================================================================
+--- gperftools-2.0.orig/src/base/linuxthreads.cc
++++ gperftools-2.0/src/base/linuxthreads.cc
+@@ -193,7 +193,7 @@ static volatile int *sig_pids, sig_num_t
+ /* Signal handler to help us recover from dying while we are attached to
+ * other threads.
+ */
+-static void SignalHandler(int signum, siginfo_t *si, void *data) {
++static void SignalHandler(int signum, struct siginfo *si, void *data) {
+ if (sig_pids != NULL) {
+ if (signum == SIGABRT) {
+ while (sig_num_threads-- > 0) {
diff --git a/dev-util/google-perftools/google-perftools-1.10.ebuild b/dev-util/google-perftools/google-perftools-1.10.ebuild
deleted file mode 100644
index 8d102c4ba6a7..000000000000
--- a/dev-util/google-perftools/google-perftools-1.10.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.10.ebuild,v 1.1 2012/07/06 00:57:34 flameeyes Exp $
-
-EAPI=4
-
-inherit toolchain-funcs eutils flag-o-matic
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="http://code.google.com/p/gperftools/"
-SRC_URI="http://gperftools.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="largepages +debug minimal test"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- makeopts="${makeopts} noinst_PROGRAMS= "
-
- # don't install _anything_ from the documentation, since it would
- # install it in non-standard locations, and would just waste time.
- makeopts="${makeopts} dist_doc_DATA= "
-}
-
-src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
-
- append-flags -fno-strict-aliasing
-
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --enable-fast-install \
- $(use_enable debug debugalloc) \
- $(use_enable minimal)
-}
-
-src_compile() {
- emake ${makeopts}
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sanbox is enabled."
- ewarn "See http://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install ${makeopts}
-
- # Remove libtool files since we dropped the static libraries
- find "${D}" -name '*.la' -delete
-
- dodoc README AUTHORS ChangeLog TODO NEWS
- pushd doc
- dohtml -r *
- popd
-}
diff --git a/dev-util/google-perftools/google-perftools-1.9.ebuild b/dev-util/google-perftools/google-perftools-1.9.ebuild
deleted file mode 100644
index 81a00e9bf4b9..000000000000
--- a/dev-util/google-perftools/google-perftools-1.9.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.9.ebuild,v 1.1 2011/12/24 15:11:26 flameeyes Exp $
-
-EAPI=4
-
-inherit toolchain-funcs eutils flag-o-matic
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="http://code.google.com/p/google-perftools/"
-SRC_URI="http://google-perftools.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="largepages +debug minimal test"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- makeopts="${makeopts} noinst_PROGRAMS= "
-
- # don't install _anything_ from the documentation, since it would
- # install it in non-standard locations, and would just waste time.
- makeopts="${makeopts} dist_doc_DATA= "
-}
-
-src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
-
- append-flags -fno-strict-aliasing
-
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --enable-fast-install \
- $(use_enable debug debugalloc) \
- $(use_enable minimal)
-}
-
-src_compile() {
- emake ${makeopts}
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sanbox is enabled."
- ewarn "See http://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install ${makeopts}
-
- # Remove libtool files since we dropped the static libraries
- find "${D}" -name '*.la' -delete
-
- dodoc README AUTHORS ChangeLog TODO NEWS
- pushd doc
- dohtml -r *
- popd
-}
diff --git a/dev-util/google-perftools/google-perftools-2.0.ebuild b/dev-util/google-perftools/google-perftools-2.0.ebuild
index 8b17ece415ef..c76592c54777 100644
--- a/dev-util/google-perftools/google-perftools-2.0.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-2.0.ebuild,v 1.1 2012/07/06 00:57:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-2.0.ebuild,v 1.2 2012/07/09 10:49:06 flameeyes Exp $
EAPI=4
@@ -38,10 +38,14 @@ pkg_setup() {
makeopts="${makeopts} dist_doc_DATA= "
}
+src_prepare() {
+ epatch "${FILESDIR}/${MY_P}+glibc-2.16.patch"
+}
+
src_configure() {
use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- append-flags -fno-strict-aliasing
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
econf \
--disable-static \