summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-21 15:26:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-21 15:26:36 +0000
commit19a078af80d6cb23bab4f1226aaf6a32bead11c0 (patch)
tree46693ed1b1631284f86ea5a7dc0e391d787cb7a5 /dev-util/gource
parentFix for parallel make, #359801 (diff)
downloadgentoo-2-19a078af80d6cb23bab4f1226aaf6a32bead11c0.tar.gz
gentoo-2-19a078af80d6cb23bab4f1226aaf6a32bead11c0.tar.bz2
gentoo-2-19a078af80d6cb23bab4f1226aaf6a32bead11c0.zip
Version bump by Enrico.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/gource')
-rw-r--r--dev-util/gource/ChangeLog8
-rw-r--r--dev-util/gource/gource-0.29.ebuild55
-rw-r--r--dev-util/gource/gource-0.32.ebuild (renamed from dev-util/gource/gource-0.28.ebuild)6
3 files changed, 11 insertions, 58 deletions
diff --git a/dev-util/gource/ChangeLog b/dev-util/gource/ChangeLog
index 03bbb1e99576..a82c744c130c 100644
--- a/dev-util/gource/ChangeLog
+++ b/dev-util/gource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/ChangeLog,v 1.14 2011/02/25 20:54:44 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/ChangeLog,v 1.15 2011/03/21 15:26:35 flameeyes Exp $
+
+*gource-0.32 (21 Mar 2011)
+
+ 21 Mar 2011; Diego E. Pettenò <flameeyes@gentoo.org> -gource-0.28.ebuild,
+ -gource-0.29.ebuild, +gource-0.32.ebuild:
+ Version bump by Enrico.
25 Feb 2011; Kevin McCarthy <signals@gentoo.org> gource-0.28.ebuild,
gource-0.29.ebuild, gource-0.31.ebuild:
diff --git a/dev-util/gource/gource-0.29.ebuild b/dev-util/gource/gource-0.29.ebuild
deleted file mode 100644
index 6f6cb674263e..000000000000
--- a/dev-util/gource/gource-0.29.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.29.ebuild,v 1.2 2011/02/25 20:54:44 signals Exp $
-
-EAPI=2
-
-inherit versionator
-
-MY_P=${P/_p/-}
-MY_P=${MY_P/_/-}
-MY_DATE=${PV/*_p}
-
-DESCRIPTION="A software version control visualization tool"
-HOMEPAGE="http://code.google.com/p/gource/"
-SRC_URI="http://gource.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=media-libs/libsdl-1.2.10[opengl,X]
- >=media-libs/sdl-image-1.2[jpeg,png]
- dev-libs/libpcre:3
- >=media-libs/ftgl-2.1.3_rc5
- >=media-libs/libpng-1.2
- virtual/jpeg
- media-libs/mesa
- media-fonts/freefont-ttf
- >=media-libs/glew-1.5
- "
-DEPEND="
- ${RDEPEND}
- dev-util/pkgconfig
- media-libs/freetype:2
- "
-
-case ${PV} in
- *_beta*)
- my_v=$(get_version_component_range 1-3)
- my_v=${my_v//_/-}
- S="${WORKDIR}/${PN}-${my_v}" ;;
- *)
- S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)" ;;
-esac
-
-src_configure() {
- econf --enable-ttf-font-dir=/usr/share/fonts/freefont-ttf/
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc README ChangeLog THANKS || die "dodoc failed"
-}
diff --git a/dev-util/gource/gource-0.28.ebuild b/dev-util/gource/gource-0.32.ebuild
index a67dd65138c2..02d86ea43a13 100644
--- a/dev-util/gource/gource-0.28.ebuild
+++ b/dev-util/gource/gource-0.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.28.ebuild,v 1.2 2011/02/25 20:54:44 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.32.ebuild,v 1.1 2011/03/21 15:26:36 flameeyes Exp $
EAPI=2
@@ -29,6 +29,7 @@ RDEPEND="
media-libs/mesa
media-fonts/freefont-ttf
>=media-libs/glew-1.5
+ dev-libs/tinyxml[-stl]
"
DEPEND="
${RDEPEND}
@@ -46,7 +47,8 @@ case ${PV} in
esac
src_configure() {
- econf --enable-ttf-font-dir=/usr/share/fonts/freefont-ttf/
+ econf --enable-ttf-font-dir=/usr/share/fonts/freefont-ttf/ \
+ --with-tinyxml
}
src_install() {