summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-10 09:56:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-10 09:56:32 +0000
commitf90e0037c0cf3b17bd47b1b543a923803b42b800 (patch)
tree94fc9b5d1b27af360e23013998ca16ea501c2207 /dev-util/gource
parentAdd missing mask on fromcvs (due to rcsparse). (diff)
downloadgentoo-2-f90e0037c0cf3b17bd47b1b543a923803b42b800.tar.gz
gentoo-2-f90e0037c0cf3b17bd47b1b543a923803b42b800.tar.bz2
gentoo-2-f90e0037c0cf3b17bd47b1b543a923803b42b800.zip
Add patch to fix building with boost 1.50, mixing one fix from upstream and one upstreamed. Thanks Enrico for finding the fix. Closes bug #425460.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/gource')
-rw-r--r--dev-util/gource/ChangeLog7
-rw-r--r--dev-util/gource/files/gource-0.38+boost-1.50.patch64
-rw-r--r--dev-util/gource/gource-0.38.ebuild5
3 files changed, 73 insertions, 3 deletions
diff --git a/dev-util/gource/ChangeLog b/dev-util/gource/ChangeLog
index fe4ff8af591e..afda6c9a376a 100644
--- a/dev-util/gource/ChangeLog
+++ b/dev-util/gource/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/ChangeLog,v 1.21 2012/07/09 09:39:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/ChangeLog,v 1.22 2012/07/10 09:56:31 flameeyes Exp $
+
+ 10 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/gource-0.38+boost-1.50.patch, gource-0.38.ebuild:
+ Add patch to fix building with boost 1.50, mixing one fix from upstream and
+ one upstreamed. Thanks Enrico for finding the fix. Closes bug #425460.
09 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Reorder metadata to help auto-filing.
diff --git a/dev-util/gource/files/gource-0.38+boost-1.50.patch b/dev-util/gource/files/gource-0.38+boost-1.50.patch
new file mode 100644
index 000000000000..994ea1e5f9da
--- /dev/null
+++ b/dev-util/gource/files/gource-0.38+boost-1.50.patch
@@ -0,0 +1,64 @@
+diff --git a/m4/m4_ax_boost_filesystem.m4 b/m4/ax_boost_filesystem.m4
+index 18df8f4..aebcbf7 100644
+--- a/m4/m4_ax_boost_filesystem.m4
++++ b/m4/m4_ax_boost_filesystem.m4
+@@ -31,7 +31,7 @@
+ # and this notice are preserved. This file is offered as-is, without any
+ # warranty.
+
+-#serial 22
++#serial 24
+
+ AC_DEFUN([AX_BOOST_FILESYSTEM],
+ [
+@@ -81,14 +81,14 @@ AC_DEFUN([AX_BOOST_FILESYSTEM],
+ AC_DEFINE(HAVE_BOOST_FILESYSTEM,,[define if the Boost::Filesystem library is available])
+ BOOSTLIBDIR=`echo $BOOST_LDFLAGS | sed -e 's/@<:@^\/@:>@*//'`
+ if test "x$ax_boost_user_filesystem_lib" = "x"; then
+- for libextension in `ls $BOOSTLIBDIR/libboost_filesystem*.so* $BOOSTLIBDIR/libboost_filesystem*.dylib* $BOOSTLIBDIR/libboost_filesystem*.a* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_filesystem.*\)\.so.*$;\1;' -e 's;^lib\(boost_filesystem.*\)\.a*$;\1;' -e 's;^lib\(boost_filesystem.*\)\.dylib$;\1;'` ; do
++ for libextension in `ls $BOOSTLIBDIR/libboost_filesystem*.so* $BOOSTLIBDIR/libboost_filesystem*.dylib* $BOOSTLIBDIR/libboost_filesystem*.a* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_filesystem.*\)\.\(dylib\|a\|so\).*$;\1;' | tac` ; do
+ ax_lib=${libextension}
+ AC_CHECK_LIB($ax_lib, exit,
+ [BOOST_FILESYSTEM_LIB="-l$ax_lib"; AC_SUBST(BOOST_FILESYSTEM_LIB) link_filesystem="yes"; break],
+ [link_filesystem="no"])
+ done
+ if test "x$link_filesystem" != "xyes"; then
+- for libextension in `ls $BOOSTLIBDIR/boost_filesystem*.{dll,a}* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_filesystem.*\)\.dll.*$;\1;' -e 's;^\(boost_filesystem.*\)\.a*$;\1;'` ; do
++ for libextension in `ls $BOOSTLIBDIR/boost_filesystem*.dll* $BOOSTLIBDIR/boost_filesystem*.a* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_filesystem.*\)\.\(dll\|a\).*$;\1;' | tac` ; do
+ ax_lib=${libextension}
+ AC_CHECK_LIB($ax_lib, exit,
+ [BOOST_FILESYSTEM_LIB="-l$ax_lib"; AC_SUBST(BOOST_FILESYSTEM_LIB) link_filesystem="yes"; break],
+diff --git a/m4/m4_ax_boost_system.m4 b/m4/ax_boost_system.m4
+index 7fbf6d3..bf82391 100644
+--- a/m4/m4_ax_boost_system.m4
++++ b/m4/m4_ax_boost_system.m4
+@@ -83,14 +83,14 @@ AC_DEFUN([AX_BOOST_SYSTEM],
+
+ LDFLAGS_SAVE=$LDFLAGS
+ if test "x$ax_boost_user_system_lib" = "x"; then
+- for libextension in `ls $BOOSTLIBDIR/libboost_system*.so* $BOOSTLIBDIR/libboost_system*.a* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_system.*\)\.so.*$;\1;' -e 's;^lib\(boost_system.*\)\.a*$;\1;'` ; do
++ for libextension in `ls $BOOSTLIBDIR/libboost_system*.a* $BOOSTLIBDIR/libboost_system*.so* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^lib\(boost_system.*\)\.\(so\|a\).*$;\1;' | tac` ; do
+ ax_lib=${libextension}
+ AC_CHECK_LIB($ax_lib, exit,
+ [BOOST_SYSTEM_LIB="-l$ax_lib"; AC_SUBST(BOOST_SYSTEM_LIB) link_system="yes"; break],
+ [link_system="no"])
+ done
+ if test "x$link_system" != "xyes"; then
+- for libextension in `ls $BOOSTLIBDIR/boost_system*.{dll,a}* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_system.*\)\.dll.*$;\1;' -e 's;^\(boost_system.*\)\.a*$;\1;'` ; do
++ for libextension in `ls $BOOSTLIBDIR/boost_system*.{dll,a}* 2>/dev/null | sed 's,.*/,,' | sed -e 's;^\(boost_system.*\)\.\(dll\|a\).*$;\1;' | tac` ; do
+ ax_lib=${libextension}
+ AC_CHECK_LIB($ax_lib, exit,
+ [BOOST_SYSTEM_LIB="-l$ax_lib"; AC_SUBST(BOOST_SYSTEM_LIB) link_system="yes"; break],
+diff --git a/src/logmill.cpp b/src/logmill.cpp
+index 8fc6153..2a9afd9 100644
+--- a/src/logmill.cpp
++++ b/src/logmill.cpp
+@@ -176,7 +176,7 @@ RCommitLog* RLogMill::fetchLog(std::string& log_format) {
+ logfile = repo_path.string();
+ }
+ }
+- } catch(boost::filesystem3::filesystem_error& error) {
++ } catch(boost::filesystem::filesystem_error& error) {
+ }
+ }
+
diff --git a/dev-util/gource/gource-0.38.ebuild b/dev-util/gource/gource-0.38.ebuild
index 3152737ba3b1..b42170629cdb 100644
--- a/dev-util/gource/gource-0.38.ebuild
+++ b/dev-util/gource/gource-0.38.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.38.ebuild,v 1.3 2012/05/12 19:25:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.38.ebuild,v 1.4 2012/07/10 09:56:31 flameeyes Exp $
EAPI=2
-inherit autotools flag-o-matic versionator
+inherit eutils autotools flag-o-matic versionator
MY_P=${P/_p/-}
MY_P=${MY_P/_/-}
@@ -48,6 +48,7 @@ case ${PV} in
esac
src_prepare() {
+ epatch "${FILESDIR}/${P}+boost-1.50.patch"
eautoreconf
}