summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-25 20:57:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-25 20:57:16 +0000
commitced2e47eb5f83dd9da5aef73c7bdeb774a744c33 (patch)
treed00d221d1e873e75c23c4adf1edf43d2ec832f99 /dev-util/gquilt
parentBump to 0.9.5, fixes #267462 (diff)
downloadgentoo-2-ced2e47eb5f83dd9da5aef73c7bdeb774a744c33.tar.gz
gentoo-2-ced2e47eb5f83dd9da5aef73c7bdeb774a744c33.tar.bz2
gentoo-2-ced2e47eb5f83dd9da5aef73c7bdeb774a744c33.zip
Bump to 0.21, fixes #266427
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/gquilt')
-rw-r--r--dev-util/gquilt/ChangeLog9
-rw-r--r--dev-util/gquilt/gquilt-0.21.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/gquilt/ChangeLog b/dev-util/gquilt/ChangeLog
index 9aabda0838e7..dbbab5757af9 100644
--- a/dev-util/gquilt/ChangeLog
+++ b/dev-util/gquilt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gquilt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/ChangeLog,v 1.14 2008/02/18 00:02:41 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/ChangeLog,v 1.15 2009/04/25 20:57:16 patrick Exp $
+
+*gquilt-0.21 (25 Apr 2009)
+
+ 25 Apr 2009; Patrick Lauer <patrick@gentoo.org> +gquilt-0.21.ebuild:
+ Bump to 0.21, fixes #266427
17 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> gquilt-0.20.ebuild:
fix python eclass use, bug #207667
diff --git a/dev-util/gquilt/gquilt-0.21.ebuild b/dev-util/gquilt/gquilt-0.21.ebuild
new file mode 100644
index 000000000000..d0511e47b6a9
--- /dev/null
+++ b/dev-util/gquilt/gquilt-0.21.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/gquilt-0.21.ebuild,v 1.1 2009/04/25 20:57:16 patrick Exp $
+
+inherit python
+
+DESCRIPTION="A Python/GTK wrapper for quilt"
+HOMEPAGE="http://users.bigpond.net.au/Peter-Williams/"
+SRC_URI="mirror://sourceforge/gquilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-util/quilt
+ >=dev-python/pygtk-2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "s/MODULES_BIN=.*/MODULES_BIN=/;
+ s/MODULES_OPT=.*/MODULES_OPT=/" Makefile
+ sed -i -e '/install -m 0644 $(MODULES_OPT)/s/\t/&#/g' Makefile
+ sed -i -e '/install -m 0644 $(MODULES_BIN)/s/\t/&#/g' Makefile
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "make install failed"
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/share/gquilt
+}
+
+pkg_prerm() {
+ python_version
+ python_mod_cleanup /usr/share/gquilt
+}