summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-20 22:32:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-20 22:32:27 +0000
commitc70987c7c70c35ccb81c53c2742758d635544ffe (patch)
treefd211acd0f986d8b2eaaa9c00b034bc568a20ed6 /dev-util/kdevplatform
parentVersion bump. (diff)
downloadgentoo-2-c70987c7c70c35ccb81c53c2742758d635544ffe.tar.gz
gentoo-2-c70987c7c70c35ccb81c53c2742758d635544ffe.tar.bz2
gentoo-2-c70987c7c70c35ccb81c53c2742758d635544ffe.zip
Fix crash with subversion-1.7, bug 388029
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kdevplatform')
-rw-r--r--dev-util/kdevplatform/ChangeLog10
-rw-r--r--dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch32
-rw-r--r--dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch95
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.2.2.ebuild4
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild71
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.2.3.ebuild4
6 files changed, 211 insertions, 5 deletions
diff --git a/dev-util/kdevplatform/ChangeLog b/dev-util/kdevplatform/ChangeLog
index af2a903f80bc..6c8481d11b37 100644
--- a/dev-util/kdevplatform/ChangeLog
+++ b/dev-util/kdevplatform/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/kdevplatform
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.59 2011/06/30 00:26:30 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.60 2011/11/20 22:32:26 dilfridge Exp $
+
+*kdevplatform-1.2.3-r1 (20 Nov 2011)
+
+ 20 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ kdevplatform-1.2.2.ebuild, kdevplatform-1.2.3.ebuild,
+ +kdevplatform-1.2.3-r1.ebuild, +files/kdevplatform-1.2.3-svn17-1.patch,
+ +files/kdevplatform-1.2.3-svn17-2.patch:
+ Fix crash with subversion-1.7, bug 388029
*kdevplatform-1.2.3 (29 Jun 2011)
diff --git a/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch b/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch
new file mode 100644
index 000000000000..c1ca7582e194
--- /dev/null
+++ b/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch
@@ -0,0 +1,32 @@
+commit 74dec52749e3c3af2ac6492f50e2676128f35b27
+Author: Milian Wolff <mail@milianw.de>
+Date: Fri Nov 18 16:26:06 2011 +0100
+
+ fix svn api usage: use svn_dirent_canonicalize instead of svn_path_internal_style
+
+ this was suggested by Stephan Sperling
+
+ CCBUG: 284061
+
+diff --git a/plugins/subversion/kdevsvncpp/path.cpp b/plugins/subversion/kdevsvncpp/path.cpp
+index eaa84c1..4dced08 100644
+--- a/plugins/subversion/kdevsvncpp/path.cpp
++++ b/plugins/subversion/kdevsvncpp/path.cpp
+@@ -24,6 +24,7 @@
+
+ // subversion api
+ #include "svn_path.h"
++#include "svn_dirent_uri.h"
+
+ // apr api
+ #include "apr_file_io.h"
+@@ -63,8 +64,7 @@ namespace svn
+ m_path = "";
+ else
+ {
+- const char * int_path =
+- svn_path_internal_style(path, pool.pool());
++ const char * int_path = svn_dirent_canonicalize(path, pool);
+
+ m_path = int_path;
+
diff --git a/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch b/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch
new file mode 100644
index 000000000000..a240eedc4380
--- /dev/null
+++ b/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch
@@ -0,0 +1,95 @@
+commit cc7f0798d314cdac14b90e427abe22e99c6bd591
+Author: Milian Wolff <mail@milianw.de>
+Date: Fri Nov 18 16:23:36 2011 +0100
+
+ properly initialize client context for compatibility with subversion API
+
+ this should hopefully fix the crash with svn 1.7 in kdevelop, please test
+
+ BUG: 284061
+
+diff --git a/plugins/subversion/kdevsvncpp/context.cpp b/plugins/subversion/kdevsvncpp/context.cpp
+index d277591..ddbb657 100644
+--- a/plugins/subversion/kdevsvncpp/context.cpp
++++ b/plugins/subversion/kdevsvncpp/context.cpp
+@@ -65,7 +65,7 @@ public:
+ bool logIsSet;
+ int promptCounter;
+ Pool pool;
+- svn_client_ctx_t ctx;
++ svn_client_ctx_t * ctx;
+ std::string username;
+ std::string password;
+ std::string logMessage;
+@@ -205,26 +205,26 @@ public:
+ svn_auth_open(&ab, providers, pool);
+
+ // initialize ctx structure
+- memset(&ctx, 0, sizeof(ctx));
++ svn_client_create_context(&ctx, pool);
+
+ // get the config based on the configDir passed in
+- svn_config_get_config(&ctx.config, c_configDir, pool);
++ svn_config_get_config(&ctx->config, c_configDir, pool);
+
+ // tell the auth functions where the config is
+ svn_auth_set_parameter(ab, SVN_AUTH_PARAM_CONFIG_DIR,
+ c_configDir);
+
+- ctx.auth_baton = ab;
+- ctx.log_msg_func = onLogMsg;
+- ctx.log_msg_baton = this;
+- ctx.notify_func = onNotify;
+- ctx.notify_baton = this;
+- ctx.cancel_func = onCancel;
+- ctx.cancel_baton = this;
++ ctx->auth_baton = ab;
++ ctx->log_msg_func = onLogMsg;
++ ctx->log_msg_baton = this;
++ ctx->notify_func = onNotify;
++ ctx->notify_baton = this;
++ ctx->cancel_func = onCancel;
++ ctx->cancel_baton = this;
+
+ #if (SVN_VER_MAJOR >= 1) && (SVN_VER_MINOR >= 2)
+- ctx.notify_func2 = onNotify2;
+- ctx.notify_baton2 = this;
++ ctx->notify_func2 = onNotify2;
++ ctx->notify_baton2 = this;
+ #endif
+ }
+
+@@ -234,7 +234,7 @@ public:
+ if (!value)
+ param = (void *)"1";
+
+- svn_auth_set_parameter(ctx.auth_baton,
++ svn_auth_set_parameter(ctx->auth_baton,
+ SVN_AUTH_PARAM_NO_AUTH_CACHE,
+ param);
+ }
+@@ -245,7 +245,7 @@ public:
+ username = usr;
+ password = pwd;
+
+- svn_auth_baton_t * ab = ctx.auth_baton;
++ svn_auth_baton_t * ab = ctx->auth_baton;
+ svn_auth_set_parameter(ab, SVN_AUTH_PARAM_DEFAULT_USERNAME,
+ username.c_str());
+ svn_auth_set_parameter(ab, SVN_AUTH_PARAM_DEFAULT_PASSWORD,
+@@ -654,13 +654,13 @@ public:
+
+ Context::operator svn_client_ctx_t * ()
+ {
+- return &(m->ctx);
++ return m->ctx;
+ }
+
+ svn_client_ctx_t *
+ Context::ctx()
+ {
+- return &(m->ctx);
++ return m->ctx;
+ }
+
+ void
diff --git a/dev-util/kdevplatform/kdevplatform-1.2.2.ebuild b/dev-util/kdevplatform/kdevplatform-1.2.2.ebuild
index 1db6370e6af3..64d3fde10746 100644
--- a/dev-util/kdevplatform/kdevplatform-1.2.2.ebuild
+++ b/dev-util/kdevplatform/kdevplatform-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.2.ebuild,v 1.6 2011/06/07 02:58:47 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.2.ebuild,v 1.7 2011/11/20 22:32:26 dilfridge Exp $
EAPI=4
@@ -28,7 +28,7 @@ IUSE="cvs debug git reviewboard subversion"
DEPEND="
dev-libs/boost
reviewboard? ( dev-libs/qjson )
- subversion? ( >=dev-vcs/subversion-1.3 )
+ subversion? ( <dev-vcs/subversion-1.7 )
"
RDEPEND="${DEPEND}
!<dev-util/kdevelop-${KDEVELOP_VERSION}:4
diff --git a/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild b/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..eaa009ac7ab4
--- /dev/null
+++ b/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild,v 1.1 2011/11/20 22:32:27 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdevelop"
+KDE_SCM="git"
+EGIT_REPONAME="${PN}"
+KDE_MINIMAL="4.6"
+VIRTUALX_REQUIRED=test
+KDE_LINGUAS="ca ca@valencia da de en_GB es et fr it nb nds nl pt pt_BR ru sl sv th uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE development support libraries and apps"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+# Moved to playground for now
+# bazaar kompare mercurial
+LICENSE="GPL-2 LGPL-2"
+IUSE="cvs debug git reviewboard subversion"
+
+# Moved to playground for now
+# bazaar? ( dev-vcs/bzr )
+# kompare? ( $(add_kdebase_dep kompare) )
+# mercurial? ( dev-vcs/mercurial )
+# block - some plugins moved to kdevplatform from kdevelop
+DEPEND="
+ dev-libs/boost
+ reviewboard? ( dev-libs/qjson )
+ subversion? ( dev-vcs/subversion )
+"
+RDEPEND="${DEPEND}
+ !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
+ !dev-util/kdevelop-git
+ $(add_kdebase_dep konsole)
+ cvs? ( dev-vcs/cvs )
+ git? ( dev-vcs/git )
+"
+
+# Quite few fails and upstream is aware
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-svn17-[12].patch
+)
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # FindKDevPlatform.cmake is installed by kdelibs
+ sed -i \
+ -e '/cmakeFiles/s/^/#DONOTINSTALL/' \
+ cmake/modules/CMakeLists.txt || die
+}
+
+# Moved to playground for now
+# $(cmake-utils_use_build bazaar)
+# $(cmake-utils_use_with kompare)
+# $(cmake-utils_use_build mercurial)
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build cvs)
+ $(cmake-utils_use_build git)
+ $(cmake-utils_use_with reviewboard QJSON)
+ $(cmake-utils_use_build subversion)
+ $(cmake-utils_use_with subversion SubversionLibrary)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild b/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild
index 274d83ca9f3f..d43aa76f6cb0 100644
--- a/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild
+++ b/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild,v 1.1 2011/06/30 00:26:30 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild,v 1.2 2011/11/20 22:32:27 dilfridge Exp $
EAPI=4
@@ -28,7 +28,7 @@ IUSE="cvs debug git reviewboard subversion"
DEPEND="
dev-libs/boost
reviewboard? ( dev-libs/qjson )
- subversion? ( >=dev-vcs/subversion-1.3 )
+ subversion? ( <dev-vcs/subversion-1.7 )
"
RDEPEND="${DEPEND}
!<dev-util/kdevelop-${KDEVELOP_VERSION}:4