summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-06-05 13:45:20 +0000
committerJohannes Huber <johu@gentoo.org>2012-06-05 13:45:20 +0000
commitcf98ea36f3ad256f4b15c53ae3ca057f66c62ffa (patch)
tree3168b453922677a770cb9ff3e156cb81ce7596a3 /dev-util/kdevplatform
parentRev and EAPI bump. Make better use of eclasses. Cleanup. (diff)
downloadgentoo-2-cf98ea36f3ad256f4b15c53ae3ca057f66c62ffa.tar.gz
gentoo-2-cf98ea36f3ad256f4b15c53ae3ca057f66c62ffa.tar.bz2
gentoo-2-cf98ea36f3ad256f4b15c53ae3ca057f66c62ffa.zip
Remove old.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kdevplatform')
-rw-r--r--dev-util/kdevplatform/ChangeLog8
-rw-r--r--dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch32
-rw-r--r--dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch95
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild74
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.2.3.ebuild70
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.3.0.ebuild69
6 files changed, 7 insertions, 341 deletions
diff --git a/dev-util/kdevplatform/ChangeLog b/dev-util/kdevplatform/ChangeLog
index 6841bd9da4ef..4efce107435f 100644
--- a/dev-util/kdevplatform/ChangeLog
+++ b/dev-util/kdevplatform/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/kdevplatform
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.67 2012/06/05 13:15:02 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.68 2012/06/05 13:45:19 johu Exp $
+
+ 05 Jun 2012; Johannes Huber <johu@gentoo.org>
+ -files/kdevplatform-1.2.3-svn17-1.patch,
+ -files/kdevplatform-1.2.3-svn17-2.patch, -kdevplatform-1.2.3-r1.ebuild,
+ -kdevplatform-1.2.3.ebuild, -kdevplatform-1.3.0.ebuild:
+ Remove old.
05 Jun 2012; Johannes Huber <johu@gentoo.org> kdevplatform-1.3.1.ebuild:
Stable for x86, wrt bug #418959
diff --git a/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch b/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch
deleted file mode 100644
index c1ca7582e194..000000000000
--- a/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-1.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-commit 74dec52749e3c3af2ac6492f50e2676128f35b27
-Author: Milian Wolff <mail@milianw.de>
-Date: Fri Nov 18 16:26:06 2011 +0100
-
- fix svn api usage: use svn_dirent_canonicalize instead of svn_path_internal_style
-
- this was suggested by Stephan Sperling
-
- CCBUG: 284061
-
-diff --git a/plugins/subversion/kdevsvncpp/path.cpp b/plugins/subversion/kdevsvncpp/path.cpp
-index eaa84c1..4dced08 100644
---- a/plugins/subversion/kdevsvncpp/path.cpp
-+++ b/plugins/subversion/kdevsvncpp/path.cpp
-@@ -24,6 +24,7 @@
-
- // subversion api
- #include "svn_path.h"
-+#include "svn_dirent_uri.h"
-
- // apr api
- #include "apr_file_io.h"
-@@ -63,8 +64,7 @@ namespace svn
- m_path = "";
- else
- {
-- const char * int_path =
-- svn_path_internal_style(path, pool.pool());
-+ const char * int_path = svn_dirent_canonicalize(path, pool);
-
- m_path = int_path;
-
diff --git a/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch b/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch
deleted file mode 100644
index a240eedc4380..000000000000
--- a/dev-util/kdevplatform/files/kdevplatform-1.2.3-svn17-2.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-commit cc7f0798d314cdac14b90e427abe22e99c6bd591
-Author: Milian Wolff <mail@milianw.de>
-Date: Fri Nov 18 16:23:36 2011 +0100
-
- properly initialize client context for compatibility with subversion API
-
- this should hopefully fix the crash with svn 1.7 in kdevelop, please test
-
- BUG: 284061
-
-diff --git a/plugins/subversion/kdevsvncpp/context.cpp b/plugins/subversion/kdevsvncpp/context.cpp
-index d277591..ddbb657 100644
---- a/plugins/subversion/kdevsvncpp/context.cpp
-+++ b/plugins/subversion/kdevsvncpp/context.cpp
-@@ -65,7 +65,7 @@ public:
- bool logIsSet;
- int promptCounter;
- Pool pool;
-- svn_client_ctx_t ctx;
-+ svn_client_ctx_t * ctx;
- std::string username;
- std::string password;
- std::string logMessage;
-@@ -205,26 +205,26 @@ public:
- svn_auth_open(&ab, providers, pool);
-
- // initialize ctx structure
-- memset(&ctx, 0, sizeof(ctx));
-+ svn_client_create_context(&ctx, pool);
-
- // get the config based on the configDir passed in
-- svn_config_get_config(&ctx.config, c_configDir, pool);
-+ svn_config_get_config(&ctx->config, c_configDir, pool);
-
- // tell the auth functions where the config is
- svn_auth_set_parameter(ab, SVN_AUTH_PARAM_CONFIG_DIR,
- c_configDir);
-
-- ctx.auth_baton = ab;
-- ctx.log_msg_func = onLogMsg;
-- ctx.log_msg_baton = this;
-- ctx.notify_func = onNotify;
-- ctx.notify_baton = this;
-- ctx.cancel_func = onCancel;
-- ctx.cancel_baton = this;
-+ ctx->auth_baton = ab;
-+ ctx->log_msg_func = onLogMsg;
-+ ctx->log_msg_baton = this;
-+ ctx->notify_func = onNotify;
-+ ctx->notify_baton = this;
-+ ctx->cancel_func = onCancel;
-+ ctx->cancel_baton = this;
-
- #if (SVN_VER_MAJOR >= 1) && (SVN_VER_MINOR >= 2)
-- ctx.notify_func2 = onNotify2;
-- ctx.notify_baton2 = this;
-+ ctx->notify_func2 = onNotify2;
-+ ctx->notify_baton2 = this;
- #endif
- }
-
-@@ -234,7 +234,7 @@ public:
- if (!value)
- param = (void *)"1";
-
-- svn_auth_set_parameter(ctx.auth_baton,
-+ svn_auth_set_parameter(ctx->auth_baton,
- SVN_AUTH_PARAM_NO_AUTH_CACHE,
- param);
- }
-@@ -245,7 +245,7 @@ public:
- username = usr;
- password = pwd;
-
-- svn_auth_baton_t * ab = ctx.auth_baton;
-+ svn_auth_baton_t * ab = ctx->auth_baton;
- svn_auth_set_parameter(ab, SVN_AUTH_PARAM_DEFAULT_USERNAME,
- username.c_str());
- svn_auth_set_parameter(ab, SVN_AUTH_PARAM_DEFAULT_PASSWORD,
-@@ -654,13 +654,13 @@ public:
-
- Context::operator svn_client_ctx_t * ()
- {
-- return &(m->ctx);
-+ return m->ctx;
- }
-
- svn_client_ctx_t *
- Context::ctx()
- {
-- return &(m->ctx);
-+ return m->ctx;
- }
-
- void
diff --git a/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild b/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild
deleted file mode 100644
index a2284bf36449..000000000000
--- a/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.3-r1.ebuild,v 1.2 2012/03/31 10:24:26 dilfridge Exp $
-
-EAPI=4
-
-KMNAME="kdevelop"
-KDE_SCM="git"
-EGIT_REPONAME="${PN}"
-KDE_MINIMAL="4.6"
-VIRTUALX_REQUIRED=test
-KDE_LINGUAS="ca ca@valencia da de en_GB es et fr it nb nds nl pt pt_BR ru sl sv th uk zh_CN zh_TW"
-inherit kde4-base
-
-DESCRIPTION="KDE development support libraries and apps"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-# Moved to playground for now
-# bazaar kompare mercurial
-LICENSE="GPL-2 LGPL-2"
-IUSE="cvs debug git reviewboard subversion"
-
-# Moved to playground for now
-# bazaar? ( dev-vcs/bzr )
-# kompare? ( $(add_kdebase_dep kompare) )
-# mercurial? ( dev-vcs/mercurial )
-# block - some plugins moved to kdevplatform from kdevelop
-DEPEND="
- dev-libs/boost
- reviewboard? ( dev-libs/qjson )
- subversion? ( dev-vcs/subversion )
-"
-RDEPEND="${DEPEND}
- !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
- !dev-util/kdevelop-git
- $(add_kdebase_dep konsole)
- cvs? ( dev-vcs/cvs )
- git? ( dev-vcs/git )
-"
-
-# Quite few fails and upstream is aware
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}"-svn17-[12].patch
-)
-
-src_prepare() {
- kde4-base_src_prepare
-
- # FindKDevPlatform.cmake is installed by kdelibs
- sed -i \
- -e '/cmakeFiles/s/^/#DONOTINSTALL/' \
- cmake/modules/CMakeLists.txt || die
-}
-
-# Moved to playground for now
-# $(cmake-utils_use_build bazaar)
-# $(cmake-utils_use_with kompare)
-# $(cmake-utils_use_build mercurial)
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_build cvs)
- $(cmake-utils_use_build git)
- $(cmake-utils_use_with reviewboard QJSON)
- $(cmake-utils_use_build subversion)
- $(cmake-utils_use_with subversion SubversionLibrary)
- )
-
- kde4-base_src_configure
-}
-
-# bug 276208
-src_test() { : ; }
diff --git a/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild b/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild
deleted file mode 100644
index 901975fd207f..000000000000
--- a/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.3.ebuild,v 1.5 2012/04/22 12:06:49 maekke Exp $
-
-EAPI=4
-
-KMNAME="kdevelop"
-KDE_SCM="git"
-EGIT_REPONAME="${PN}"
-KDE_MINIMAL="4.6"
-VIRTUALX_REQUIRED=test
-KDE_LINGUAS="ca ca@valencia da de en_GB es et fr it nb nds nl pt pt_BR ru sl sv th uk zh_CN zh_TW"
-inherit kde4-base
-
-DESCRIPTION="KDE development support libraries and apps"
-
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-# Moved to playground for now
-# bazaar kompare mercurial
-LICENSE="GPL-2 LGPL-2"
-IUSE="cvs debug git reviewboard subversion"
-
-# Moved to playground for now
-# bazaar? ( dev-vcs/bzr )
-# kompare? ( $(add_kdebase_dep kompare) )
-# mercurial? ( dev-vcs/mercurial )
-# block - some plugins moved to kdevplatform from kdevelop
-DEPEND="
- dev-libs/boost
- reviewboard? ( dev-libs/qjson )
- subversion? ( <dev-vcs/subversion-1.7 )
-"
-RDEPEND="${DEPEND}
- !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
- !dev-util/kdevelop-git
- $(add_kdebase_dep konsole)
- cvs? ( dev-vcs/cvs )
- git? ( dev-vcs/git )
-"
-
-# Quite few fails and upstream is aware
-RESTRICT="test"
-
-src_prepare() {
- kde4-base_src_prepare
-
- # FindKDevPlatform.cmake is installed by kdelibs
- sed -i \
- -e '/cmakeFiles/s/^/#DONOTINSTALL/' \
- cmake/modules/CMakeLists.txt || die
-}
-
-# Moved to playground for now
-# $(cmake-utils_use_build bazaar)
-# $(cmake-utils_use_with kompare)
-# $(cmake-utils_use_build mercurial)
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_build cvs)
- $(cmake-utils_use_build git)
- $(cmake-utils_use_with reviewboard QJSON)
- $(cmake-utils_use_build subversion)
- $(cmake-utils_use_with subversion SubversionLibrary)
- )
-
- kde4-base_src_configure
-}
-
-# bug 276208
-src_test() { : ; }
diff --git a/dev-util/kdevplatform/kdevplatform-1.3.0.ebuild b/dev-util/kdevplatform/kdevplatform-1.3.0.ebuild
deleted file mode 100644
index 7a94bac8d151..000000000000
--- a/dev-util/kdevplatform/kdevplatform-1.3.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.3.0.ebuild,v 1.2 2012/03/31 10:24:26 dilfridge Exp $
-
-EAPI=4
-
-KMNAME="kdevelop"
-KDE_SCM="git"
-KDE_MINIMAL="4.7"
-VIRTUALX_REQUIRED=test
-KDE_LINGUAS="bs ca ca@valencia da de el en_GB es et fi fr gl it nb nds nl pl pt
-pt_BR ru sl sv th uk zh_CN zh_TW"
-EGIT_REPONAME="${PN}"
-
-inherit kde4-base
-
-DESCRIPTION="KDE development support libraries and apps"
-LICENSE="GPL-2 LGPL-2"
-IUSE="cvs debug git reviewboard subversion"
-
-if [[ $PV == *9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-fi
-
-# Moved to playground for now
-# bazaar? ( dev-vcs/bzr )
-# kompare? ( $(add_kdebase_dep kompare) )
-# mercurial? ( dev-vcs/mercurial )
-DEPEND="
- dev-libs/boost
-"
-RDEPEND="${DEPEND}
- !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
- $(add_kdebase_dep konsole)
- cvs? ( dev-vcs/cvs )
- git? ( dev-vcs/git )
- reviewboard? ( dev-libs/qjson )
- subversion? ( dev-vcs/subversion )
-"
-
-src_prepare() {
- kde4-base_src_prepare
-
- # FindKDevPlatform.cmake is installed by kdelibs
- sed -i \
- -e '/cmakeFiles/s/^/#DONOTINSTALL/' \
- cmake/modules/CMakeLists.txt || die
-}
-
-# Moved to playground for now
-# $(cmake-utils_use_build bazaar)
-# $(cmake-utils_use_with kompare)
-# $(cmake-utils_use_build mercurial)
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_build cvs)
- $(cmake-utils_use_build git)
- $(cmake-utils_use_with reviewboard QJSON)
- $(cmake-utils_use_build subversion)
- $(cmake-utils_use_with subversion SubversionLibrary)
- )
-
- kde4-base_src_configure
-}
-
-# bug 276208
-src_test() { : ; }