summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-04-02 02:58:38 +0000
committerTim Harder <radhermit@gentoo.org>2015-04-02 02:58:38 +0000
commit3702fc543eb8d4d71b7b9023a3b07ebb28320b14 (patch)
tree955fb8cdfb600c8fb82e8cc9e69f5d93934559d0 /dev-util/pkgcheck/pkgcheck-9999.ebuild
parentUpdate HOMEPAGE, bug 544802. (diff)
downloadgentoo-2-3702fc543eb8d4d71b7b9023a3b07ebb28320b14.tar.gz
gentoo-2-3702fc543eb8d4d71b7b9023a3b07ebb28320b14.tar.bz2
gentoo-2-3702fc543eb8d4d71b7b9023a3b07ebb28320b14.zip
Rename pkgcore-checks to pkgcheck and version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
new file mode 100644
index 000000000000..e05a097c5580
--- /dev/null
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcheck/pkgcheck-9999.ebuild,v 1.1 2015/04/02 02:58:38 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgcore/pkgcheck.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore-based QA utility"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+
+RDEPEND="=sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
+ =dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # disable snakeoil 2to3 caching...
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS NEWS.rst )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo "updating pkgcore plugin cache"
+ python_foreach_impl pplugincache pkgcheck.plugins
+}