summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-08-27 17:25:00 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-08-27 17:25:00 +0000
commit5230594f4e8fd0b974b38fb9f4c2eda140549a4b (patch)
treeb234047b6e5c4e236a5d75aab1bf4e5e929cd3d5 /dev-util/pkgconfig
parentDie if both amd64 and x86 are set. (diff)
downloadgentoo-2-5230594f4e8fd0b974b38fb9f4c2eda140549a4b.tar.gz
gentoo-2-5230594f4e8fd0b974b38fb9f4c2eda140549a4b.tar.bz2
gentoo-2-5230594f4e8fd0b974b38fb9f4c2eda140549a4b.zip
Bump to 0.22
- Make Requires.private a whole lot more useful by traversing the whole tree, not just the top-level, for Cflags. - Add support for using the system glib. - Update URL to pkg-config website - Fix some win32 problems. - Other minor fixes. (Portage version: 2.1.3.6)
Diffstat (limited to 'dev-util/pkgconfig')
-rw-r--r--dev-util/pkgconfig/ChangeLog13
-rw-r--r--dev-util/pkgconfig/files/digest-pkgconfig-0.223
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.22.ebuild47
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index 4768b8c94d8d..db99a7c5fbd4 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-util/pkgconfig
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.62 2007/06/27 05:51:50 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.63 2007/08/27 17:25:00 dang Exp $
+
+*pkgconfig-0.22 (27 Aug 2007)
+
+ 27 Aug 2007; Daniel Gryniewicz <dang@gentoo.org> +pkgconfig-0.22.ebuild:
+ Bump to 0.22
+ - Make Requires.private a whole lot more useful by traversing the
+ whole tree, not just the top-level, for Cflags.
+ - Add support for using the system glib.
+ - Update URL to pkg-config website
+ - Fix some win32 problems.
+ - Other minor fixes.
27 Jun 2007; Markus Rothe <corsair@gentoo.org> pkgconfig-0.21-r1.ebuild:
Stable on ppc64; bug #182981
diff --git a/dev-util/pkgconfig/files/digest-pkgconfig-0.22 b/dev-util/pkgconfig/files/digest-pkgconfig-0.22
new file mode 100644
index 000000000000..46ebd4dede72
--- /dev/null
+++ b/dev-util/pkgconfig/files/digest-pkgconfig-0.22
@@ -0,0 +1,3 @@
+MD5 fd5c547e9d66ba49bc735ccb8c791f2a pkg-config-0.22.tar.gz 1006425
+RMD160 f82754f9892469d2865cc5d2fd3c2ca4513dab5b pkg-config-0.22.tar.gz 1006425
+SHA256 7e0761b47d604847006e7c6caa9b9cf044530a516ff84395450edcfa3c2febe6 pkg-config-0.22.tar.gz 1006425
diff --git a/dev-util/pkgconfig/pkgconfig-0.22.ebuild b/dev-util/pkgconfig/pkgconfig-0.22.ebuild
new file mode 100644
index 000000000000..093ce55746ca
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.22.ebuild,v 1.1 2007/08/27 17:25:00 dang Exp $
+
+inherit flag-o-matic eutils
+
+MY_PN="pkg-config"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+
+SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="hardened"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch ${FILESDIR}/${MY_PN}-0.21-fix-tests.patch
+
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+}
+
+src_compile() {
+ local myconf
+
+ # Force using all the requirements when linking, so that needed -pthread
+ # lines are inherited between libraries
+ use elibc_FreeBSD && myconf="${myconf} --enable-indirect-deps"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}