summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-23 19:20:05 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-23 19:20:05 +0000
commit4520e14c39ea1b1af5e767b291d985654ef392ab (patch)
tree97812c2a68db8b163a9d6f4549618731bfb59ef6 /dev-util/strace
parentFixed ebuild that mount.* would be installed. Closes #17823. (diff)
downloadgentoo-2-4520e14c39ea1b1af5e767b291d985654ef392ab.tar.gz
gentoo-2-4520e14c39ea1b1af5e767b291d985654ef392ab.tar.bz2
gentoo-2-4520e14c39ea1b1af5e767b291d985654ef392ab.zip
added selinux support
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog5
-rw-r--r--dev-util/strace/files/digest-strace-4.4-r11
-rw-r--r--dev-util/strace/strace-4.4-r1.ebuild14
3 files changed, 15 insertions, 5 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 3fe060fe5005..36b8bb5fd109 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-util/strace
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.14 2003/03/22 22:53:43 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.15 2003/03/23 19:16:45 method Exp $
*strace-4.4.93 (16 Feb 2003)
@@ -15,6 +15,9 @@
*strace-4.4-r1 (31 Dec 2002)
+ 23 Mar 2003; Joshua Brindle <method@gentoo.org> strace-4.4-r1.ebuild:
+ added selinux support, thanks pebenito
+
22 Mar 2003; Zach Welch <zwelch@gentoo.org> strace-4.4-r1.ebuild,
files/strace-4.4-arm-configure.patch, files/strace-4.4-arm.patch:
add ARM patches for strace
diff --git a/dev-util/strace/files/digest-strace-4.4-r1 b/dev-util/strace/files/digest-strace-4.4-r1
index 7d07987d9a58..c3c7a5db82eb 100644
--- a/dev-util/strace/files/digest-strace-4.4-r1
+++ b/dev-util/strace/files/digest-strace-4.4-r1
@@ -1 +1,2 @@
MD5 7246ce73640760fa7e8357fd9ecf7af3 strace_4.4-1.tar.gz 398273
+MD5 7b99ffc22a7604140f1ff37ee435cc3e strace-4.4-selinux.patch.bz2 4137
diff --git a/dev-util/strace/strace-4.4-r1.ebuild b/dev-util/strace/strace-4.4-r1.ebuild
index ae4f792468e0..cefba5755871 100644
--- a/dev-util/strace/strace-4.4-r1.ebuild
+++ b/dev-util/strace/strace-4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4-r1.ebuild,v 1.5 2003/03/22 22:53:43 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4-r1.ebuild,v 1.6 2003/03/23 19:16:45 method Exp $
# NOTE: For some reason, upstream has changed the naming scheme
# for the tarballs to something quite lame:
@@ -13,20 +13,26 @@
# - Jon Nelson, 27 Apr 2002
DESCRIPTION="A usefull diagnostic, instructional, and debugging tool"
-SRC_URI="mirror://sourceforge/strace/strace_4.4-1.tar.gz"
+SRC_URI="mirror://sourceforge/strace/strace_4.4-1.tar.gz
+ selinux? mirror://gentoo/${P}-selinux.patch.bz2"
HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ~ppc ~sparc alpha hppa arm"
-IUSE="static"
+IUSE="static selinux"
+inherit eutils
DEPEND="virtual/glibc
- sys-devel/autoconf"
+ sys-devel/autoconf
+ selinux? ( >=sys-apps/selinux-small )"
src_unpack() {
unpack ${A}
cd ${S}
+
+ use selinux && epatch ${DISTDIR}/${P}-selinux.patch.bz2
+
if [ "${ARCH}" = "arm" ]; then
epatch ${FILESDIR}/${P}-arm.patch
epatch ${FILESDIR}/${P}-arm-configure.patch