summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-06-17 22:16:40 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-06-17 22:16:40 +0000
commit8fed528d18c92791c904cba92b0e4fa7e5a58d28 (patch)
tree310d1b36d1b0eb0b812b7a2f2ba96a53dfd617ac /dev-util/ticpp
parentnet-analyzer/ike-scan: Fix bufferoverflow, #277556; bump to EAPI=4 (diff)
downloadgentoo-2-8fed528d18c92791c904cba92b0e4fa7e5a58d28.tar.gz
gentoo-2-8fed528d18c92791c904cba92b0e4fa7e5a58d28.tar.bz2
gentoo-2-8fed528d18c92791c904cba92b0e4fa7e5a58d28.zip
Add new snapshot, wrt to bug #412081
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ticpp')
-rw-r--r--dev-util/ticpp/ChangeLog7
-rw-r--r--dev-util/ticpp/ticpp-0_p20120423.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-util/ticpp/ChangeLog b/dev-util/ticpp/ChangeLog
index f96769c360bc..489483e07425 100644
--- a/dev-util/ticpp/ChangeLog
+++ b/dev-util/ticpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ticpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ticpp/ChangeLog,v 1.6 2012/06/17 22:13:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ticpp/ChangeLog,v 1.7 2012/06/17 22:16:40 ago Exp $
+
+*ticpp-0_p20120423 (17 Jun 2012)
+
+ 17 Jun 2012; Agostino Sarubbo <ago@gentoo.org> +ticpp-0_p20120423.ebuild:
+ Add new snapshot, wrt to bug #412081
17 Jun 2012; Agostino Sarubbo <ago@gentoo.org> metadata.xml:
Take maintainership
diff --git a/dev-util/ticpp/ticpp-0_p20120423.ebuild b/dev-util/ticpp/ticpp-0_p20120423.ebuild
new file mode 100644
index 000000000000..d613991690b7
--- /dev/null
+++ b/dev-util/ticpp/ticpp-0_p20120423.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ticpp/ticpp-0_p20120423.ebuild,v 1.1 2012/06/17 22:16:40 ago Exp $
+
+EAPI=4
+
+DESCRIPTION="A completely new interface to TinyXML that uses MANY of the C++ strengths"
+HOMEPAGE="http://code.google.com/p/ticpp/"
+SRC_URI="http://dev.gentoo.org/~ago/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc"
+
+DEPEND=">=dev-util/premake-4.3
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ premake4 gmake || die
+
+ sed -i "s:\$(ARCH)::g" TiCPP.make || die
+}
+
+src_compile() {
+ local myconf
+ use !debug && myconf="config=release"
+ emake ${myconf}
+
+ if use doc ; then
+ sed -i -e '/GENERATE_HTMLHELP/s:YES:NO:' dox || die
+ doxygen dox || die
+ fi
+}
+
+src_install () {
+ insinto /usr/include/ticpp
+ doins *.h
+
+ if use debug ; then
+ dolib lib/libticppd.a
+ else
+ dolib lib/libticpp.a
+ fi
+
+ dodoc {changes,readme,tutorial_gettingStarted,tutorial_ticpp}.txt
+
+ use doc && dohtml -r docs/*
+}