summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-18 20:56:21 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-18 20:56:21 +0000
commit2fc653c1279340ad24c2830ca76d1316b4db26f1 (patch)
tree74ff4e6269838978c8fd472e5876fe6ca025a237 /dev-util/valgrind
parentFix use masking for net-libs/cyassl[aes-ni], bug #470220 (diff)
downloadgentoo-2-2fc653c1279340ad24c2830ca76d1316b4db26f1.tar.gz
gentoo-2-2fc653c1279340ad24c2830ca76d1316b4db26f1.tar.bz2
gentoo-2-2fc653c1279340ad24c2830ca76d1316b4db26f1.zip
Fix link error with gcc-4.8, bug #466488
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.8.1-gcc-4.8-memmove.patch26
-rw-r--r--dev-util/valgrind/valgrind-3.8.1-r1.ebuild109
3 files changed, 142 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 9f476af85a25..f3d428aaffce 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.169 2013/05/26 12:17:05 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.170 2013/06/18 20:56:20 blueness Exp $
+
+*valgrind-3.8.1-r1 (18 Jun 2013)
+
+ 18 Jun 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/valgrind-3.8.1-gcc-4.8-memmove.patch, +valgrind-3.8.1-r1.ebuild:
+ Fix link error with gcc-4.8, bug #466488
26 May 2013; Anthony G. Basile <blueness@gentoo.org> valgrind-3.8.1.ebuild:
Respect AR, bug #468114, thanks Michael Mair-Keimberger
diff --git a/dev-util/valgrind/files/valgrind-3.8.1-gcc-4.8-memmove.patch b/dev-util/valgrind/files/valgrind-3.8.1-gcc-4.8-memmove.patch
new file mode 100644
index 000000000000..453a67859ee7
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.8.1-gcc-4.8-memmove.patch
@@ -0,0 +1,26 @@
+Index: coregrind/m_main.c
+===================================================================
+--- coregrind/m_main.c (revision 13287)
++++ coregrind/m_main.c (revision 13288)
+@@ -2636,8 +2636,8 @@
+
+ From this derive two requirements:
+
+- 1. gcc may emit calls to memcpy and memset to deal with structure
+- assignments etc. Since we have chosen to ignore all the
++ 1. gcc may emit calls to memcpy, memmove and memset to deal with
++ structure assignments etc. Since we have chosen to ignore all the
+ "normal" supporting libraries, we have to provide our own
+ implementations of them. No problem.
+
+@@ -2651,6 +2651,10 @@
+ void* memcpy(void *dest, const void *src, SizeT n) {
+ return VG_(memcpy)(dest,src,n);
+ }
++void* memmove(void *dest, const void *src, SizeT n);
++void* memmove(void *dest, const void *src, SizeT n) {
++ return VG_(memmove)(dest,src,n);
++}
+ void* memset(void *s, int c, SizeT n);
+ void* memset(void *s, int c, SizeT n) {
+ return VG_(memset)(s,c,n);
diff --git a/dev-util/valgrind/valgrind-3.8.1-r1.ebuild b/dev-util/valgrind/valgrind-3.8.1-r1.ebuild
new file mode 100644
index 000000000000..51c75ebc0157
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.8.1-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.8.1-r1.ebuild,v 1.1 2013/06/18 20:56:20 blueness Exp $
+
+EAPI="4"
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ # Respect CFLAGS, LDFLAGS
+ epatch "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+
+ # Changing Makefile.all.am to disable SSP
+ epatch "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.8.0-non-exec-stack.patch
+
+ # Fix for glibc 2.18, bug #458326
+ epatch "${FILESDIR}"/${PN}-3.8.1-glibc-2.17.patch
+
+ # Fix unwrapped memmove with gcc-4.8, bug #466488
+ epatch "${FILESDIR}"/${PN}-3.8.1-gcc-4.8-memmove.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # Respect ar, bug #468114
+ tc-export AR
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ filter-flags -m64 -mx32
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x86-macos && myconf="${myconf} --enable-only32bit"
+ use x64-macos && myconf="${myconf} --enable-only64bit"
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "Valgrind will not work if glibc does not have debug symbols."
+ elog "To fix this you can add splitdebug to FEATURES in make.conf"
+ elog "and remerge glibc. See:"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=274771"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=388703"
+}