summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-10 23:23:51 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-10 23:23:51 +0000
commitdf1b0b023d9ed5c8a2446ebb20245e39855068ba (patch)
tree12f64a6ee30b9e37183b01139b5b7edd056c86bb /dev-util/w32api
parentversion bump, fixes bug 223239 and 245465 (diff)
downloadgentoo-2-df1b0b023d9ed5c8a2446ebb20245e39855068ba.tar.gz
gentoo-2-df1b0b023d9ed5c8a2446ebb20245e39855068ba.tar.bz2
gentoo-2-df1b0b023d9ed5c8a2446ebb20245e39855068ba.zip
old
Diffstat (limited to 'dev-util/w32api')
-rw-r--r--dev-util/w32api/w32api-3.12.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-util/w32api/w32api-3.12.ebuild b/dev-util/w32api/w32api-3.12.ebuild
deleted file mode 100644
index d51d5d30265b..000000000000
--- a/dev-util/w32api/w32api-3.12.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/w32api/w32api-3.12.ebuild,v 1.1 2008/09/08 02:44:57 vapier Exp $
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-MY_P="${P}-mingw32"
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.7-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf \
- --host=${CTARGET} \
- --prefix=/usr/${CTARGET}/usr \
- || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- emake install DESTDIR="${D}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
- fi
-}