summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-27 22:03:11 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-27 22:03:11 +0000
commit24f7d1425b8861341df678b17fd448e78564ef6d (patch)
tree803241ba8b9c7d2baca177335b525f97126a4dd0 /dev-util
parentVersion bump. introspection adjustements. Fix a regression in pager from 2.30... (diff)
downloadgentoo-2-24f7d1425b8861341df678b17fd448e78564ef6d.tar.gz
gentoo-2-24f7d1425b8861341df678b17fd448e78564ef6d.tar.bz2
gentoo-2-24f7d1425b8861341df678b17fd448e78564ef6d.zip
Version bump. Fix RCS support. Fix support of old pygobject.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meld/ChangeLog7
-rw-r--r--dev-util/meld/meld-1.4.0.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index cf08a5dd6114..834a4beb109d 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.110 2010/09/13 20:58:17 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.111 2010/09/27 22:03:11 eva Exp $
+
+*meld-1.4.0 (27 Sep 2010)
+
+ 27 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org> +meld-1.4.0.ebuild:
+ Version bump. Fix RCS support. Fix support of old pygobject.
*meld-1.3.3 (13 Sep 2010)
diff --git a/dev-util/meld/meld-1.4.0.ebuild b/dev-util/meld/meld-1.4.0.ebuild
new file mode 100644
index 000000000000..0aaa64fcfc93
--- /dev/null
+++ b/dev-util/meld/meld-1.4.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.4.0.ebuild,v 1.1 2010/09/27 22:03:11 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit python gnome2 eutils multilib
+
+DESCRIPTION="A graphical (GNOME 2) diff and merge tool"
+HOMEPAGE="http://meld.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnome"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=dev-python/libgnome-python-2.22
+ >=dev-python/gconf-python-2.22
+ >=dev-python/gnome-vfs-python-2.22 )
+ >=dev-python/pygtk-2.8
+ >=dev-python/pygobject-2.8"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS NEWS help/ChangeLog"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix the prefix so its not in */local/*
+ sed -e 's:/usr/local:/usr:' \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # let the python eclass handle python objects
+ sed -e '/$(PYTHON) .* .import compileall;/s/\t/&#/g' \
+ -i Makefile || die "sed 3 failed"
+
+ # don't run scrollkeeper (with the wrong path), leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/Makefile || die "sed 4 failed"
+
+ # fix test suite
+ sed -e 's,\(for file in \["\)\(meld"\]\),\1bin/\2,' \
+ -e 's,\(open("\)\(meldapp.py")\),\1meld/\2,' \
+ -i tools/check_release || die "sed 5 failed"
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/Makefile || die "sed 5 failed"
+ fi
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/meld
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/meld
+}