summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-12 01:34:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-12 01:34:29 +0000
commitbe600e4c35c458597734405167e7a953b3b3d5c0 (patch)
tree2902766fc518d54a787e54a99cab5067bbaa15e8 /dev-util
parentAdd sus4-copyright. (diff)
downloadgentoo-2-be600e4c35c458597734405167e7a953b3b3d5c0.tar.gz
gentoo-2-be600e4c35c458597734405167e7a953b3b3d5c0.tar.bz2
gentoo-2-be600e4c35c458597734405167e7a953b3b3d5c0.zip
Bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-4.13.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 1db23473b9ca..fa3cb7a4c615 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.37 2009/04/04 10:28:08 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.38 2009/09/12 01:34:28 patrick Exp $
+
+*bouml-4.13.1 (12 Sep 2009)
+
+ 12 Sep 2009; Patrick Lauer <patrick@gentoo.org> +bouml-4.13.1.ebuild:
+ Bump
*bouml-4.12.1 (04 Apr 2009)
diff --git a/dev-util/bouml/bouml-4.13.1.ebuild b/dev-util/bouml/bouml-4.13.1.ebuild
new file mode 100644
index 000000000000..e952566810d7
--- /dev/null
+++ b/dev-util/bouml/bouml-4.13.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-4.13.1.ebuild,v 1.1 2009/09/12 01:34:29 patrick Exp $
+
+EAPI=1
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://downloads.sourceforge.net/bouml/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/qt:3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+ local subdir="${file%/*}"
+ eqmake3 "${file}" -o "${subdir}"/Makefile
+ emake -C "${subdir}" || die "emake failed in ${subdir}"
+ done
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+ || die "emake install failed"
+}