summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-03-24 10:42:00 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-03-24 10:42:00 +0000
commitd0015d806c2bbe34ec0352757b62b7dbd827bec1 (patch)
tree794cd00858b9dd2b9b3209cab0566089e849c322 /dev-util
parentVersion bump, wrt bug #410911. Psi+ support has been removed for now (diff)
downloadgentoo-2-d0015d806c2bbe34ec0352757b62b7dbd827bec1.tar.gz
gentoo-2-d0015d806c2bbe34ec0352757b62b7dbd827bec1.tar.bz2
gentoo-2-d0015d806c2bbe34ec0352757b62b7dbd827bec1.zip
Version bump. EAPI bump. Migration to python-r1.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmdtest/ChangeLog9
-rw-r--r--dev-util/cmdtest/cmdtest-0.6.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-util/cmdtest/ChangeLog b/dev-util/cmdtest/ChangeLog
index 413387800547..9ff09822eefe 100644
--- a/dev-util/cmdtest/ChangeLog
+++ b/dev-util/cmdtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmdtest
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmdtest/ChangeLog,v 1.1 2012/10/07 00:35:56 mschiff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmdtest/ChangeLog,v 1.2 2013/03/24 10:42:00 mschiff Exp $
+
+*cmdtest-0.6 (24 Mar 2013)
+
+ 24 Mar 2013; Marc Schiffbauer <mschiff@gentoo.org> +cmdtest-0.6.ebuild:
+ Version bump. EAPI bump. Migration to python-r1.
*cmdtest-0.5 (07 Oct 2012)
diff --git a/dev-util/cmdtest/cmdtest-0.6.ebuild b/dev-util/cmdtest/cmdtest-0.6.ebuild
new file mode 100644
index 000000000000..c1545dcb3f01
--- /dev/null
+++ b/dev-util/cmdtest/cmdtest-0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmdtest/cmdtest-0.6.ebuild,v 1.1 2013/03/24 10:42:00 mschiff Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="black box tests Unix command line tools"
+HOMEPAGE="http://liw.fi/cmdtest/"
+SRC_URI="http://code.liw.fi/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/ttystatus
+"
+
+src_prepare() {
+ addpredict /proc/self/comm
+ distutils-r1_src_prepare
+}
+