summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2011-03-27 15:06:22 +0000
committerDominik Kapusta <ayoy@gentoo.org>2011-03-27 15:06:22 +0000
commite79a24d0b360c3cf6f18102a34e0180a53654e6f (patch)
treef3b8dce03be002e383b1c714e6fce05bf2122517 /dev-vcs/git-sh
parentStable on alpha, bug #358543 (diff)
downloadgentoo-2-e79a24d0b360c3cf6f18102a34e0180a53654e6f.tar.gz
gentoo-2-e79a24d0b360c3cf6f18102a34e0180a53654e6f.tar.bz2
gentoo-2-e79a24d0b360c3cf6f18102a34e0180a53654e6f.zip
Version bump (bug #347553)
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git-sh')
-rw-r--r--dev-vcs/git-sh/ChangeLog9
-rw-r--r--dev-vcs/git-sh/git-sh-1.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-vcs/git-sh/ChangeLog b/dev-vcs/git-sh/ChangeLog
index 3f6aa4ba6c86..9c09e1d445c8 100644
--- a/dev-vcs/git-sh/ChangeLog
+++ b/dev-vcs/git-sh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git-sh
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/ChangeLog,v 1.2 2010/03/17 16:36:41 sping Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/ChangeLog,v 1.3 2011/03/27 15:06:22 ayoy Exp $
+
+*git-sh-1.1 (27 Mar 2011)
+
+ 27 Mar 2011; Dominik Kapusta <ayoy@gentoo.org> +git-sh-1.1.ebuild:
+ Version bump (bug #347553).
17 Mar 2010; Sebastian Pipping <sping@gentoo.org> git-sh-1.0-r1.ebuild:
Propagate move of dev-util/git to dev-vcs/git
diff --git a/dev-vcs/git-sh/git-sh-1.1.ebuild b/dev-vcs/git-sh/git-sh-1.1.ebuild
new file mode 100644
index 000000000000..d59b822a9c18
--- /dev/null
+++ b/dev-vcs/git-sh/git-sh-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.1.ebuild,v 1.1 2011/03/27 15:06:22 ayoy Exp $
+
+EAPI="2"
+
+DESCRIPTION="A customized bash environment suitable for git work."
+HOMEPAGE="http://github.com/rtomayko/git-sh"
+SRC_URI="http://github.com/rtomayko/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/rtomayko-${PN}-a59681d"
+
+src_prepare() {
+ sed -e 's/git-completion\.bash //' \
+ -e 's:/local::' -i Makefile || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES README.markdown || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "For bash completion in git commands emerge dev-vcs/git"
+ einfo "with bash-completion USE flag."
+ einfo
+}