summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-08-16 05:47:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-08-16 05:47:29 +0000
commit3c0e938a2288fa6b10c8813d8af1062076a36dc4 (patch)
treed217ce2c7bff01b41ee9049c91e9fa39bb9cc4ea /dev-vcs/git
parentStable for PPC (bug #327853). (diff)
downloadgentoo-2-3c0e938a2288fa6b10c8813d8af1062076a36dc4.tar.gz
gentoo-2-3c0e938a2288fa6b10c8813d8af1062076a36dc4.tar.bz2
gentoo-2-3c0e938a2288fa6b10c8813d8af1062076a36dc4.zip
Bug #332935: In newer EAPIs, perl-module brings in dev-lang/perl as well, which we do not always want.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog8
-rw-r--r--dev-vcs/git/git-1.6.4.4.ebuild5
-rw-r--r--dev-vcs/git/git-1.7.0.ebuild5
-rw-r--r--dev-vcs/git/git-1.7.1-r1.ebuild5
-rw-r--r--dev-vcs/git/git-1.7.1.1.ebuild5
-rw-r--r--dev-vcs/git/git-1.7.2-r2.ebuild5
-rw-r--r--dev-vcs/git/git-1.7.2.ebuild5
-rw-r--r--dev-vcs/git/git-9999.ebuild5
8 files changed, 28 insertions, 15 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index b0f338d0913b..65719207c58d 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.22 2010/08/09 20:02:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.23 2010/08/16 05:47:29 robbat2 Exp $
+
+ 16 Aug 2010; Robin H. Johnson <robbat2@gentoo.org> git-1.6.4.4.ebuild,
+ git-1.7.0.ebuild, git-1.7.1-r1.ebuild, git-1.7.1.1.ebuild,
+ git-1.7.2.ebuild, git-1.7.2-r2.ebuild, git-9999.ebuild:
+ Bug #332935: In newer EAPIs, perl-module brings in dev-lang/perl as well,
+ which we do not always want.
*git-1.7.2-r2 (09 Aug 2010)
diff --git a/dev-vcs/git/git-1.6.4.4.ebuild b/dev-vcs/git/git-1.6.4.4.ebuild
index f2629ea78b9a..c68e79bcec30 100644
--- a/dev-vcs/git/git-1.6.4.4.ebuild
+++ b/dev-vcs/git/git-1.6.4.4.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.6.4.4.ebuild,v 1.4 2010/06/22 18:47:46 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.6.4.4.ebuild,v 1.5 2010/08/16 05:47:29 robbat2 Exp $
EAPI=2
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ CDEPEND="
dev-libs/openssl
sys-libs/zlib
app-arch/cpio
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
diff --git a/dev-vcs/git/git-1.7.0.ebuild b/dev-vcs/git/git-1.7.0.ebuild
index 80a5a93b15f3..75ef8d7479d1 100644
--- a/dev-vcs/git/git-1.7.0.ebuild
+++ b/dev-vcs/git/git-1.7.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.0.ebuild,v 1.6 2010/07/18 12:56:59 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.0.ebuild,v 1.7 2010/08/16 05:47:29 robbat2 Exp $
EAPI=2
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav x
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
diff --git a/dev-vcs/git/git-1.7.1-r1.ebuild b/dev-vcs/git/git-1.7.1-r1.ebuild
index 1372e1e6afd4..09afcf5eec3a 100644
--- a/dev-vcs/git/git-1.7.1-r1.ebuild
+++ b/dev-vcs/git/git-1.7.1-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.1-r1.ebuild,v 1.8 2010/07/18 16:53:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.1-r1.ebuild,v 1.9 2010/08/16 05:47:29 robbat2 Exp $
EAPI=2
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav x
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
diff --git a/dev-vcs/git/git-1.7.1.1.ebuild b/dev-vcs/git/git-1.7.1.1.ebuild
index be50262dcfad..9c62d1a32ddc 100644
--- a/dev-vcs/git/git-1.7.1.1.ebuild
+++ b/dev-vcs/git/git-1.7.1.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.1.1.ebuild,v 1.1 2010/06/30 00:15:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.1.1.ebuild,v 1.2 2010/08/16 05:47:29 robbat2 Exp $
EAPI=2
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav x
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
diff --git a/dev-vcs/git/git-1.7.2-r2.ebuild b/dev-vcs/git/git-1.7.2-r2.ebuild
index f73c742c5285..e33f3f89be80 100644
--- a/dev-vcs/git/git-1.7.2-r2.ebuild
+++ b/dev-vcs/git/git-1.7.2-r2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2-r2.ebuild,v 1.1 2010/08/09 20:02:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2-r2.ebuild,v 1.2 2010/08/16 05:47:29 robbat2 Exp $
EAPI=3
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav x
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
diff --git a/dev-vcs/git/git-1.7.2.ebuild b/dev-vcs/git/git-1.7.2.ebuild
index 8860499ff1f3..bf805226e19d 100644
--- a/dev-vcs/git/git-1.7.2.ebuild
+++ b/dev-vcs/git/git-1.7.2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.ebuild,v 1.1 2010/07/22 16:56:06 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.ebuild,v 1.2 2010/08/16 05:47:29 robbat2 Exp $
EAPI=2
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav x
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index c072c0a1ba99..35f16c2bc523 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.4 2010/06/22 18:47:46 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.5 2010/08/16 05:47:29 robbat2 Exp $
EAPI=2
+GENTOO_DEPEND_ON_PERL=no
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
[ "$PV" == "9999" ] && inherit git
@@ -35,7 +36,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav x
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl )
+ perl? ( dev-lang/perl[-build] )
tk? ( dev-lang/tk )
curl? (
net-misc/curl