summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 19:27:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 19:27:19 +0000
commit0b6bdbdbce9e584f520de73364dd52b932fbaa5c (patch)
tree9e86d0a31c8e3883ae56a76fb6d8af3494151f8c /dev-vcs/gitosis
parentDelete older ebuilds. (diff)
downloadgentoo-2-0b6bdbdbce9e584f520de73364dd52b932fbaa5c.tar.gz
gentoo-2-0b6bdbdbce9e584f520de73364dd52b932fbaa5c.tar.bz2
gentoo-2-0b6bdbdbce9e584f520de73364dd52b932fbaa5c.zip
Use Python 2 (bug #329481).
(Portage version: 2.2.0_alpha29_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitosis')
-rw-r--r--dev-vcs/gitosis/ChangeLog8
-rw-r--r--dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild10
-rw-r--r--dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild10
3 files changed, 22 insertions, 6 deletions
diff --git a/dev-vcs/gitosis/ChangeLog b/dev-vcs/gitosis/ChangeLog
index 490287cccf41..30965dbc4474 100644
--- a/dev-vcs/gitosis/ChangeLog
+++ b/dev-vcs/gitosis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/gitosis
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/ChangeLog,v 1.2 2010/06/19 16:23:07 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/ChangeLog,v 1.3 2011/04/06 19:27:19 arfrever Exp $
+
+ 06 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gitosis-0.2_p20080626.ebuild, gitosis-0.2_p20080825.ebuild:
+ Use Python 2 (bug #329481).
19 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gitosis-0.2_p20080626.ebuild, gitosis-0.2_p20080825.ebuild:
diff --git a/dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild b/dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild
index 07e90097df6c..374650166050 100644
--- a/dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild
+++ b/dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild,v 1.2 2010/06/19 16:23:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/gitosis-0.2_p20080626.ebuild,v 1.3 2011/04/06 19:27:19 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit eutils distutils
@@ -26,6 +29,9 @@ S=${WORKDIR}/gitosis
DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
enewgroup git
enewuser git -1 /bin/sh /var/spool/gitosis git
}
diff --git a/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild b/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild
index 1aa03b40fefd..763275e5a8c5 100644
--- a/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild
+++ b/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild,v 1.2 2010/06/19 16:23:07 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild,v 1.3 2011/04/06 19:27:19 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit eutils distutils
@@ -26,6 +29,9 @@ S=${WORKDIR}/gitosis
DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
enewgroup git
enewuser git -1 /bin/sh /var/spool/gitosis git
}