summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-09 00:00:38 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-09-09 00:00:38 +0000
commit543a965e13fe9d3ba290fe75d2344acecef1a478 (patch)
tree947e37f49f6eed7e4d03ab2dffecfa3474e836f4 /dev-vcs
parentadded ~arm (tested by me) (diff)
downloadgentoo-2-543a965e13fe9d3ba290fe75d2344acecef1a478.tar.gz
gentoo-2-543a965e13fe9d3ba290fe75d2344acecef1a478.tar.bz2
gentoo-2-543a965e13fe9d3ba290fe75d2344acecef1a478.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hg-fast-export/ChangeLog8
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-vcs/hg-fast-export/ChangeLog b/dev-vcs/hg-fast-export/ChangeLog
index b28013fc45ca..8613db9a38da 100644
--- a/dev-vcs/hg-fast-export/ChangeLog
+++ b/dev-vcs/hg-fast-export/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/hg-fast-export
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-fast-export/ChangeLog,v 1.3 2014/09/08 23:55:11 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-fast-export/ChangeLog,v 1.4 2014/09/09 00:00:38 ottxor Exp $
+
+*hg-fast-export-20140706 (09 Sep 2014)
+
+ 09 Sep 2014; Christoph Junghans <ottxor@gentoo.org>
+ +hg-fast-export-20140706.ebuild:
+ version bump
08 Sep 2014; Christoph Junghans <ottxor@gentoo.org>
hg-fast-export-20140328.ebuild:
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild
new file mode 100644
index 000000000000..dcb12bb39ad1
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild,v 1.1 2014/09/09 00:00:38 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="2c21922ad1795e1d305dac6bdb977f2e50eb809e"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ sed -e '/^PYTHON/s/python/&2/' \
+ -e 's/PYTHON/E&/g' \
+ -i "${PN}".sh || die
+ rm Makefile || die #don't compile old svn2git code
+}
+
+src_install() {
+ newbin "${PN}".sh "${PN}"
+ dodoc README
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_domodule hg2git.py
+}