summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-10-11 15:23:59 +0000
committerMike Gilbert <floppym@gentoo.org>2011-10-11 15:23:59 +0000
commitf12e79f39687092401e912d1d26c2d1f0cd89e2c (patch)
treeba3728e5c57cee23db7e25b68d6a8b520971a075 /dev-vcs
parentVersion bump pudb to 2011.3. (diff)
downloadgentoo-2-f12e79f39687092401e912d1d26c2d1f0cd89e2c.tar.gz
gentoo-2-f12e79f39687092401e912d1d26c2d1f0cd89e2c.tar.bz2
gentoo-2-f12e79f39687092401e912d1d26c2d1f0cd89e2c.zip
Version bump.
(Portage version: 2.2.0_alpha65/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog7
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.1.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index af13d0d1bbe3..32e71435239b 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.1 2011/09/07 02:33:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.2 2011/10/11 15:23:59 floppym Exp $
+
+*tortoisehg-2.1.4 (11 Oct 2011)
+
+ 11 Oct 2011; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.1.4.ebuild:
+ Version bump.
*tortoisehg-2.1.3 (07 Sep 2011)
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.1.4.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.1.4.ebuild
new file mode 100644
index 000000000000..0208d5cbf974
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.1.4.ebuild,v 1.1 2011/10/11 15:23:59 floppym Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils multilib
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nautilus"
+
+RDEPEND="dev-python/iniparse
+ dev-python/pygments
+ dev-python/PyQt4
+ dev-python/qscintilla-python
+ >=dev-vcs/mercurial-1.9
+ nautilus? ( dev-python/nautilus-python )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+src_prepare() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO || die
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg || die
+ domenu contrib/${PN}.desktop || die
+
+ if ! use nautilus; then
+ rm -r "${ED}usr/$(get_libdir)/nautilus" || die
+ fi
+}