summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-10-12 12:31:36 +0000
committerMatti Bickel <mabi@gentoo.org>2008-10-12 12:31:36 +0000
commit6fd2572d04213dc98e3d8416fd47473fa8fa2198 (patch)
treef153856263bad8af40d6f58aaea6db258ffd1af2 /eclass/fox.eclass
parentSpecify name of Emacs site-init file explicitely. (diff)
downloadgentoo-2-6fd2572d04213dc98e3d8416fd47473fa8fa2198.tar.gz
gentoo-2-6fd2572d04213dc98e3d8416fd47473fa8fa2198.tar.bz2
gentoo-2-6fd2572d04213dc98e3d8416fd47473fa8fa2198.zip
fix bug #240060
Diffstat (limited to 'eclass/fox.eclass')
-rw-r--r--eclass/fox.eclass22
1 files changed, 15 insertions, 7 deletions
diff --git a/eclass/fox.eclass b/eclass/fox.eclass
index 63fe16a8d577..9fccc28a730b 100644
--- a/eclass/fox.eclass
+++ b/eclass/fox.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/fox.eclass,v 1.7 2007/01/15 20:27:06 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/fox.eclass,v 1.8 2008/10/12 12:31:36 mabi Exp $
# fox eclass
#
@@ -29,7 +29,7 @@
#
# Some concepts borrowed from gst-plugins and gtk-sharp-component eclasses
-inherit eutils libtool
+inherit eutils libtool versionator
FOX_PV="${FOX_PV:-${PV}}"
@@ -110,11 +110,19 @@ fox_src_unpack() {
# use the installed headers and library for apps
for d in ${FOX_APPS} ; do
- sed -i \
- -e "s:-I\$(top_srcdir)/include -I\$(top_builddir)/include:-I\$(includedir)/fox${FOXVER_SUFFIX}:" \
- -e 's:../src/libFOX:-lFOX:' \
- -e 's:\.la::' \
- ${d}/Makefile.am || die "sed ${d}/Makefile.am error"
+ if version_is_at_least "1.6.34" ${PV} ; then
+ sed -i \
+ -e "s:-I\$(top_srcdir)/include -I\$(top_builddir)/include:-I\$(includedir)/fox${FOXVER_SUFFIX}:" \
+ -e 's:$(top_builddir)/src/libFOX:-lFOX:' \
+ -e 's:\.la::' \
+ ${d}/Makefile.am || die "sed ${d}/Makefile.am error"
+ else
+ sed -i \
+ -e "s:-I\$(top_srcdir)/include -I\$(top_builddir)/include:-I\$(includedir)/fox${FOXVER_SUFFIX}:" \
+ -e 's:../src/libFOX:-lFOX:' \
+ -e 's:\.la::' \
+ ${d}/Makefile.am || die "sed ${d}/Makefile.am error"
+ fi
done
# Upstream often has trouble with version number transitions