summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2006-10-07 16:34:30 +0000
committerJim Ramsay <lack@gentoo.org>2006-10-07 16:34:30 +0000
commitdf1d7aac7ea043cea03c55d994b9adc701f9f30a (patch)
treeb7b6a81fc1b54cbb5c8459569f30547af5dcbbb5 /eclass/rox.eclass
parentput init script configuration variables in conf.d - fixes bug #150376 - thank... (diff)
downloadgentoo-2-df1d7aac7ea043cea03c55d994b9adc701f9f30a.tar.gz
gentoo-2-df1d7aac7ea043cea03c55d994b9adc701f9f30a.tar.bz2
gentoo-2-df1d7aac7ea043cea03c55d994b9adc701f9f30a.zip
Bug 150303 part two, adjust LIBDIRPATH before compiling
Diffstat (limited to 'eclass/rox.eclass')
-rw-r--r--eclass/rox.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/rox.eclass b/eclass/rox.eclass
index 686996cd4b4f..ff8f4429219c 100644
--- a/eclass/rox.eclass
+++ b/eclass/rox.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/rox.eclass,v 1.13 2006/10/06 22:07:02 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/rox.eclass,v 1.14 2006/10/07 16:34:30 lack Exp $
# ROX eclass Version 2
@@ -52,15 +52,17 @@ rox_src_compile() {
#Some packages need to be compiled.
chmod 755 AppRun
if [ -d src/ ]; then
- # Bug 150303: Compile with Rox-Clib will fail if the user has 0install
+ # Bug 150303: Check with Rox-Clib will fail if the user has 0install
# installed on their system somewhere, so remove the check for it in the
- # configure script
+ # configure script, and adjust the path that the 'libdir' program uses
+ # to search for it:
if [ -f src/configure.in ]; then
cd src
sed -i.bak -e 's/ROX_CLIB_0LAUNCH/ROX_CLIB/' configure.in
autoconf
cd ..
fi
+ export LIBDIRPATH="/usr/lib/"
# Most rox self-compiles have a 'read' call to wait for the user to
# press return if the compile fails.