summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-07 17:38:38 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-07 17:38:38 +0000
commit286a56bb7f43df37dfcb227d1dc503cc8f472453 (patch)
treea97fa1b87f298396ef817f1da175df8136231d50 /eclass
parentrepoman: Trim trailing whitespace (Manifest recommit) (diff)
downloadgentoo-2-286a56bb7f43df37dfcb227d1dc503cc8f472453.tar.gz
gentoo-2-286a56bb7f43df37dfcb227d1dc503cc8f472453.tar.bz2
gentoo-2-286a56bb7f43df37dfcb227d1dc503cc8f472453.zip
fix confusing message about updating gcc to use SSP from glibc since we also support uclibc
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 45fa683a3528..478c4afca4d5 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.6 2004/09/07 17:08:11 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.7 2004/09/07 17:38:38 lv Exp $
#
# This eclass should contain general toolchain-related functions that are
# expected to not change, or change much.
@@ -275,7 +275,7 @@ do_gcc_SSP_patches() {
# then lets use those for SSP instead of libgcc.
update_gcc_for_libc_ssp() {
if libc_has_ssp ; then
- einfo "Updating gcc to use SSP from glibc..."
+ einfo "Updating gcc to use SSP from libc..."
sed -e 's|^\(LIBGCC2_CFLAGS.*\)$|\1 -D_LIBC_PROVIDES_SSP_|' \
-i ${S}/gcc/Makefile.in || die "Failed to update gcc!"
fi
@@ -498,7 +498,7 @@ libc_has_ssp() {
local my_libc=${ROOT}/${libc_prefix}/${libc_file}
- # Check for the glibc to have the __guard symbols
+ # Check for the libc to have the __guard symbols
if [ "$(readelf -s "${my_libc}" 2>/dev/null | \
grep GLOBAL | grep OBJECT | grep '__guard')" ] && \
[ "$(readelf -s "${my_libc}" 2>/dev/null | \