summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-10-19 11:40:25 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-10-19 11:40:25 +0000
commit42cef92f58733dea742bb946e594adc03ec983a5 (patch)
tree2a3f8d3dee753b27d1638a9472b69a0a34bc555a /eclass
parentAdded a patch to get net-tools to go on 2.6 headers: Bug #31240. (diff)
downloadgentoo-2-42cef92f58733dea742bb946e594adc03ec983a5.tar.gz
gentoo-2-42cef92f58733dea742bb946e594adc03ec983a5.tar.bz2
gentoo-2-42cef92f58733dea742bb946e594adc03ec983a5.zip
fixed dodoc
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils.eclass16
1 files changed, 10 insertions, 6 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index af7e9e0f7fc5..1a3303e1e10e 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.19 2003/10/17 07:14:26 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.20 2003/10/19 11:40:25 lanius Exp $
#
# Author: Jon Nelson <jnelson@gentoo.org>
# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
@@ -44,11 +44,15 @@ distutils_src_install() {
else
${python} setup.py install --root=${D} "$@" || die
fi
-
- dodoc CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO
- dodoc CONTRIBUTORS LICENSE COPYING*
- dodoc Change* MANIFEST* README*
-
+
+ DDOCS="CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO"
+ DDOCS="${DDOCS} CONTRIBUTORS LICENSE COPYING*"
+ DDOCS="${DDOCS} Change* MANIFEST* README*"
+
+ for doc in ${DDOCS}; do
+ [ -s "$doc" ] && dodoc $doc
+ done
+
[ -n "${DOCS}" ] && dodoc ${DOCS}
# deprecated! please use DOCS instead.