summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-11 08:14:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-11 08:14:07 +0000
commit09597e19f15effb4de1a3f5ebc6deeb41fca2b97 (patch)
tree10a3d7ec878298286c22bc25e1c0384f63394f50 /games-action/atanks
parentversion bump (diff)
downloadgentoo-2-09597e19f15effb4de1a3f5ebc6deeb41fca2b97.tar.gz
gentoo-2-09597e19f15effb4de1a3f5ebc6deeb41fca2b97.tar.bz2
gentoo-2-09597e19f15effb4de1a3f5ebc6deeb41fca2b97.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/ChangeLog7
-rw-r--r--games-action/atanks/atanks-3.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index b940847f8185..c81de5a450ce 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/atanks
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.31 2008/06/25 19:24:35 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.32 2008/08/11 08:14:07 mr_bones_ Exp $
+
+*atanks-3.1 (11 Aug 2008)
+
+ 11 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org> +atanks-3.1.ebuild:
+ version bump
25 Jun 2008; nixnut <nixnut@gentoo.org> atanks-2.9.ebuild:
Stable on ppc wrt bug 229241
diff --git a/games-action/atanks/atanks-3.1.ebuild b/games-action/atanks/atanks-3.1.ebuild
new file mode 100644
index 000000000000..de824ca087fd
--- /dev/null
+++ b/games-action/atanks/atanks-3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-3.1.ebuild,v 1.1 2008/08/11 08:14:07 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CC/s:g++:$(tc-getCXX):" \
+ -e '/^CFLAGS/s:-g::' \
+ -e 's:CFLAGS:CXXFLAGS:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${GAMES_DATADIR}/${PN}\\\\\":" \
+ src/Makefile \
+ || die "sed failed"
+ emake clean
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dat *.txt || die "doins failed"
+ doicon ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+ prepgamesdirs
+}