summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-02-17 19:36:21 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-02-17 19:36:21 +0000
commit668ff000d759eb6f515a29ecadb6606ecfba1fe6 (patch)
tree5acbb5a89a48192e8c992395b0b05fe47acbcace /games-action/atanks
parentAdd missing jack dependency, thanks to jovie1024@yahoo.com for reporting in b... (diff)
downloadgentoo-2-668ff000d759eb6f515a29ecadb6606ecfba1fe6.tar.gz
gentoo-2-668ff000d759eb6f515a29ecadb6606ecfba1fe6.tar.bz2
gentoo-2-668ff000d759eb6f515a29ecadb6606ecfba1fe6.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/ChangeLog9
-rw-r--r--games-action/atanks/atanks-2.8.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index 2403acf64a0f..b228d7943f56 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/atanks
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.26 2007/12/31 03:39:44 mr_bones_ Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.27 2008/02/17 19:36:21 nyhm Exp $
+
+*atanks-2.8 (17 Feb 2008)
+
+ 17 Feb 2008; Tristan Heaven <nyhm@gentoo.org> +atanks-2.8.ebuild:
+ Version bump
*atanks-2.7 (19 Dec 2007)
diff --git a/games-action/atanks/atanks-2.8.ebuild b/games-action/atanks/atanks-2.8.ebuild
new file mode 100644
index 000000000000..c50f358f600a
--- /dev/null
+++ b/games-action/atanks/atanks-2.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-2.8.ebuild,v 1.1 2008/02/17 19:36:21 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CC/s:g++:$(tc-getCXX):" \
+ -e '/^CFLAGS/s:-g::' \
+ -e 's:CFLAGS:CXXFLAGS:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${GAMES_DATADIR}/${PN}\\\\\":" \
+ src/Makefile \
+ || die "sed failed"
+ emake clean
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dat *.txt || die "doins failed"
+ doicon ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+ prepgamesdirs
+}