summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-24 05:53:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-24 05:53:08 +0000
commitd5b219059231f3140516f47fb0274ae49538590b (patch)
treed49415ddcc9a81cc7c9314674b7cbd2b72e77f21 /games-action/chromium
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-d5b219059231f3140516f47fb0274ae49538590b.tar.gz
gentoo-2-d5b219059231f3140516f47fb0274ae49538590b.tar.bz2
gentoo-2-d5b219059231f3140516f47fb0274ae49538590b.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action/chromium')
-rw-r--r--games-action/chromium/ChangeLog10
-rw-r--r--games-action/chromium/chromium-0.9.14.1.ebuild70
2 files changed, 78 insertions, 2 deletions
diff --git a/games-action/chromium/ChangeLog b/games-action/chromium/ChangeLog
index de8f5026a4cd..959a1f9138c4 100644
--- a/games-action/chromium/ChangeLog
+++ b/games-action/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/chromium
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.39 2009/09/27 11:13:53 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.40 2010/06/24 05:53:08 mr_bones_ Exp $
+
+*chromium-0.9.14.1 (24 Jun 2010)
+
+ 24 Jun 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +chromium-0.9.14.1.ebuild:
+ version bump
27 Sep 2009; Markus Meier <maekke@gentoo.org> chromium-0.9.14.ebuild:
amd64/x86 stable, bug #286034
diff --git a/games-action/chromium/chromium-0.9.14.1.ebuild b/games-action/chromium/chromium-0.9.14.1.ebuild
new file mode 100644
index 000000000000..4825390d2510
--- /dev/null
+++ b/games-action/chromium/chromium-0.9.14.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.14.1.ebuild,v 1.1 2010/06/24 05:53:08 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_P="${PN}-bsu-${PV}"
+DESCRIPTION="Chromium B.S.U. - an arcade game"
+HOMEPAGE="http://chromium-bsu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/chromium-bsu/${MY_P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mixer nls +sdl"
+
+RDEPEND="media-fonts/dejavu
+ media-libs/quesoglc
+ media-libs/glpng
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXmu
+ mixer? ( media-libs/sdl-mixer )
+ !mixer? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ nls? ( virtual/libintl )
+ sdl? (
+ media-libs/libsdl[X]
+ media-libs/sdl-image[png]
+ )
+ !sdl? ( virtual/glut )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-ftgl \
+ --enable-glc \
+ --with-font-path="/usr/share/fonts/dejavu/DejaVuSerif-Bold.ttf" \
+ $(use_enable mixer sdlmixer) \
+ $(use_enable !mixer openal) \
+ $(use_enable nls) \
+ $(use_enable sdl) \
+ $(use_enable sdl sdlimage) \
+ $(use_enable !sdl glut)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # remove installed /usr/games/share stuff
+ rm -rf "${D}"/"${GAMES_PREFIX}"/share/
+ newicon misc/${PN}-bsu.png ${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN}-bsu "Chromium B.S.U"
+
+ # install documentation
+ dodoc AUTHORS README NEWS || die "dodoc failed"
+ dohtml "${S}"/data/doc/*.htm || die "dohtml failed"
+ cd "${S}"/data/doc/images
+ insinto /usr/share/doc/${PF}/html/images
+ doins *.jpg || die "doins failed"
+
+ prepgamesdirs
+}