summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commitf199057b8679cd2eed424fccb45361c89a133d31 (patch)
treee6ec41e59db82809cd99452c53c9efe67a3985e3 /games-action/powermanga
parentgames action and arcade (diff)
downloadgentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.gz
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.tar.bz2
gentoo-2-f199057b8679cd2eed424fccb45361c89a133d31.zip
action games !
Diffstat (limited to 'games-action/powermanga')
-rw-r--r--games-action/powermanga/ChangeLog17
-rw-r--r--games-action/powermanga/Manifest5
-rw-r--r--games-action/powermanga/files/digest-powermanga-0.771
-rw-r--r--games-action/powermanga/files/digest-powermanga-0.781
-rw-r--r--games-action/powermanga/powermanga-0.77.ebuild47
-rw-r--r--games-action/powermanga/powermanga-0.78.ebuild46
6 files changed, 117 insertions, 0 deletions
diff --git a/games-action/powermanga/ChangeLog b/games-action/powermanga/ChangeLog
new file mode 100644
index 000000000000..cb87212433e0
--- /dev/null
+++ b/games-action/powermanga/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for app-games/powermanga
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+ 29 Jul 2003; Michael Sterrett <msterret@gentoo.org> powermanga-0.78.ebuild:
+ use the distribution site now that they're providing versioned releases.
+
+*powermanga-0.78 (29 Jul 2003)
+
+ 29 Jul 2003; Michael Sterrett <msterret@gentoo.org> powermanga-0.78.ebuild:
+ version bump
+
+*powermanga-0.77 (03 Jul 2003)
+
+ 03 Jul 2003; Michael Sterrett <msterret@gentoo.org> powermanga-0.77.ebuild:
+ Initial commit
+
diff --git a/games-action/powermanga/Manifest b/games-action/powermanga/Manifest
new file mode 100644
index 000000000000..fb828cd96a9b
--- /dev/null
+++ b/games-action/powermanga/Manifest
@@ -0,0 +1,5 @@
+MD5 e86a7bdb7e76bd176c23311512e10237 powermanga-0.77.ebuild 1201
+MD5 b4385423c434a328c2ef76cccf1ce362 ChangeLog 632
+MD5 d170b73835fbbbf7f986a1c5713cd112 powermanga-0.78.ebuild 1136
+MD5 8b2c32e40e89a35ac9ac46dc6abeaf7d files/digest-powermanga-0.77 68
+MD5 2943a5cad4be13cb5a4b7b95b7532300 files/digest-powermanga-0.78 68
diff --git a/games-action/powermanga/files/digest-powermanga-0.77 b/games-action/powermanga/files/digest-powermanga-0.77
new file mode 100644
index 000000000000..7209d4a22f42
--- /dev/null
+++ b/games-action/powermanga/files/digest-powermanga-0.77
@@ -0,0 +1 @@
+MD5 65568266d385b0bc15b722ed6c659788 powermanga-0.77.tar.gz 7100932
diff --git a/games-action/powermanga/files/digest-powermanga-0.78 b/games-action/powermanga/files/digest-powermanga-0.78
new file mode 100644
index 000000000000..0bdfad32a58d
--- /dev/null
+++ b/games-action/powermanga/files/digest-powermanga-0.78
@@ -0,0 +1 @@
+MD5 6d84fac8f9f838dd5654735bbc68b9d7 powermanga-0.78.tar.gz 6802816
diff --git a/games-action/powermanga/powermanga-0.77.ebuild b/games-action/powermanga/powermanga-0.77.ebuild
new file mode 100644
index 000000000000..1634a61e3536
--- /dev/null
+++ b/games-action/powermanga/powermanga-0.77.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.77.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="An arcade 2D shoot-em-up game"
+HOMEPAGE="http://linux.tlk.fr/"
+# TLK seems to always use the same name for releases. That's bad.
+#SRC_URI="http://www.tlk.fr/lesjeux/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT=0
+
+DEPEND="virtual/glibc
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die
+}
+
+src_install() {
+ local f
+
+ dogamesbin powermanga || die "dogamesbin failed"
+ doman powermanga.6 || die "doman failed"
+ dodoc AUTHORS CHANGES README || die "dodoc failed"
+
+ insinto ${GAMES_DATADIR}/powermanga/sounds
+ doins sounds/*
+
+ insinto ${GAMES_DATADIR}/powermanga/graphics
+ doins graphics/*
+
+ insinto /var/games
+ for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard
+ do
+ touch ${D}/var/games/${f} || \
+ die "touch ${f} failed"
+ fperms 664 /var/games/${f} || \
+ die "fperms ${f} failed"
+ done
+
+ prepgamesdirs
+}
diff --git a/games-action/powermanga/powermanga-0.78.ebuild b/games-action/powermanga/powermanga-0.78.ebuild
new file mode 100644
index 000000000000..de07b5956230
--- /dev/null
+++ b/games-action/powermanga/powermanga-0.78.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.78.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="An arcade 2D shoot-em-up game"
+HOMEPAGE="http://linux.tlk.fr/"
+SRC_URI="http://www.tlk.fr/lesjeux/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT=0
+
+DEPEND="virtual/glibc
+ >=media-libs/libsdl-0.11.0
+ media-libs/sdl-mixer"
+
+src_compile() {
+ egamesconf --prefix=/usr || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ dogamesbin powermanga || die "dogamesbin failed"
+ doman powermanga.6 || die "doman failed"
+ dodoc AUTHORS CHANGES README || die "dodoc failed"
+
+ insinto ${GAMES_DATADIR}/powermanga/sounds
+ doins sounds/*
+
+ insinto ${GAMES_DATADIR}/powermanga/graphics
+ doins graphics/*
+
+ insinto /var/games
+ for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard
+ do
+ touch ${D}/var/games/${f} || \
+ die "touch ${f} failed"
+ fperms 664 /var/games/${f} || \
+ die "fperms ${f} failed"
+ done
+
+ prepgamesdirs
+}