summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-11-06 16:12:01 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-11-06 16:12:01 +0000
commite6e8adfd1930031a637bf96d4c98b95927a6cac6 (patch)
tree41e6d83b16356c39827002f53209b61f5950cf11 /games-action/xbomber
parentAdd bmp support (diff)
downloadgentoo-2-e6e8adfd1930031a637bf96d4c98b95927a6cac6.tar.gz
gentoo-2-e6e8adfd1930031a637bf96d4c98b95927a6cac6.tar.bz2
gentoo-2-e6e8adfd1930031a637bf96d4c98b95927a6cac6.zip
Fixed BUG #108724. Patch fixes usage of vsprintf.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-action/xbomber')
-rw-r--r--games-action/xbomber/ChangeLog6
-rw-r--r--games-action/xbomber/files/xbomber-101-va_list.patch48
-rw-r--r--games-action/xbomber/xbomber-101.ebuild3
3 files changed, 55 insertions, 2 deletions
diff --git a/games-action/xbomber/ChangeLog b/games-action/xbomber/ChangeLog
index af47d1031052..d1eacdf67e86 100644
--- a/games-action/xbomber/ChangeLog
+++ b/games-action/xbomber/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/xbomber
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xbomber/ChangeLog,v 1.6 2005/10/10 00:15:52 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xbomber/ChangeLog,v 1.7 2005/11/06 16:12:01 kugelfang Exp $
+
+ 06 Nov 2005; Danny van Dyk <kugelfang@gentoo.org>
+ +files/xbomber-101-va_list.patch, xbomber-101.ebuild:
+ Fixed BUG #108724. Patch fixes usage of vsprintf.
10 Oct 2005; Luis Medinas <metalgod@gentoo.org> xbomber-101.ebuild:
Added ~amd64 keyword.
diff --git a/games-action/xbomber/files/xbomber-101-va_list.patch b/games-action/xbomber/files/xbomber-101-va_list.patch
new file mode 100644
index 000000000000..cd15b84b00e3
--- /dev/null
+++ b/games-action/xbomber/files/xbomber-101-va_list.patch
@@ -0,0 +1,48 @@
+--- bomber.c.orig 2005-11-06 16:50:04.000000000 +0100
++++ bomber.c 2005-11-06 16:47:35.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <stdarg.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <sys/uio.h>
+@@ -626,8 +627,11 @@
+ void scrprintf(char *str,...)
+ {
+ char output[256],*p,*p2;
++va_list ap;
+
+- vsprintf(output,str,&str+1);
++ va_start(ap, str);
++ vsprintf(output,str,ap);
++ va_end(ap);
+ p=output;
+ for(;;)
+ {
+@@ -653,8 +657,11 @@
+ void bigscrprintf(char *str,...)
+ {
+ char output[256],*p,*p2;
++va_list ap;
+
+- vsprintf(output,str,&str+1);
++ va_start(ap, str);
++ vsprintf(output,str,ap);
++ va_end(ap);
+ p=output;
+ for(;;)
+ {
+@@ -1873,8 +1880,11 @@
+ additem(char *item,...)
+ {
+ char output[256];
++va_list ap;
+
+- vsprintf(output,item,&item+1);
++ va_start(ap, item);
++ vsprintf(output,item,ap);
++ va_end(ap);
+ if(menunum<0)
+ menutitle=menuput;
+ else
diff --git a/games-action/xbomber/xbomber-101.ebuild b/games-action/xbomber/xbomber-101.ebuild
index 470dd008c60b..edc2a26a94eb 100644
--- a/games-action/xbomber/xbomber-101.ebuild
+++ b/games-action/xbomber/xbomber-101.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xbomber/xbomber-101.ebuild,v 1.7 2005/10/10 00:15:52 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xbomber/xbomber-101.ebuild,v 1.8 2005/11/06 16:12:01 kugelfang Exp $
inherit games
@@ -23,6 +23,7 @@ src_unpack() {
sed -i "s:X386:X11R6:" Makefile
sed -i "s:data/%s:${GAMES_DATADIR}/${PN}/%s:" bomber.c
sed -i "s:=\"data\":=\"${GAMES_DATADIR}/${PN}\":" sound.c
+ epatch ${FILESDIR}/${P}-va_list.patch
}
src_compile() {