summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-14 16:13:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-14 16:13:50 +0000
commit2fb7eb5c26e46a3bffd5aba67c55da7ee0a00ae1 (patch)
tree9801c1cb3bc33ca7c187084332a0db57515d12c3 /games-action
parentMask www-client/chromium dev channel release. (diff)
downloadgentoo-2-2fb7eb5c26e46a3bffd5aba67c55da7ee0a00ae1.tar.gz
gentoo-2-2fb7eb5c26e46a3bffd5aba67c55da7ee0a00ae1.tar.bz2
gentoo-2-2fb7eb5c26e46a3bffd5aba67c55da7ee0a00ae1.zip
EAPI=2; tidy; skip missing doc install (bug #315209)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gltron/ChangeLog8
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild26
2 files changed, 18 insertions, 16 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
index 45529975defa..adad888535d5 100644
--- a/games-action/gltron/ChangeLog
+++ b/games-action/gltron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/gltron
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.13 2007/02/14 00:34:36 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.14 2010/04/14 16:13:50 mr_bones_ Exp $
+
+ 14 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ gltron-0.70-r1.ebuild:
+ EAPI=2; tidy; skip missing doc install (bug #315209)
14 Feb 2007; Tristan Heaven <nyhm@gentoo.org> -files/gltron.png,
gltron-0.70-r1.ebuild:
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
index 10d08dc57673..d0fa4ecf8bda 100644
--- a/games-action/gltron/gltron-0.70-r1.ebuild
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.5 2007/02/14 00:34:36 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70-r1.ebuild,v 1.6 2010/04/14 16:13:50 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="3d tron, just like the movie"
@@ -16,34 +17,31 @@ IUSE=""
DEPEND="virtual/opengl
media-libs/libpng
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-sound"
+ media-libs/libsdl[audio,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-sound[vorbis,mikmod]
+ media-libs/smpeg
+ media-libs/libmikmod"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-configure.patch \
"${FILESDIR}"/${P}-prototypes.patch \
"${FILESDIR}"/${P}-debian.patch
}
-src_compile() {
+src_configure() {
# warn/debug/profile just modify CFLAGS, they aren't
# real options, so don't utilize USE flags here
egamesconf \
--disable-warn \
--disable-debug \
- --disable-profile \
- || die
- emake || die "emake failed"
+ --disable-profile
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog README
- dohtml *.html
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry ${PN} GLtron
prepgamesdirs