summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-22 05:58:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-22 05:58:25 +0000
commit41ad044e03affd3c185a3097f56ed3fee14b8d32 (patch)
tree481f0cb3cb25a7e0d5ebe3cb60cb32ac6b1807ef /games-action
parentadd ~amd64 #110067 for accelerator #110010 and add a sanity check to make sur... (diff)
downloadgentoo-2-41ad044e03affd3c185a3097f56ed3fee14b8d32.tar.gz
gentoo-2-41ad044e03affd3c185a3097f56ed3fee14b8d32.tar.bz2
gentoo-2-41ad044e03affd3c185a3097f56ed3fee14b8d32.zip
initial import #110010
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/accelerator3d/ChangeLog8
-rw-r--r--games-action/accelerator3d/Manifest2
-rw-r--r--games-action/accelerator3d/accelerator3d-0.1.0.ebuild38
-rw-r--r--games-action/accelerator3d/files/accelerator3d-0.1.0-gentoo-paths.patch9
-rw-r--r--games-action/accelerator3d/files/digest-accelerator3d-0.1.01
-rw-r--r--games-action/accelerator3d/metadata.xml5
6 files changed, 63 insertions, 0 deletions
diff --git a/games-action/accelerator3d/ChangeLog b/games-action/accelerator3d/ChangeLog
new file mode 100644
index 000000000000..0e7bc8c3dc31
--- /dev/null
+++ b/games-action/accelerator3d/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-action/accelerator3d
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/ChangeLog,v 1.1 2005/10/22 05:58:25 vapier Exp $
+
+*accelerator3d-0.1.0 (22 Oct 2005)
+
+ 22 Oct 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for #110010 by Matija Suklje (hook).
diff --git a/games-action/accelerator3d/Manifest b/games-action/accelerator3d/Manifest
new file mode 100644
index 000000000000..1654f211b462
--- /dev/null
+++ b/games-action/accelerator3d/Manifest
@@ -0,0 +1,2 @@
+MD5 1c165918383a11546561b44c9acaac11 accelerator3d-0.1.0.ebuild 490
+MD5 4b68311bbba9323e9f182a6aebc67090 files/digest-accelerator3d-0.1.0 70
diff --git a/games-action/accelerator3d/accelerator3d-0.1.0.ebuild b/games-action/accelerator3d/accelerator3d-0.1.0.ebuild
new file mode 100644
index 000000000000..21c6b687a54a
--- /dev/null
+++ b/games-action/accelerator3d/accelerator3d-0.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/accelerator3d-0.1.0.ebuild,v 1.1 2005/10/22 05:58:25 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Fast-paced, 3D, first-person shoot/dodge-'em-up, in the vain of Tempest or n2o"
+HOMEPAGE="http://accelerator3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/accelerator3d/accelerator-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyode
+ dev-python/pygame
+ dev-python/pyopengl
+ virtual/python"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ accelerator.py || die
+}
+
+src_install() {
+ newgamesbin accelerator.py accelerator || die "gamesbin"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins gfx/* || die "doins gfx"
+ dodoc CHANGELOG README
+ prepgamesdirs
+}
diff --git a/games-action/accelerator3d/files/accelerator3d-0.1.0-gentoo-paths.patch b/games-action/accelerator3d/files/accelerator3d-0.1.0-gentoo-paths.patch
new file mode 100644
index 000000000000..1eed0972cd6d
--- /dev/null
+++ b/games-action/accelerator3d/files/accelerator3d-0.1.0-gentoo-paths.patch
@@ -0,0 +1,9 @@
+--- accelerator.py
++++ accelerator.py
+@@ -63,5 +63,5 @@
+ def __init__(self,texfile,mipmap = False):
+ global activeTexture
+- filename = os.path.join('gfx',texfile)
++ filename = os.path.join('@GENTOO_DATADIR@',texfile)
+ image = pygame.image.load(filename)
+ data = pygame.image.tostring(image,'RGBX')
diff --git a/games-action/accelerator3d/files/digest-accelerator3d-0.1.0 b/games-action/accelerator3d/files/digest-accelerator3d-0.1.0
new file mode 100644
index 000000000000..369ad1d49f59
--- /dev/null
+++ b/games-action/accelerator3d/files/digest-accelerator3d-0.1.0
@@ -0,0 +1 @@
+MD5 4c672f1711968d8ba407f34cc3cf38f0 accelerator-0.1.0.tar.bz2 456102
diff --git a/games-action/accelerator3d/metadata.xml b/games-action/accelerator3d/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/accelerator3d/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>