summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-12-12 21:34:43 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-12-12 21:34:43 +0000
commit7bb70e464006e53f9167fe43a8f27d79dcf57b0f (patch)
tree9356874f32c9213a1ae5eb7cfe69b7f0d38e4790 /games-action
parentVersion bump (diff)
downloadgentoo-2-7bb70e464006e53f9167fe43a8f27d79dcf57b0f.tar.gz
gentoo-2-7bb70e464006e53f9167fe43a8f27d79dcf57b0f.tar.bz2
gentoo-2-7bb70e464006e53f9167fe43a8f27d79dcf57b0f.zip
version bump wrt #376855
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/ChangeLog9
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8-fribidi.patch48
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8-gentoo.patch17
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8-irrlicht.patch69
-rw-r--r--games-action/supertuxkart/supertuxkart-0.8.ebuild75
5 files changed, 217 insertions, 1 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index dd00386fda04..253462c9a7ee 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/supertuxkart
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.28 2012/12/07 23:36:34 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.29 2012/12/12 21:34:43 hasufell Exp $
+
+*supertuxkart-0.8 (12 Dec 2012)
+
+ 12 Dec 2012; Julian Ospald <hasufell@gentoo.org> +supertuxkart-0.8.ebuild,
+ +files/supertuxkart-0.8-fribidi.patch, +files/supertuxkart-0.8-gentoo.patch,
+ +files/supertuxkart-0.8-irrlicht.patch:
+ version bump wrt #376855
07 Dec 2012; Julian Ospald <hasufell@gentoo.org> supertuxkart-0.7.ebuild:
prepare deps for irrlicht-1.8 import, fix as-is license to ZLIB
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8-fribidi.patch b/games-action/supertuxkart/files/supertuxkart-0.8-fribidi.patch
new file mode 100644
index 000000000000..026471afca59
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8-fribidi.patch
@@ -0,0 +1,48 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Dec 12 18:33:26 UTC 2012
+Subject: use pkgconfig to locate fribidi
+
+https://sourceforge.net/apps/trac/supertuxkart/ticket/840
+
+--- cmake/FindFribidi.cmake
++++ cmake/FindFribidi.cmake
+@@ -9,19 +9,27 @@
+ # FRIBIDI_LIBRARIES
+ # Fribidi library list
+
++if(UNIX)
++ include(FindPkgConfig)
++ pkg_check_modules(FRIBIDI fribidi)
++else()
++ set(FRIBIDI_FOUND 0)
++endif()
+
+-find_path(FRIBIDI_INCLUDE_DIR NAMES fribidi/fribidi.h PATHS /Library/Frameworks/fribidi.framework/Headers "${PROJECT_SOURCE_DIR}/dependencies/include")
+-find_library(FRIBIDI_LIBRARY NAMES fribidi PATHS /Library/Frameworks/fribidi.framework "${PROJECT_SOURCE_DIR}/dependencies/lib")
+-
+-include(FindPackageHandleStandardArgs)
+-find_package_handle_standard_args(Fribidi DEFAULT_MSG FRIBIDI_INCLUDE_DIR FRIBIDI_LIBRARY)
+-
+-
+-if(APPLE)
+-set(FRIBIDI_INCLUDE_DIR "/Library/Frameworks/fribidi.framework/Headers")
++if(NOT FRIBIDI_FOUND)
++ find_path(FRIBIDI_INCLUDE_DIR NAMES fribidi/fribidi.h PATHS /Library/Frameworks/fribidi.framework/Headers "${PROJECT_SOURCE_DIR}/dependencies/include")
++ find_library(FRIBIDI_LIBRARY NAMES fribidi PATHS /Library/Frameworks/fribidi.framework "${PROJECT_SOURCE_DIR}/dependencies/lib")
++
++ include(FindPackageHandleStandardArgs)
++ find_package_handle_standard_args(Fribidi DEFAULT_MSG FRIBIDI_INCLUDE_DIR FRIBIDI_LIBRARY)
++
++ if(APPLE)
++ set(FRIBIDI_INCLUDE_DIR "/Library/Frameworks/fribidi.framework/Headers")
++ endif()
++
++ # Publish variables
++ set(FRIBIDI_INCLUDE_DIRS ${FRIBIDI_INCLUDE_DIR})
++ set(FRIBIDI_LIBRARIES ${FRIBIDI_LIBRARY})
+ endif()
+
+-# Publish variables
+-set(FRIBIDI_INCLUDE_DIRS ${FRIBIDI_INCLUDE_DIR})
+-set(FRIBIDI_LIBRARIES ${FRIBIDI_LIBRARY})
+ mark_as_advanced(FRIBIDI_INCLUDE_DIR FRIBIDI_LIBRARY)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8-gentoo.patch b/games-action/supertuxkart/files/supertuxkart-0.8-gentoo.patch
new file mode 100644
index 000000000000..14a9d7f59ddc
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8-gentoo.patch
@@ -0,0 +1,17 @@
+this is gentoo specific, because of unbundling Irrlicht dependencies
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -196,7 +196,11 @@
+ ${IRRLICHT_LIBRARY}
+ ${IRRLICHT_XF86VM_LIBRARY}
+ ${OPENAL_LIBRARY}
+- ${OPENGL_LIBRARIES})
++ ${OPENGL_LIBRARIES}
++ png
++ jpeg
++ bz2
++ z)
+
+ if(USE_FRIBIDI)
+ target_link_libraries(supertuxkart ${FRIBIDI_LIBRARIES})
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8-irrlicht.patch b/games-action/supertuxkart/files/supertuxkart-0.8-irrlicht.patch
new file mode 100644
index 000000000000..43130d14a09a
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8-irrlicht.patch
@@ -0,0 +1,69 @@
+unbundle Irrlicht dependencies
+and respect CFLAGS
+
+--- lib/irrlicht/include/IrrCompileConfig.h
++++ lib/irrlicht/include/IrrCompileConfig.h
+@@ -245,7 +245,7 @@
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
++//#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #undef _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #endif
+@@ -261,7 +261,7 @@
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
++//#define _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #ifdef NO_IRR_USE_NON_SYSTEM_LIB_PNG_
+ #undef _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #endif
+@@ -598,7 +598,7 @@
+ /** If this is commented out, Irrlicht will try to compile using the zlib
+ installed on the system. This is only used when _IRR_COMPILE_WITH_ZLIB_ is
+ defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
++//#define _IRR_USE_NON_SYSTEM_ZLIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_ZLIB_
+ #undef _IRR_USE_NON_SYSTEM_ZLIB_
+ #endif
+--- lib/irrlicht/source/Irrlicht/Makefile
++++ lib/irrlicht/source/Irrlicht/Makefile
+@@ -46,11 +46,7 @@
+ IRRIOOBJ = CFileList.o CFileSystem.o CLimitReadFile.o CMemoryFile.o CReadFile.o CWriteFile.o CXMLReader.o CXMLWriter.o CWADReader.o CZipReader.o CPakReader.o CNPKReader.o CTarReader.o CMountPointReader.o irrXML.o CAttributes.o lzma/LzmaDec.o
+ IRROTHEROBJ = CIrrDeviceSDL.o CIrrDeviceLinux.o CIrrDeviceConsole.o CIrrDeviceStub.o CIrrDeviceWin32.o CIrrDeviceFB.o CLogger.o COSOperator.o Irrlicht.o os.o
+ IRRGUIOBJ = CGUIButton.o CGUICheckBox.o CGUIComboBox.o CGUIContextMenu.o CGUIEditBox.o CGUIEnvironment.o CGUIFileOpenDialog.o CGUIFont.o CGUIImage.o CGUIInOutFader.o CGUIListBox.o CGUIMenu.o CGUIMeshViewer.o CGUIMessageBox.o CGUIModalScreen.o CGUIScrollBar.o CGUISpinBox.o CGUISkin.o CGUIStaticText.o CGUITabControl.o CGUITable.o CGUIToolBar.o CGUIWindow.o CGUIColorSelectDialog.o CDefaultGUIElementFactory.o CGUISpriteBank.o CGUIImageList.o CGUITreeView.o
+-ZLIBOBJ = zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o zlib/inffast.o zlib/inflate.o zlib/inftrees.o zlib/trees.o zlib/uncompr.o zlib/zutil.o
+-JPEGLIBOBJ = jpeglib/jcapimin.o jpeglib/jcapistd.o jpeglib/jccoefct.o jpeglib/jccolor.o jpeglib/jcdctmgr.o jpeglib/jchuff.o jpeglib/jcinit.o jpeglib/jcmainct.o jpeglib/jcmarker.o jpeglib/jcmaster.o jpeglib/jcomapi.o jpeglib/jcparam.o jpeglib/jcprepct.o jpeglib/jcsample.o jpeglib/jctrans.o jpeglib/jdapimin.o jpeglib/jdapistd.o jpeglib/jdatadst.o jpeglib/jdatasrc.o jpeglib/jdcoefct.o jpeglib/jdcolor.o jpeglib/jddctmgr.o jpeglib/jdhuff.o jpeglib/jdinput.o jpeglib/jdmainct.o jpeglib/jdmarker.o jpeglib/jdmaster.o jpeglib/jdmerge.o jpeglib/jdpostct.o jpeglib/jdsample.o jpeglib/jdtrans.o jpeglib/jerror.o jpeglib/jfdctflt.o jpeglib/jfdctfst.o jpeglib/jfdctint.o jpeglib/jidctflt.o jpeglib/jidctfst.o jpeglib/jidctint.o jpeglib/jmemmgr.o jpeglib/jmemnobs.o jpeglib/jquant1.o jpeglib/jquant2.o jpeglib/jutils.o jpeglib/jcarith.o jpeglib/jdarith.o jpeglib/jaricom.o
+-LIBPNGOBJ = libpng/png.o libpng/pngerror.o libpng/pngget.o libpng/pngmem.o libpng/pngpread.o libpng/pngread.o libpng/pngrio.o libpng/pngrtran.o libpng/pngrutil.o libpng/pngset.o libpng/pngtrans.o libpng/pngwio.o libpng/pngwrite.o libpng/pngwtran.o libpng/pngwutil.o
+ LIBAESGM = aesGladman/aescrypt.o aesGladman/aeskey.o aesGladman/aestab.o aesGladman/fileenc.o aesGladman/hmac.o aesGladman/prng.o aesGladman/pwd2key.o aesGladman/sha1.o aesGladman/sha2.o
+-BZIP2OBJ = bzip2/blocksort.o bzip2/huffman.o bzip2/crctable.o bzip2/randtable.o bzip2/bzcompress.o bzip2/decompress.o bzip2/bzlib.o
+
+ # Next variable is for additional scene nodes etc. of customized Irrlicht versions
+ EXTRAOBJ =
+@@ -61,18 +57,16 @@
+
+ ###############
+ #Compiler flags
+-CXXINCS = -I../../include -Izlib -Ijpeglib -Ilibpng
++CXXINCS = -I../../include
+ CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1
+-CXXFLAGS += -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing
++CXXFLAGS += -Wall -fno-exceptions -fno-rtti
+ ifndef NDEBUG
+-CXXFLAGS += -g -D_DEBUG
+-else
+-CXXFLAGS += -fexpensive-optimizations -O3
++CXXFLAGS += -D_DEBUG
+ endif
+ ifdef PROFILE
+ CXXFLAGS += -pg
+ endif
+-CFLAGS := -O3 -fexpensive-optimizations -DPNG_THREAD_UNSAFE_OK -DPNG_NO_MMX_CODE -DPNG_NO_MNG_FEATURES
++CFLAGS += -DPNG_THREAD_UNSAFE_OK -DPNG_NO_MMX_CODE -DPNG_NO_MNG_FEATURES
+
+ sharedlib sharedlib_osx: CXXFLAGS += -fPIC
+ sharedlib sharedlib_osx: CFLAGS += -fPIC
diff --git a/games-action/supertuxkart/supertuxkart-0.8.ebuild b/games-action/supertuxkart/supertuxkart-0.8.ebuild
new file mode 100644
index 000000000000..8c2028dde817
--- /dev/null
+++ b/games-action/supertuxkart/supertuxkart-0.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.ebuild,v 1.1 2012/12/12 21:34:43 hasufell Exp $
+
+EAPI=2
+inherit cmake-utils eutils games
+
+DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
+HOMEPAGE="http://supertuxkart.sourceforge.net/"
+SRC_URI="mirror://sourceforge/supertuxkart/SuperTuxKart/${PV}/${P}-src.tar.bz2
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0 CCPL-Attribution-2.0 CCPL-Sampling-Plus-1.0 public-domain ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+# don't unbundle irrlicht and bullet
+# both are modified and system versions will break the game
+# http://sourceforge.net/tracker/?func=detail&aid=3454889&group_id=74339&atid=540679
+
+# VERSION BUMP NOTICE: enet might be needed for supertuxkart-0.9
+RDEPEND="dev-libs/fribidi
+ media-libs/freeglut
+ media-libs/libpng:0
+ media-libs/libvorbis
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg
+ virtual/libintl
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/SuperTuxKart-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{gentoo,fribidi,irrlicht}.patch
+
+ # inconsistent handling of debug definition
+ # avoid using Debug build type
+ use debug &&
+ sed -i \
+ -e 's/add_definitions(-DNDEBUG)/add_definitions(-DDEBUG)/' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSTK_INSTALL_BINARY_DIR="${GAMES_BINDIR}"
+ -DSTK_INSTALL_DATA_DIR="${GAMES_DATADIR}"/${PN}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ # build bundled irrlicht
+ NDEBUG=1 emake -C lib/irrlicht/source/Irrlicht
+
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} SuperTuxKart
+ dodoc AUTHORS ChangeLog README TODO
+ prepgamesdirs
+}