summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-11 18:20:25 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-11 18:20:25 +0000
commit8445c14b29ae825ea3983807621955b1dd83b1df (patch)
treed44c95d394c28337a5fc90b857e5a58b77d328c6 /games-action
parentFreeBSD backend fixes. malloc.h -> stdlib.h (diff)
downloadgentoo-2-8445c14b29ae825ea3983807621955b1dd83b1df.tar.gz
gentoo-2-8445c14b29ae825ea3983807621955b1dd83b1df.tar.bz2
gentoo-2-8445c14b29ae825ea3983807621955b1dd83b1df.zip
use games_make_wrapper; add missing gtk+-1 dependency
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/parsec/ChangeLog8
-rw-r--r--games-action/parsec/files/parsec3
-rw-r--r--games-action/parsec/parsec-0197.ebuild24
3 files changed, 18 insertions, 17 deletions
diff --git a/games-action/parsec/ChangeLog b/games-action/parsec/ChangeLog
index 97b8d2979747..7499436aeb42 100644
--- a/games-action/parsec/ChangeLog
+++ b/games-action/parsec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/parsec
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/ChangeLog,v 1.12 2006/11/27 01:27:49 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/ChangeLog,v 1.13 2007/04/11 18:20:25 nyhm Exp $
+
+ 11 Apr 2007; Tristan Heaven <nyhm@gentoo.org> -files/parsec,
+ parsec-0197.ebuild:
+ use games_make_wrapper; add missing gtk+-1 dependency
27 Nov 2006; <blubb@gentoo.org> parsec-0197.ebuild:
stable on amd64
diff --git a/games-action/parsec/files/parsec b/games-action/parsec/files/parsec
deleted file mode 100644
index ddf33eb11d4d..000000000000
--- a/games-action/parsec/files/parsec
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd GENTOO_DIR
-exec ./launcher ${@}
diff --git a/games-action/parsec/parsec-0197.ebuild b/games-action/parsec/parsec-0197.ebuild
index 4ee4f7329190..d26b8ad03cf9 100644
--- a/games-action/parsec/parsec-0197.ebuild
+++ b/games-action/parsec/parsec-0197.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.13 2006/11/27 01:27:49 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.14 2007/04/11 18:20:25 nyhm Exp $
inherit games
@@ -9,34 +9,34 @@ HOMEPAGE="http://openparsec.sourceforge.net/"
SRC_URI="http://public.www.planetmirror.com/pub/parsec/${PV}/parsec_lan_build${PV}.tar.gz
ftp://ftp.planetmirror.com/pub/parsec/${PV}/parsec_lan_build${PV}.tar.gz
http://ftp.webmonster.de/pub/parsec/parsec_lan_build${PV}.tar.gz"
-RESTRICT="mirror strip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="mirror strip"
-DEPEND="x11-libs/libXi
- virtual/opengl
+RDEPEND="virtual/opengl
virtual/glut
virtual/glu
media-libs/openal
+ =x11-libs/gtk+-1.2*
x86? ( sys-libs/lib-compat )
- amd64? ( app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-compat )"
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-compat
+ )"
S=${WORKDIR}/${PN}
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
- dogamesbin "${FILESDIR}/parsec" || die "dogamesbin failed"
+ games_make_wrapper ${PN} ./launcher "${dir}"
dodir "${dir}"
# preserve execute permissions. bug #119081
cp -r * "${D}${dir}" || die "cp failed"
- sed -i \
- -e "s:GENTOO_DIR:${dir}:" \
- "${D}${GAMES_BINDIR}/parsec" \
- || die "sed failed"
prepgamesdirs
}