summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-05-23 22:10:00 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-05-23 22:10:00 +0000
commit87af9c86209596962ffce3c9f6de444ba785a551 (patch)
treec3700ee0e81316ae085e144c93526b48dc68d7fd /games-action
parentRemove dodoc on non-existing file (diff)
downloadgentoo-2-87af9c86209596962ffce3c9f6de444ba785a551.tar.gz
gentoo-2-87af9c86209596962ffce3c9f6de444ba785a551.tar.bz2
gentoo-2-87af9c86209596962ffce3c9f6de444ba785a551.zip
Use system sdl-gfx instead of the bundled version, bug #252526
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/btanks/ChangeLog6
-rw-r--r--games-action/btanks/btanks-0.8.7686.ebuild11
-rw-r--r--games-action/btanks/files/btanks-0.8.7686-scons-blows.patch155
3 files changed, 75 insertions, 97 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index 0ce80842ebd8..537fcaec20df 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/btanks
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.19 2009/05/19 17:38:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.20 2009/05/23 22:09:59 nyhm Exp $
+
+ 23 May 2009; Tristan Heaven <nyhm@gentoo.org> btanks-0.8.7686.ebuild,
+ files/btanks-0.8.7686-scons-blows.patch:
+ Use system sdl-gfx instead of the bundled version, bug #252526
19 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
btanks-0.8.7686.ebuild:
diff --git a/games-action/btanks/btanks-0.8.7686.ebuild b/games-action/btanks/btanks-0.8.7686.ebuild
index 792766475017..e814ba35f55e 100644
--- a/games-action/btanks/btanks-0.8.7686.ebuild
+++ b/games-action/btanks/btanks-0.8.7686.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.8.7686.ebuild,v 1.7 2009/05/19 17:38:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.8.7686.ebuild,v 1.8 2009/05/23 22:09:59 nyhm Exp $
EAPI=2
inherit eutils games
@@ -19,14 +19,17 @@ RDEPEND=">=dev-lang/lua-5.1
media-libs/libvorbis
virtual/opengl
dev-libs/expat
- sys-libs/zlib
media-libs/smpeg
- media-libs/sdl-image[jpeg,png]"
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-gfx"
DEPEND="${RDEPEND}
dev-util/scons
dev-util/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-scons-blows.patch )
+src_prepare() {
+ rm -rf sdlx/gfx
+ epatch "${FILESDIR}"/${P}-scons-blows.patch
+}
src_compile() {
local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
diff --git a/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch b/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch
index 942bd7985706..9920115b324a 100644
--- a/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch
+++ b/games-action/btanks/files/btanks-0.8.7686-scons-blows.patch
@@ -1,6 +1,37 @@
-diff -ru btanks-0.8.7686.orig/SConstruct btanks-0.8.7686/SConstruct
---- btanks-0.8.7686.orig/SConstruct 2008-07-29 05:08:59.000000000 -0400
-+++ btanks-0.8.7686/SConstruct 2009-01-23 02:15:29.000000000 -0500
+--- clunk/kiss/_kiss_fft_guts.h
++++ clunk/kiss/_kiss_fft_guts.h
+@@ -18,6 +18,7 @@
+ typedef struct { kiss_fft_scalar r; kiss_fft_scalar i; }kiss_fft_cpx; */
+ #include "kiss_fft.h"
+ #include <limits.h>
++#include <string.h>
+
+ #define MAXFACTORS 32
+ /* e.g. an fft of length 128 has 4 factors
+--- mrt/export_base.h
++++ mrt/export_base.h
+@@ -1,7 +1,7 @@
+ #ifndef MRT_EXPORT_MACRO_H__
+ #define MRT_EXPORT_MACRO_H__
+
+-// Shared library support
++/* Shared library support */
+ #ifdef _WINDOWS
+
+ # pragma warning(disable:4251) /* needs to have dll-interface used by client */
+--- mrt/tclUniData.c
++++ mrt/tclUniData.c
+@@ -880,7 +880,7 @@
+ FINAL_QUOTE_PUNCTUATION,
+ OTHER_PUNCTUATION,
+ MATH_SYMBOL,
+- CURRENCY_SYMBOL,
++ LCURRENCY_SYMBOL,
+ MODIFIER_SYMBOL,
+ OTHER_SYMBOL
+ };
+--- SConstruct
++++ SConstruct
@@ -49,7 +49,7 @@
if os.environ.has_key('CC'):
env['CC'] = os.environ['CC']
@@ -32,98 +63,38 @@ diff -ru btanks-0.8.7686.orig/SConstruct btanks-0.8.7686/SConstruct
conf_env = env.Clone()
-diff -ru btanks-0.8.7686.orig/clunk/kiss/_kiss_fft_guts.h btanks-0.8.7686/clunk/kiss/_kiss_fft_guts.h
---- btanks-0.8.7686.orig/clunk/kiss/_kiss_fft_guts.h 2008-03-12 06:32:16.000000000 -0400
-+++ btanks-0.8.7686/clunk/kiss/_kiss_fft_guts.h 2009-01-23 02:16:13.000000000 -0500
-@@ -18,6 +18,7 @@
- typedef struct { kiss_fft_scalar r; kiss_fft_scalar i; }kiss_fft_cpx; */
- #include "kiss_fft.h"
- #include <limits.h>
-+#include <string.h>
+--- sdlx/SConscript
++++ sdlx/SConscript
+@@ -12,7 +12,7 @@
- #define MAXFACTORS 32
- /* e.g. an fft of length 128 has 4 factors
-diff -ru btanks-0.8.7686.orig/mrt/export_base.h btanks-0.8.7686/mrt/export_base.h
---- btanks-0.8.7686.orig/mrt/export_base.h 2008-01-09 06:14:14.000000000 -0500
-+++ btanks-0.8.7686/mrt/export_base.h 2009-01-23 02:16:58.000000000 -0500
-@@ -1,7 +1,7 @@
- #ifndef MRT_EXPORT_MACRO_H__
- #define MRT_EXPORT_MACRO_H__
+ env.MergeFlags(sdl_cflags, sdl_libs)
--// Shared library support
-+/* Shared library support */
- #ifdef _WINDOWS
+-libs = ['mrt', 'SDL', 'SDL_image']
++libs = ['mrt', 'SDL', 'SDL_image', 'SDL_gfx']
- # pragma warning(disable:4251) /* needs to have dll-interface used by client */
-diff -ru btanks-0.8.7686.orig/mrt/tclUniData.c btanks-0.8.7686/mrt/tclUniData.c
---- btanks-0.8.7686.orig/mrt/tclUniData.c 2008-08-15 03:44:45.000000000 -0400
-+++ btanks-0.8.7686/mrt/tclUniData.c 2009-01-23 02:15:29.000000000 -0500
-@@ -880,7 +880,7 @@
- FINAL_QUOTE_PUNCTUATION,
- OTHER_PUNCTUATION,
- MATH_SYMBOL,
-- CURRENCY_SYMBOL,
-+ LCURRENCY_SYMBOL,
- MODIFIER_SYMBOL,
- OTHER_SYMBOL
- };
-diff -ru btanks-0.8.7686.orig/sdlx/gfx/SDL_rotozoom.c btanks-0.8.7686/sdlx/gfx/SDL_rotozoom.c
---- btanks-0.8.7686.orig/sdlx/gfx/SDL_rotozoom.c 2008-09-02 06:43:34.000000000 -0400
-+++ btanks-0.8.7686/sdlx/gfx/SDL_rotozoom.c 2009-01-23 02:18:37.000000000 -0500
-@@ -153,7 +153,7 @@
- * Advance destination pointer
- */
- dp++;
-- } // dst x loop
-+ } /* dst x loop */
-
- /* next box-y */
- sp = (Uint8 *)((Uint8*)osp + src->pitch*factory);
-@@ -739,7 +739,7 @@
- }
- break;
-
-- case 2: // rotated 180 degrees clockwise
-+ case 2: /* rotated 180 degrees clockwise */
- {
- Uint32* srcBuf = NULL;
- Uint32* dstBuf = NULL;
-@@ -751,8 +751,8 @@
- *dstBuf = *srcBuf;
- ++srcBuf;
- --dstBuf;
-- } // for(col)
-- } // for(row)
-+ }
-+ }
- }
- break;
-
-@@ -768,17 +768,16 @@
- *dstBuf = *srcBuf;
- ++srcBuf;
- dstBuf -= pSurfOut->pitch/4;
-- } // for(col)
-- } // for(row)
-+ }
-+ }
- }
- break;
-- } // switch
-+ }
-
- SDL_UnlockSurface(pSurf);
- SDL_UnlockSurface(pSurfOut);
-- } // if numClockwiseTurns > 0
-+ }
- else {
-- // simply copy surface to output
- if(SDL_BlitSurface(pSurf, NULL, pSurfOut, NULL)) {
- return NULL;
- }
-diff -ru btanks-0.8.7686.orig/sdlx/wrappers/glSDL.c btanks-0.8.7686/sdlx/wrappers/glSDL.c
---- btanks-0.8.7686.orig/sdlx/wrappers/glSDL.c 2008-05-29 05:54:00.000000000 -0400
-+++ btanks-0.8.7686/sdlx/wrappers/glSDL.c 2009-01-23 02:17:48.000000000 -0500
+ if sys.platform != "win32":
+ c_map_env= env.Clone()
+@@ -34,7 +34,6 @@
+ sdlx_sources = ['cursor.cpp', 'sdl_ex.cpp', 'surface.cpp', 'system.cpp', 'joystick.cpp',
+ 'thread.cpp', 'mutex.cpp', 'semaphore.cpp', 'color.cpp',
+ c_map, 'font.cpp', 'timer.cpp', 'module.cpp', 'file_rw.cpp',
+- 'gfx/SDL_rotozoom.c',
+ ] # 'ttf.cpp',
+
+ if sys.platform == 'win32':
+--- sdlx/surface.cpp
++++ sdlx/surface.cpp
+@@ -430,7 +430,7 @@
+ throw_sdl(("SDL_SetColorKey"));
+ }
+
+-#include "gfx/SDL_rotozoom.h"
++#include <SDL_rotozoom.h>
+
+ void Surface::rotozoom(const sdlx::Surface &src, double angle, double zoom, bool smooth) {
+ if (src.isNull())
+--- sdlx/wrappers/glSDL.c
++++ sdlx/wrappers/glSDL.c
@@ -11,8 +11,6 @@
#ifdef HAVE_OPENGL