summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-23 21:23:51 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-23 21:23:51 +0000
commit8c7ab1a3ffd4cde852aa32cb421a2d39e14af204 (patch)
treecb391ea7badeae6468ec94a7575e4731e7f43d31 /games-action
parentuse unpack_zip from unpacker.eclass (diff)
downloadgentoo-2-8c7ab1a3ffd4cde852aa32cb421a2d39e14af204.tar.gz
gentoo-2-8c7ab1a3ffd4cde852aa32cb421a2d39e14af204.tar.bz2
gentoo-2-8c7ab1a3ffd4cde852aa32cb421a2d39e14af204.zip
use unpack_zip from unpacker.eclass
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/beathazardultra/ChangeLog6
-rw-r--r--games-action/beathazardultra/beathazardultra-20130308.ebuild8
2 files changed, 8 insertions, 6 deletions
diff --git a/games-action/beathazardultra/ChangeLog b/games-action/beathazardultra/ChangeLog
index 3280c4acc653..ee0f0e2de202 100644
--- a/games-action/beathazardultra/ChangeLog
+++ b/games-action/beathazardultra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/beathazardultra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/beathazardultra/ChangeLog,v 1.1 2013/03/21 21:53:04 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/beathazardultra/ChangeLog,v 1.2 2013/03/23 21:23:51 hasufell Exp $
+
+ 23 Mar 2013; Julian Ospald <hasufell@gentoo.org>
+ beathazardultra-20130308.ebuild:
+ use unpack_zip from unpacker.eclass
*beathazardultra-20130308 (21 Mar 2013)
diff --git a/games-action/beathazardultra/beathazardultra-20130308.ebuild b/games-action/beathazardultra/beathazardultra-20130308.ebuild
index 09e3c9719cfc..45accd2751f6 100644
--- a/games-action/beathazardultra/beathazardultra-20130308.ebuild
+++ b/games-action/beathazardultra/beathazardultra-20130308.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/beathazardultra/beathazardultra-20130308.ebuild,v 1.2 2013/03/22 21:30:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/beathazardultra/beathazardultra-20130308.ebuild,v 1.3 2013/03/23 21:23:50 hasufell Exp $
# TODO: unbundle allegro on amd64 when multilib support
EAPI=5
-inherit eutils games
+inherit eutils unpacker games
DESCRIPTION="Intense music-driven arcade shooter powered by your music"
HOMEPAGE="http://www.coldbeamgames.com/"
@@ -53,9 +53,7 @@ pkg_nofetch() {
}
src_unpack() {
- # self unpacking zip archive; unzip warns about the exe stuff
- unzip -q "${DISTDIR}"/${A}
- [[ $? -gt 1 ]] && die "unpacking failed"
+ unpack_zip ${A}
}
src_prepare() {