summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-02 10:47:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-02 10:47:13 +0000
commit9488f02aeedd5343e4139071370c9ff9aa3874e5 (patch)
tree5cee546ea4973823eaa5ef295bfc5d781c025bbf /games-action
parentAdd network-uri to depends (bug #532550 by Helmut Jarausch). (diff)
downloadgentoo-2-9488f02aeedd5343e4139071370c9ff9aa3874e5.tar.gz
gentoo-2-9488f02aeedd5343e4139071370c9ff9aa3874e5.tar.bz2
gentoo-2-9488f02aeedd5343e4139071370c9ff9aa3874e5.zip
EAPI 4
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/transcend/ChangeLog13
-rw-r--r--games-action/transcend/transcend-0.3.ebuild17
2 files changed, 17 insertions, 13 deletions
diff --git a/games-action/transcend/ChangeLog b/games-action/transcend/ChangeLog
index e500b47f6249..5c8ebe94eb1a 100644
--- a/games-action/transcend/ChangeLog
+++ b/games-action/transcend/ChangeLog
@@ -1,17 +1,20 @@
# ChangeLog for games-action/transcend
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.8 2011/04/26 07:08:48 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.9 2015/01/02 10:47:13 tupone Exp $
+
+ 02 Jan 2015; Tupone Alfredo <tupone@gentoo.org> transcend-0.3.ebuild:
+ EAPI 4
26 Apr 2011; Tupone Alfredo <tupone@gentoo.org> transcend-0.3.ebuild:
- Fixed build. Bug #362999 by Diego Elio Pettenò
+ Fixed build. Bug #362999 by Diego Elio Pettenò
- 16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> transcend-0.3.ebuild:
+ 16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> transcend-0.3.ebuild:
virtual/glut -> media-libs/glut
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> transcend-0.3.ebuild:
Removing old virtual/x11 dependency.
- 22 Nov 2006; Piotr Jaroszyński <peper@gentoo.org> transcend-0.3.ebuild:
+ 22 Nov 2006; Piotr Jaroszyński <peper@gentoo.org> transcend-0.3.ebuild:
Add ~amd64 wrt bug #155890.
28 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
diff --git a/games-action/transcend/transcend-0.3.ebuild b/games-action/transcend/transcend-0.3.ebuild
index 59c6f56ff55a..b4fce67e0825 100644
--- a/games-action/transcend/transcend-0.3.ebuild
+++ b/games-action/transcend/transcend-0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.7 2011/04/26 07:11:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.8 2015/01/02 10:47:13 tupone Exp $
-EAPI=2
+EAPI=4
inherit games
DESCRIPTION="retro-style, abstract, 2D shooter"
@@ -19,6 +19,7 @@ DEPEND="x11-libs/libXmu
virtual/opengl
virtual/glu
media-libs/freeglut"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/Transcend_${PV}_UnixSource/Transcend
@@ -42,22 +43,22 @@ src_prepare() {
src_configure() {
cd portaudio
- egamesconf || die
+ egamesconf --enable-dependency-tracking
}
src_compile() {
cd portaudio
- emake
+ nonfatal emake
cd ../game
- emake || die
+ emake
cd ..
cp game/Transcend ${PN} || die "cp failed"
}
src_install() {
- dogamesbin ${PN} || die "dogamesbin failed"
+ dogamesbin ${PN}
insinto "${GAMES_DATADIR}/${PN}"
- doins -r levels/ || die "doins failed"
+ doins -r levels/
dodoc doc/how_to_*.txt
prepgamesdirs
}