summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-23 21:20:31 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-23 21:20:31 +0000
commitace482a30c4cee8d735d6eb872799c201489d87b (patch)
tree4a0f9cea81d516232a6404d671508dd3b2d6e0f5 /games-action
parentadd unpack_zip function to unpacker.eclass wrt #462612 (diff)
downloadgentoo-2-ace482a30c4cee8d735d6eb872799c201489d87b.tar.gz
gentoo-2-ace482a30c4cee8d735d6eb872799c201489d87b.tar.bz2
gentoo-2-ace482a30c4cee8d735d6eb872799c201489d87b.zip
use unpack_zip from unpacker.eclass
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/super-hexagon/ChangeLog5
-rw-r--r--games-action/super-hexagon/super-hexagon-15.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/games-action/super-hexagon/ChangeLog b/games-action/super-hexagon/ChangeLog
index 1c0ea7f261ff..35c1c404f8b6 100644
--- a/games-action/super-hexagon/ChangeLog
+++ b/games-action/super-hexagon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/super-hexagon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.1 2013/03/21 21:58:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/ChangeLog,v 1.2 2013/03/23 21:20:31 hasufell Exp $
+
+ 23 Mar 2013; Julian Ospald <hasufell@gentoo.org> super-hexagon-15.ebuild:
+ use unpack_zip from unpacker.eclass
*super-hexagon-15 (21 Mar 2013)
diff --git a/games-action/super-hexagon/super-hexagon-15.ebuild b/games-action/super-hexagon/super-hexagon-15.ebuild
index 97e27ce23015..770073978776 100644
--- a/games-action/super-hexagon/super-hexagon-15.ebuild
+++ b/games-action/super-hexagon/super-hexagon-15.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.2 2013/03/22 21:31:22 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/super-hexagon/super-hexagon-15.ebuild,v 1.3 2013/03/23 21:20:31 hasufell Exp $
EAPI=5
-inherit eutils games
+inherit eutils unpacker games
DESCRIPTION="A minimal action game by Terry Cavanagh, with music by Chipzel"
HOMEPAGE="http://www.superhexagon.com/"
@@ -51,9 +51,7 @@ pkg_nofetch() {
}
src_unpack() {
- # self unpacking zip archive; unzip warns about the exe stuff
- unzip -q "${DISTDIR}"/${A}
- [[ $? -gt 1 ]] && die "unpacking failed"
+ unpack_zip ${A}
}
src_prepare() {