summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-12-26 16:16:27 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-12-26 16:16:27 +0000
commitd1c31442af7e6a35acb38c3f98af756c8d0943bc (patch)
tree4be42fcfbeecf7e8682ba629fd7c9ff375694409 /games-action
parentStable for x86, wrt bug #375655 (diff)
downloadgentoo-2-d1c31442af7e6a35acb38c3f98af756c8d0943bc.tar.gz
gentoo-2-d1c31442af7e6a35acb38c3f98af756c8d0943bc.tar.bz2
gentoo-2-d1c31442af7e6a35acb38c3f98af756c8d0943bc.zip
Use QA_PREBUILT. Bug #430982
(Portage version: 2.1.11.38/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/mutantstorm-demo/ChangeLog5
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/games-action/mutantstorm-demo/ChangeLog b/games-action/mutantstorm-demo/ChangeLog
index d456a7b25968..a1c6c237a108 100644
--- a/games-action/mutantstorm-demo/ChangeLog
+++ b/games-action/mutantstorm-demo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/mutantstorm-demo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.13 2012/02/08 21:28:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.14 2012/12/26 16:16:27 tupone Exp $
+
+ 26 Dec 2012; Tupone Alfredo <tupone@gentoo.org> mutantstorm-demo-1.33.ebuild:
+ Use QA_PREBUILT. Bug #430982 by Diego Elio Pettenò
08 Feb 2012; Mike Frysinger <vapier@gentoo.org> mutantstorm-demo-1.33.ebuild:
Move to new unpacker eclass for unpack_makeself.
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
index 4c5cc71ee485..b85324b93cab 100644
--- a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.13 2012/02/08 21:28:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.14 2012/12/26 16:16:27 tupone Exp $
+EAPI=4
inherit eutils unpacker games
@@ -28,20 +29,21 @@ S=${WORKDIR}
dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/mutantstorm-bin"
src_install() {
insinto "${dir}"
- doins -r menu script styles || die "doins failed"
+ doins -r menu script styles
exeinto "${dir}"
- doexe bin/Linux/x86/* || die "doexe failed"
+ doexe bin/Linux/x86/*
# Remove libSDL since we use the system version and our version doesn't
# have TEXTRELs in it.
rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
games_make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
insinto "${dir}"
- doins README.txt buy_me mutant.xpm pompom readme.htm || die "doins failed"
+ doins README.txt buy_me mutant.xpm pompom readme.htm
prepgamesdirs
}