summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-29 23:31:25 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-29 23:31:25 +0000
commitdbe2f1922953cfa70d09c5a9d5cc7e4dec4da33f (patch)
treeea211693f5cff3d106f230a9c101d99ab6f40aea /games-action
parentFDisable doc generation because of missing doxygen files, bug #509052 (diff)
downloadgentoo-2-dbe2f1922953cfa70d09c5a9d5cc7e4dec4da33f.tar.gz
gentoo-2-dbe2f1922953cfa70d09c5a9d5cc7e4dec4da33f.tar.bz2
gentoo-2-dbe2f1922953cfa70d09c5a9d5cc7e4dec4da33f.zip
fix build with mesa-10.x wrt #504104
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/supertuxkart/ChangeLog6
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.8.1-mesa-10.x.patch38
-rw-r--r--games-action/supertuxkart/supertuxkart-0.8.1.ebuild4
3 files changed, 45 insertions, 3 deletions
diff --git a/games-action/supertuxkart/ChangeLog b/games-action/supertuxkart/ChangeLog
index 5b40532af9bd..58cfa794e03d 100644
--- a/games-action/supertuxkart/ChangeLog
+++ b/games-action/supertuxkart/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/supertuxkart
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.42 2014/03/18 18:43:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/ChangeLog,v 1.43 2014/04/29 23:31:25 hasufell Exp $
+
+ 29 Apr 2014; Julian Ospald <hasufell@gentoo.org> supertuxkart-0.8.1.ebuild,
+ +files/supertuxkart-0.8.1-mesa-10.x.patch:
+ fix build with mesa-10.x wrt #504104
18 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/supertuxkart-0.8-desktopfile.patch,
diff --git a/games-action/supertuxkart/files/supertuxkart-0.8.1-mesa-10.x.patch b/games-action/supertuxkart/files/supertuxkart-0.8.1-mesa-10.x.patch
new file mode 100644
index 000000000000..b4d8e68a9049
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-0.8.1-mesa-10.x.patch
@@ -0,0 +1,38 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Apr 29 23:28:11 UTC 2014
+Subject: fix build with mesa-10.x
+
+--- lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h
++++ lib/irrlicht/source/Irrlicht/COpenGLExtensionHandler.h
+@@ -21,6 +21,7 @@
+ #endif
+ #include <GL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #include "wglext.h"
+@@ -36,6 +37,7 @@
+ #endif
+ #include <OpenGL/gl.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #endif
+ #elif defined(_IRR_COMPILE_WITH_SDL_DEVICE_) && !defined(_IRR_COMPILE_WITH_X11_DEVICE_)
+@@ -49,6 +51,7 @@
+ #define NO_SDL_GLEXT
+ #include <SDL/SDL_video.h>
+ #include <SDL/SDL_opengl.h>
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #else
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
+@@ -61,6 +64,7 @@
+ #include <GL/gl.h>
+ #include <GL/glx.h>
+ #if defined(_IRR_OPENGL_USE_EXTPOINTER_)
++ typedef void (APIENTRYP PFNGLBLENDEQUATIONPROC) (GLenum mode);
+ #include "glext.h"
+ #undef GLX_ARB_get_proc_address // avoid problems with local glxext.h
+ #include "glxext.h"
diff --git a/games-action/supertuxkart/supertuxkart-0.8.1.ebuild b/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
index 9694ba50af1b..32fe3b170215 100644
--- a/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
+++ b/games-action/supertuxkart/supertuxkart-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.1.ebuild,v 1.4 2014/03/12 05:18:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/supertuxkart/supertuxkart-0.8.1.ebuild,v 1.5 2014/04/29 23:31:25 hasufell Exp $
EAPI=5
inherit gnome2-utils cmake-utils eutils games
@@ -41,7 +41,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/SuperTuxKart-${PV}
src_prepare() {
- epatch "${FILESDIR}"/${P}-{gentoo,icon-dest,irrlicht,desktopfile}.patch
+ epatch "${FILESDIR}"/${P}-{gentoo,icon-dest,irrlicht,desktopfile,mesa-10.x}.patch
# inconsistent handling of debug definition
# avoid using Debug build type