summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-24 06:46:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-24 06:46:41 +0000
commitfd2d2f5fce87b7e38d0191c16602f7f2259c9c83 (patch)
treee15007666a43e9f13dfdba2269f56ac3bf0254da /games-action
parentlet the package handle LFS itself rather than forcing it via flag-o-matic #28... (diff)
downloadgentoo-2-fd2d2f5fce87b7e38d0191c16602f7f2259c9c83.tar.gz
gentoo-2-fd2d2f5fce87b7e38d0191c16602f7f2259c9c83.tar.bz2
gentoo-2-fd2d2f5fce87b7e38d0191c16602f7f2259c9c83.zip
version bump (bug #167339)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/d1x-rebirth/ChangeLog10
-rw-r--r--games-action/d1x-rebirth/d1x-rebirth-0.55.1.ebuild102
2 files changed, 110 insertions, 2 deletions
diff --git a/games-action/d1x-rebirth/ChangeLog b/games-action/d1x-rebirth/ChangeLog
index 36af53740f8a..21b3f878711b 100644
--- a/games-action/d1x-rebirth/ChangeLog
+++ b/games-action/d1x-rebirth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/d1x-rebirth
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d1x-rebirth/ChangeLog,v 1.2 2007/01/10 17:40:02 wolf31o2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x-rebirth/ChangeLog,v 1.3 2009/08/24 06:46:41 mr_bones_ Exp $
+
+*d1x-rebirth-0.55.1 (24 Aug 2009)
+
+ 24 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +d1x-rebirth-0.55.1.ebuild:
+ version bump (bug #167339)
10 Jan 2007; Chris Gianelloni <wolf31o2@gentoo.org>
d1x-rebirth-0.50.ebuild:
diff --git a/games-action/d1x-rebirth/d1x-rebirth-0.55.1.ebuild b/games-action/d1x-rebirth/d1x-rebirth-0.55.1.ebuild
new file mode 100644
index 000000000000..6be60b443a22
--- /dev/null
+++ b/games-action/d1x-rebirth/d1x-rebirth-0.55.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x-rebirth/d1x-rebirth-0.55.1.ebuild,v 1.1 2009/08/24 06:46:41 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DV=1
+DESCRIPTION="Descent Rebirth - enhanced Descent ${DV} engine"
+HOMEPAGE="http://www.dxx-rebirth.de/"
+SRC_URI="mirror://sourceforge/dxx-rebirth/${PN}_v${PV}-src.tar.gz
+ http://www.dxx-rebirth.com/download/dxx/res/d1xrdata.zip
+ http://www.dxx-rebirth.com/download/dxx/res/dxx-rebirth_icons.zip
+ timidity? ( http://www.dxx-rebirth.com/download/dxx/res/descent${DV/1}_midi.zip )
+ cdinstall? ( http://www.dxx-rebirth.com/download/dxx/res/d1datapt.zip )
+ linguas_de? ( http://www.dxx-rebirth.com/download/dxx/res/D${DV}XBDE01.zip )"
+
+LICENSE="D1X GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall ipv6 linguas_de opengl timidity"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ dev-games/physfs[hog,zip]
+ media-libs/libsdl
+ media-libs/sdl-mixer[timidity?]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/scons"
+
+S=${WORKDIR}/${PN}_v${PV}-src
+
+src_unpack() {
+ unpack ${PN}_v${PV}-src.tar.gz dxx-rebirth_icons.zip
+ use linguas_de && unpack D${DV}XBDE01.zip
+ if use cdinstall ; then
+ unpack d1datapt.zip
+ cdrom_get_cds descent/descent.hog
+ mkdir "${S}"/Data
+ cp \
+ ${CDROM_ROOT}/descent/descent.{hog,pig} \
+ ${CDROM_ROOT}/descent/chaos.{hog,msn} \
+ "${S}"/Data \
+ || die "cp failed"
+ fi
+}
+
+src_prepare() {
+ if use cdinstall ; then
+ cd Data
+ patch -p0 < "${WORKDIR}"/d1datapt/descent.hog.diff descent.hog
+ patch -p0 < "${WORKDIR}"/d1datapt/descent.pig.diff descent.pig
+ fi
+}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+
+ scons ${sconsopts} \
+ sharepath="${GAMES_DATADIR}/d${DV}x" \
+ sdlmixer=1 \
+ sdl_only=$(use opengl && echo 0 || echo 1)
+ ipv6=$(use ipv6 && echo 1 || echo 0)
+}
+
+src_install() {
+ dodoc INSTALL.txt README.txt
+ insinto "${GAMES_DATADIR}/d${DV}x"
+ doins "${DISTDIR}"/d1xrdata.zip || die
+ if use linguas_de ; then
+ doins "${WORKDIR}"/D${DV}XBDE01/D${DV}XbDE01/*.txb
+ fi
+ if use timidity ; then
+ doins "${DISTDIR}"/descent_midi.zip || die
+ fi
+ if use cdinstall ; then
+ doins Data/descent.{hog,pig} || die
+ insinto "${GAMES_DATADIR}"/d${DV}x/missions
+ doins Data/chaos.{hog,msn} || die
+ fi
+ doicon "${WORKDIR}/${PN}.xpm"
+
+ if use opengl ; then
+ newgamesbin d${DV}x-rebirth-gl d${DV}x-rebirth
+ else
+ newgamesbin d${DV}x-rebirth-sdl d${DV}x-rebirth
+ fi
+ make_desktop_entry d${DV}x-rebirth "Descent ${DV} Rebirth" ${PN}.xpm
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall ; then
+ echo
+ elog "You need to copy data-files from original Descent ${DV}"
+ elog "installation to ${GAMES_DATADIR}/d${DV}x. Please read "
+ elog "/usr/share/doc/${PF}/INSTALL.txt for more info."
+ echo
+ fi
+}