summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 22:01:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 22:01:07 +0000
commit3ea5daa8ec182e9ebbb174f7ea979ad8efee722e (patch)
tree7a25df0a01354d6ec140130ba039504f878c3dbd /games-arcade/gav
parentFix building with gcc-4.3 (diff)
downloadgentoo-2-3ea5daa8ec182e9ebbb174f7ea979ad8efee722e.tar.gz
gentoo-2-3ea5daa8ec182e9ebbb174f7ea979ad8efee722e.tar.bz2
gentoo-2-3ea5daa8ec182e9ebbb174f7ea979ad8efee722e.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-arcade/gav')
-rw-r--r--games-arcade/gav/ChangeLog8
-rw-r--r--games-arcade/gav/files/gav-0.9.0-gcc43.patch10
-rw-r--r--games-arcade/gav/gav-0.9.0.ebuild10
3 files changed, 22 insertions, 6 deletions
diff --git a/games-arcade/gav/ChangeLog b/games-arcade/gav/ChangeLog
index 424a29f178db..4d6a9a438ade 100644
--- a/games-arcade/gav/ChangeLog
+++ b/games-arcade/gav/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/gav
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/ChangeLog,v 1.13 2007/04/24 14:40:37 drizzt Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/ChangeLog,v 1.14 2008/04/30 22:01:06 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/gav-0.9.0-gcc43.patch, gav-0.9.0.ebuild:
+ Fix building with gcc-4.3
24 Apr 2007; Timothy Redaelli <drizzt@gentoo.org> gav-0.9.0.ebuild:
Add ~x86-fbsd keyword.
diff --git a/games-arcade/gav/files/gav-0.9.0-gcc43.patch b/games-arcade/gav/files/gav-0.9.0-gcc43.patch
new file mode 100644
index 000000000000..06bc1a5d2542
--- /dev/null
+++ b/games-arcade/gav/files/gav-0.9.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- Configuration.cpp
++++ Configuration.cpp
+@@ -25,6 +25,7 @@
+ #include <stdlib.h>
+ #include <string>
+ #include <iostream>
++#include <cstring>
+ #include "Configuration.h"
+ #include "ControlsArray.h"
+
diff --git a/games-arcade/gav/gav-0.9.0.ebuild b/games-arcade/gav/gav-0.9.0.ebuild
index 07d6ac2e7e78..8b1680588e36 100644
--- a/games-arcade/gav/gav-0.9.0.ebuild
+++ b/games-arcade/gav/gav-0.9.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/gav-0.9.0.ebuild,v 1.2 2007/04/24 14:40:37 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gav/gav-0.9.0.ebuild,v 1.3 2008/04/30 22:01:06 nyhm Exp $
inherit eutils games
@@ -35,6 +35,7 @@ src_unpack() {
cp ${d}/Makefile.Linux ${d}/Makefile || die "cp ${d}/Makefile failed"
done
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i \
-e "s:/usr/bin:${GAMES_BINDIR}:" \
-e "/strip/d" \
@@ -65,8 +66,9 @@ src_compile() {
src_install() {
dodir "${GAMES_BINDIR}"
- make ROOT="${D}" install || die "make install failed"
- cp -r sounds/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ emake ROOT="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r sounds || die "doins failed"
dodoc CHANGELOG README
prepgamesdirs
}